Post by ozbpohs » Wed May 15, 2019 1:01 am

Everything I've read over the past few weeks regarding upgrading Opencart from very old version to current, seems fraught with danger
I have offered to help freshen up someone's existing store. Have not had access to it yet so I only know that it was created a few years back so likely a very old version.

What is the risk of leaving her with the old version of Opencart and simply customizing a new theme?

Her existing site: www.sueshappytails.com
I'd used Opencart 3 to test a new theme but it comes in older versions www.billieraven.com/happytails

Newbie

Posts

Joined
Fri Apr 20, 2018 3:42 am

Post by straightlight » Wed May 15, 2019 1:23 am

What is the risk of leaving her with the old version of Opencart and simply customizing a new theme?
- Not being kept up-to-date with service providers changes
- Not updated with CSS / Bootstrap changes
- Not updated with jQuery adaptation code changes
- Not updated with the OC events structure
- Don't have additional features built-in from both ends - admin and store-front end

The rest goes to extension compatibility and custom codes.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Wed May 15, 2019 10:54 pm

- Not updated with CSS / Bootstrap changes
- Not updated with jQuery adaptation code changes
Well, it might depend of the exact OC Version used, but generally, neither
Bootstrap nor jQuery is a problem, since 1.5.6.x OC Versions will still work
with later Versions of Bootstrap Style and jQuery Code in full. And it only
takes one or two additional Files to change, to make it work with PHP7.2x.

Unfortunately, the Theme, shown below, is no longer available in the
OC Extension Section, but since it was released under GPL Open Source
Terms, I could spare one, if your OC Version is above OC v.1.5.5.x.

It would probably be the easiest way, to get 'responsive', in addition to
so use one of the few TOP NOTCH Performer Themes ever built.

Otherways, if you tend to move up, there would nothing be left, out
of your existing Installation, including the DB, usable again in a later
OC release, without spending a lot of time and even money, to get it
made work again.

But if your OC Version is still below v.1.5.6.x, I would at least install the
latest v.1.5.6.x Version available, just to make sure ... ;)

Merkent Theme powered v.1.5.6.5_rc Version, possibly not yet fully ready,
since I only installed it last night again, in order to build a 'basic' free
(risk-free ;) ) Version out of it
A slightly modified Version 1.5.6.5 can be seen here, equipped with that
Merkent Bootstrap Theme:
http://www.bigmax.ch/shop/

Just in case ...
Ernie
Last edited by IP_CAM on Tue Jul 14, 2020 5:15 pm, edited 1 time in total.

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Elevate » Mon Jul 08, 2019 1:28 am

The security risks of running old, non supported PHP versions is a huge risk. Atleast use Qphoria's upgrade service or work with a developer for further customization and upgrades.

ELEV8TE Website Development
https://www.elev8your.com


User avatar
New member

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by Denva » Tue Jul 14, 2020 3:22 am

IP_CAM wrote:
Wed May 15, 2019 10:54 pm
- Not updated with CSS / Bootstrap changes
- Not updated with jQuery adaptation code changes
Well, it might depend of the exact OC Version used, but generally, neither
Bootstrap nor jQuery is a problem, since 1.5.6.x OC Versions will still work
with later Versions of Bootstrap Style and jQuery Code in full. And it only
takes one or two additional Files to change, to make it work with PHP7.2x.

Unfortunately, the Theme, shown below, is no longer available in the
OC Extension Section, but since it was released under GPL Open Source
Terms, I could spare one, if your OC Version is above OC v.1.5.5.x.

It would probably be the easiest way, to get 'responsive', in addition to
so use one of the few TOP NOTCH Performer Themes ever built.
https://gtmetrix.com/reports/www.hitline.info/DCZy3Srs
Otherways, if you tend to move up, there would nothing be left, out
of your existing Installation, including the DB, usable again in a later
OC release, without spending a lot of time and even money, to get it
made work again.

But if your OC Version is still below v.1.5.6.x, I would at least install the
latest v.1.5.6.x Version available, just to make sure ... ;)

Merkent Theme powered v.1.5.6.5_rc Version, possibly not yet fully ready,
since I only installed it last night again, in order to build a 'basic' free
(risk-free ;) ) Version out of it:
http://www.hitline.info/shop/
A (hopefully still) older working and slightly modified Version 1.5.6.5 can
be seen here, equipped with that Merkent Bootstrap Theme:
http://www.bigmax.ch/shop/

Just in case ...
Ernie
---
Image
Please can you help me install the version 1.5.6.4 to my site ? i have a theme that i like i bought it 70$ and i dont want it to go waste

Newbie

Posts

Joined
Tue Jul 14, 2020 3:01 am

Post by johnp » Tue Jul 14, 2020 4:54 pm

There are plenty who could help you with an install. What theme do you have? There are many themes that I've tried that aren't worth the bother. Before you go ruining a nice OC install think this through.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by IP_CAM » Tue Jul 14, 2020 5:08 pm

Well, it's not that bad, as it might sound on first view, so far, OC v.1.5.6.4 has not
shown problems, when it comes to security. Still, better use OC v.1.5.6.5_rc,
it (inofficial) successor, if one likes to stay with 1.5.6.x, since it had a few minor
fixes, compared to 1.5.6.4.

And it only required one new File, (system/library/encryption.php), the same as
later OC Versions require, to function up to PHP v.7.x.x so far. So just download the
(already fixed) OC v.1.5.6.5_rc Version from here, and you will be ready, to use
your Theme:
https://github.com/IP-CAM/Opencart-1.5.6.5_RC
You could also use this encryption.php File content instead, to make sure, to
be able to use up to PHP v.7.4.7 Versions:

Code: Select all

<?php
final class Encryption {
	
	private $cipher = 'aes-256-ctr';
	private $digest = 'sha256';
	private $key;
	
	public function __construct($key) {
		$this->key = $key;
	}

	public function encrypt($value) {
		$key       = openssl_digest($this->key, $this->digest, true);
		$iv_length = openssl_cipher_iv_length($this->cipher);
		$iv        = openssl_random_pseudo_bytes($iv_length);
		return base64_encode($iv . openssl_encrypt($value, $this->cipher, $key, OPENSSL_RAW_DATA, $iv));
	}
	
	public function decrypt($value) {
		$key       = openssl_digest($this->key, $this->digest, true);
		$iv_length = openssl_cipher_iv_length($this->cipher);
		$value     = base64_decode($value);
		$iv        = substr($value, 0, $iv_length);
		$value     = substr($value, $iv_length);
		return openssl_decrypt($value, $this->cipher, $key, OPENSSL_RAW_DATA, $iv);
	}
}
?>
Ernie
Last edited by IP_CAM on Tue Jul 14, 2020 5:34 pm, edited 1 time in total.

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by johnp » Tue Jul 14, 2020 5:20 pm

Yes an upgrade is recommended but I like other pros have clients who won't spend the required £££s. For those I use:

OC1.5.6.5_rc
Vqmod 2.6.3
PHP7.x
OC Bootstrap Pro theme

When push comes to shove they'll have to bite the bullet and upgrade but at the moment the above is a stable and reliable model. I normally add a couple of protection scripts to block bad traffic and stop SQL injection attacks. Basically, it works and is cheap.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service £££ - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at https://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by Elevate » Fri Jul 31, 2020 3:28 am

IP_CAM wrote:
Wed May 15, 2019 10:54 pm
- Not updated with CSS / Bootstrap changes
- Not updated with jQuery adaptation code changes
Well, it might depend of the exact OC Version used, but generally, neither
Bootstrap nor jQuery is a problem, since 1.5.6.x OC Versions will still work
with later Versions of Bootstrap Style and jQuery Code in full. And it only
takes one or two additional Files to change, to make it work with PHP7.2x.

Just in case ...
Ernie
Ernie,
You need to quick misleading users. Sure, the older versions of bootstrap and jquery 'work'. However, there are plenty of vulnerabilities that put shop owners and their customers at risk. This is 2020 and it's time to let go of the 1.5.x and even the 2.x branches.

https://snyk.io/vuln/npm:bootstrap

https://snyk.io/vuln/npm:jquery

ELEV8TE Website Development
https://www.elev8your.com


User avatar
New member

Posts

Joined
Fri Jul 06, 2018 12:40 am
Location - Denver, Colorado, USA

Post by IP_CAM » Fri Jul 31, 2020 8:54 am

However, there are plenty of vulnerabilities that put shop owners and their
customers at risk. This is 2020 and it's time to let go of the 1.5.x and even the 2.x branches.
RISK:
Well, then show me one of those vulnerabilities, it's as easy as that. :laugh:
My Sites get hit on a daily bases, by those, trying to get them down, but so far,
it only forced me, to add IP Ranges to my 1'900+ locked out IP-Ranges already,
and for me, that's the best proof, that noone yet found a way, to get in. To me,
it's more a Game, because I never planned, to run a real Shop in the first Place.

To OC-3:
For about 3 Years, it's still the same Main Version, and I would have been forced,
to upgrade 10+ times, and look around for new Mods, instead of using something,
already proven to work in full. Not to mention the already great existing Amount
of free Extensions. OC-3 also had some problems with PHP-7.x Versions, but my
Version only needed a different encryption.php File, to do it's job up to PHP v.7.4.7
so far, that's all my Hoster offers per now.

So, just be reasonable, and accept the Fact, that v.1.5.6.5_rc really was an ultimate
Version Solution, it just required a decent Bootstrap Theme, to so work up to
Font Awesome v.5.14.0 and Bootstrap v.4.5.0 without the slightest problem. So,
strictly technically, not one good reason exists, to replace it, as long as nothing
comparable exists, based on simple and transparent code, among lot's of wisdom.

Like it or not, it's not my fault. Still, strictly from the Business Point of View, I fully
understand your Arguments, but since I don't create income from/with OC, it's
not my problem either. And as long as 1.5.6.x Extensions are offered officially,
even new one's, OC does not seem to care much about removing it from OC Earth.

And if more of you Fellow-Dev's would have assisted OC on OC-Github during the
past 2 Years, there would be no need, to keep an Oldie alive ... :laugh:
And less v.3.x Versions would probably need to exist, because of that ...
Ernie
---
Image

Attachments

oc_versions.jpg

oc_versions.jpg (164.15 KiB) Viewed 454 times


Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 8 guests