Post by caraban2 » Fri Aug 23, 2019 4:26 pm

Hola a todos, tengo instalada la version 3.0.3.2 y al hacer pruebas de compra veo que no envía notificaciones ni correos al cliente ni al propietario de la tienda.... Necesito ayuda urgente !!
Last edited by caraban2 on Thu Aug 29, 2019 6:19 pm, edited 3 times in total.

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Fri Aug 23, 2019 10:50 pm

Hola @caraban2.

¿Dices que no envía notificaciones o no envía correos en absoluto. ? Pueden ser cosas diferentes de acuerdo a como se entienda.

Puedes ver si el sistema envía correos usando la herramienta de Marketing > Emails desde la administración y enviando a algún cliente de prueba.

Si el caso es que no envia correos:

De otra forma, comprueba los ajustes en Configuración > Tienda > Pestaña "Correo". Probablemente tu servidor no tenga habilitado para que envies emails usando la función PHP, y debas entonces configurar una pasarela SMTP. Si ya tienes configurado una pasarela SMTP, entonces es evidente que tienes problemas con ellas.

===

O si prefieres una opción más versatil, nosotros hemos desarrollado una integración con Mailgun, que comprando la extensión, podemos darte apoyo en la configuración.

https://www.opencart.com/index.php?rout ... _id=31115

Un saludo.

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Sat Aug 24, 2019 2:59 am

Hola Daniel, muchas gracias por contestar tan rápido.... A ver, el sistema debería enviar un mail cuando se da de alta un posible cliente, o cuando se hace un pedido, o cuando se modifica el estatus de un pedido, pues bien, no hace nada de nada, no envía nada, he probado con los parámetros del hosting en SMTP y nada.... he probado a poner Correo y que se envíe a mi cuenta de Gmail, y nada, no envía nada de nada,

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by caraban2 » Sat Aug 24, 2019 3:10 am

Daniel, yo ahora no puedo pagar 60 dolares, pues no he empezado a generar ventas todavia....
Ademas veo que no es compatible con la versión que utilizo...
Last edited by caraban2 on Fri Aug 30, 2019 3:52 am, edited 1 time in total.

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by caraban2 » Sat Aug 24, 2019 3:38 am

Intente enviar desde Marqueting y sale esto.......

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html>< head>
<title> 403 Forbidden</h1>
</head><body>
<h1>Forbidden </h1>
<p>Tou don't have permission to acces /admin/index.php
on this server.<br />
</p>
</body></html>
es un menseje de error que no tengo la menor isea de que significa...

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by caraban2 » Mon Aug 26, 2019 7:43 pm

Hola, he cambiado a las recomendaciones que me dijeron en el proveedor de host y tampoco funciona..... me sale este error.....

Attachments

mensaje error-2.jpg

mensaje error-2.jpg (129.04 KiB) Viewed 1471 times


Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by caraban2 » Thu Aug 29, 2019 6:16 pm

Tendré que desistir de poner la web en funcionamiento si nadie puede ayudarme. es una pena ya que en las versiones anteriores si funcionaba el correo, y creo que no es difícil, pero para quien sabe hacerlo.....
De cualquier forma, muchas gracias a todas las personas que han intentado ayudarme en otros momentos.....

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Sat Aug 31, 2019 10:32 pm

Hola @caraban2.

Veo que muchos usuarios han intentado ayudarte pero no has seguido instrucciones para determinar cual es tu problema.


Por ejemplo: @paulfeakins, te sugirió que hicieras la siguiente prueba para determinar si tu servidor envía o no correos usando la función nativa de php mail().

viewtopic.php?f=202&t=213478&p=763152#p763141

¿Lo has hecho, o quizas no entiendes como hacerla y porque te ha sugerido hacer esto?

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Sat Aug 31, 2019 10:51 pm

A ver Daniel, yo no soy programador, si me dicen que hay que hacer, pero no me dicen como ni donde, sigo perdido, he probado lo que me habeis dicho y que he entendido, y no ha funcionado nada.
Por otra parte, no he instalado nada fuera de OC, solamente la traducción a Español, y un programa para importar exportar archivos de excel.... que lo utilizo para subir los datos de los productos.....
Tampoco me funciona en otra web que tengo con la misma version de OC la 3.0.3.0
Si no soluciono esto, no podre poner en marcha la web, es fundamental....

Esa funcion nativa de PHP, donde debo insertarla, o como la hago funcionar ?

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Sat Aug 31, 2019 11:41 pm

Hola @caraban2

Lo que vamos a hacer es verificar si funciona la función nativa de PHP Mail en tu servidor:

https://www.php.net/manual/es/function.mail.php

Para ello:

1. Copia este código en un fichero php.

Code: Select all

<?php
// the message
$msg = "First line of text\nSecond line of text";

// use wordwrap() if lines are longer than 70 characters
$msg = wordwrap($msg,70);

// send email
mail("someone@example.com","My subject",$msg);
?>
2. Reemplaza "someone@example.com" con tu correo.
3. Guardalo en un fichero con nombre test.php
4. Subelo a tu servidor.
5. Ve al navegador y ejecuta la URL donde han guardado ese fichero. Si lo has subido en la raíz publica del servidor, sera entonces "tudominio.com/test.php"
6. Revisa si recibes el correo en tu bandeja de entrada de la dirección que has indicado.
7. Revisa si el correo no esta en span o correo no deseado también.

Si no lo recibes no tienes acceso a la función de php mail, habla con la gente de tu servidor y pide "que necesitas que habiliten la posibilidad de enviar correos usando php mail".

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Wed Sep 04, 2019 8:37 pm

Hola, hecho lo que me dijiste y sale este error....
Esta página no funciona La página www.tintaston.es no puede procesar esta solicitud ahora.
HTTP ERROR 500

Revisado el archivo y comprobando que esta tal cual me has dicho, la pagina se queda en blanco......

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by caraban2 » Thu Sep 05, 2019 12:37 am

En el host me dicen esto......

Buenas tardes José,

La función mail() de PHP está habilitada para ser usada en el alojamiento.

No obstante, existen muchas posibilidades de que dichos correos sean marcados como SPAM al ser enviados desde hostingsrv65.dondominio.com en vez de tu cuenta de correo. Ten en cuenta que no se están enviando desde el servicio de correo, sino desde el servicio de hosting. Realmente estás haciéndote pasar por una cuenta de correo que no ha enviado el correo electrónico.

En el caso de que el uso de SMTP no sea realizado de forma correcta por parte del algún plugin o tema, te recomendamos encarecidamente utilizar una alternativa.

Saludos,

No entiendo este galimatias.....

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Thu Sep 05, 2019 9:26 pm

Hola @caraban2.

1. Lo del error 500 con toda seguridad debes haber hecho algo mal cuando has modificado el correo o hecho la prueba. Yo he probado con las instrucciones que te he dado y no tiene ningún problema para devolverte un error 500.

2. Con respecto a lo que te dicen del servidor. No se que pensar. Si ellos dicen que tienes la función activa; entonces activa el envio de correos por protocolo de correo y no de SMTP, en Sistema > Tienda > Pestaña Correos. Y deberia de funcionar. Aun con la posibilidad de recibirlos en tu bandeja de span, deberia de funcionar. Sino , quien sabe que tipo de problema puedes tener en tu tienda.

Mi consejo: Contrata a alguien que sepa manejar esto y que te arregle el problema o realiza cursos y obtén formación en esto de administrar tiendas y programación.

Sencillamente, y sin ninguna intención de que te sientas mal por lo que digo, no es posible para mi ayudar a alguien que no tiene los conocimientos mínimos necesarios. No se si lo sabes, pero nadie cobra por prestar ayuda en estos foros. Y por mi parte, solo puedo dedicar un estrecho margen de tiempo a orientar a otros usuarios. Llevar una tienda no es magia, y ponerla en funcionamiento es solo uno de los primeros pasos que se requiere para tener un negocio online con éxito.

Por mi parte no puedo ayudar más, quizas otro usuario pueda atenderte con el detalle que requieres.

Un saludo.

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Thu Sep 05, 2019 10:33 pm

Gracias Daniel de todos formas, entiendo que no puedas dedicarle mas tiempo, y sobre todo porque eres el que mas ha tratado de ayudarme, quizas tengas razon en cuanto a que algo se ha hecho mal, ya que he probado con todo lo que me han dicho, pero no hemos dado con la solucion al problema, y asi no puedo poner la tienda en marcha....
Lo que si que piendo es que con las versiones antiguas, tanto de OC como de PHP, si que funcionaba bien, eso es lo que no entiendo...

Un gran saludo

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Thu Sep 05, 2019 10:39 pm

Una cosa se me ha ocurrido ahora.

Puedes revisar en tu tienda, en el admin, menu principal, Extensiones > Eventos e indicarme que numero de registros tienes en esa sección. ?

Un saludo.

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Fri Sep 06, 2019 8:01 pm

Tiene 33 eventos, y que contengan la palabra mail en total 17....

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm

Post by dharmawebstudio » Fri Sep 06, 2019 9:55 pm

Hola @caraban2.

Lo lamento, pero no va a ser esto entonces.
Tienes el número correcto de eventos registrados.

Un saludo.

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain

Post by caraban2 » Sat Sep 07, 2019 12:31 am

Pues ya no se que hacer..... a no ser que desactive el antivirus

Active Member

Posts

Joined
Mon Oct 29, 2012 9:38 pm
Who is online

Users browsing this forum: No registered users and 8 guests