Post by valdas » Sat Jul 20, 2019 10:00 pm

hi Q

I have installed this oc2.3.0.2 and after second time coming to step 6 I am getting the following error.

Fatal error: Uncaught Exception: Error: Unknown column 'order_id' in 'where clause'<br />Error No: 1054<br />DELETE FROM `vp_order_status_auto` WHERE order_id = '615' in /home/vpflower/public_html/system/library/db/mysqli.php:40 Stack trace: #0 /home/vpflower/public_html/vqmod/vqcache/vq2-system_storage_modification_system_library_db.php(110): DB\MySQLi->query('DELETE FROM `vp...', Array) #1 /home/vpflower/public_html/vqmod/vqcache/vq2-system_storage_modification_catalog_model_checkout_order.php(87): DB->query('DELETE FROM `vp...') #2 /home/vpflower/public_html/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(178): ModelCheckoutOrder->addOrder(Array) #3 /home/vpflower/public_html/system/engine/proxy.php(25): Loader->{closure}(Array, Array) #4 /home/vpflower/public_html/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_checkout_confirm.php(328): Proxy->__call('addOrder', Array) #5 /home/vpflower/public_html/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php(51): Cont in /home/vpflower/public_html/system/library/db/mysqli.php on line 40

Can you advise how to fix this? Thanks

Newbie

Posts

Joined
Sat Jul 20, 2019 9:54 pm

Post by cedcommerceteam » Tue Jul 23, 2019 5:43 pm

Hi Valdas,

Please check whether `order_id` exist in `vp_order_status_auto` table, if yes than add a check for `order_id` > 0 then Delete that order otherwise do not delete & show a message order doesn't exist.

I hope this will help you, if not then explain us l'll bit more.

Thanks & Regards :

Call us at : (+91) -8765210318 , Skype: live:carlmorgan.cedcommerce , Email: support@cedcommerce.com
CedCommerece : Officail Opencart Partners
CedCommerce Official : www.cedcommerce.com
Opencart Services : www.cedcommerce/opencart-services.com
Sell On various Marketplace Integration : Opencart-Extensions
Magenative Mobile App/IOS Development : magenative.com


User avatar
Active Member

Posts

Joined
Wed Aug 09, 2017 9:02 pm

Post by rlasmar » Wed Aug 07, 2019 3:13 am

Sometimes I get this error, only sometimes. I mean between 50 orders, I receive this error one or two times.

Code: Select all

PHP Notice:  Undefined variable: order_id
File: catalog/model/checkout/order.php

Opencart 3.0.3.2

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by rlasmar » Sat Dec 14, 2019 10:47 pm

Hi I am having problem using this extension with fields custom field. Opencart 3.0.3.2

In the checkout, When I choose to register a new shipping address, it changes the address correctly and shows everything right in front of the store.
I move on to finalize the order, so far so good.

however, within the order history in admin, it is showing the custom fields of the old address. it's like taking data from the previous session or getting something cached

Steps to reproduce this error:
1. Go to checkout step 6 payment confirmation
2. Back to step 3 - add new delivery address (It must have custom fields in the register form, in my store I have the custom field "number")
3. Go to step 6 again and confirm the order.
4. Go to admin - and check this order you just made
5. Check the delivery address - The custom field is taking data from the old address (The error is only in custom field, all the rest from data like address, city, name are correct)

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm
Who is online

Users browsing this forum: No registered users and 2 guests