Post by Hillbilly57 » Mon Feb 18, 2019 4:49 am

An intermittent problem but it happens more often than not - my product descriptions will not save to database. All other product info will save with no issues. Nothing shows up in the error logs. I've tried enabling the fixes at the bottom of the .htaccess file which only throws a 500 error. php.ini post_max_size 50M is more than enough headroom. I tried changing the table's description field to MEDIUMTEXT to no avail. On echo the description field is empty.

Code: Select all

Array
(
    [product_description] => Array
        (
            [1] => Array
                (
                    [name] => Paul Thorn LP Bundle
                    [description] => 
                    [meta_title] => Paul Thorn LP Bundle
                    [meta_description] => Buy the Don't Let The Devil Ride and Too Blessed To Be Stressed vinyl LPs from the official Paul Thorn music store.
                    [meta_keyword] => paul thorn, thorne, band, music, rock, americana, singer, songwriter, songs, album, vinyl, lp, record, don't let the devil ride, too blessed to be stressed, store, buy, purchase
                    [tag] => 
                )
Here is the html that creates the latest issue...

Code: Select all

<p><span style="font-size:18px">Get Paul's brand new "Don't Let The Devil Ride" and "Too Blessed To Be Stressed" on high quality vinyl for only $40.00 plus $10.00 shipping.</span></p>
<p><img style="width: 220px; float: left;" src="https://www.perpetualobscurity.com/image/catalog/Music/dldr_tbtbs_bundle.jpg"><br></p>
<p></p><h2>Don't Let The Devil Ride<br>(On vinyl LP)*</h2><p></p>
<p>After a dozen roots-rock records, Paul Thorn reclaims his past by celebrating the first music he ever experienced. <em>Don’t Let The Devil Ride</em> features contributions from the <strong>Blind Boys of Alabama, The McCrary Sisters, the Preservation Hall Jazz Horns</strong>, and <strong>Bonnie Bishop</strong>.</p>
I've tried switching from my preferred browser (Firefox) to Chrome with no joy. This is so frustrating but I have too much time and money invested in OC to give up on it yet. Any ideas? And thanks in advance for any input.

A hillbilly in America


Newbie

Posts

Joined
Thu Dec 13, 2018 11:27 am

Post by straightlight » Mon Feb 18, 2019 5:01 am

I've tried switching from my preferred browser (Firefox) to Chrome with no joy. This is so frustrating but I have too much time and money invested in OC to give up on it yet. Any ideas? And thanks in advance for any input.
With such an investment, and that time seem to be at the essence on your end, you could create a service request in the Commercial Support section of the forum to get this done as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Hillbilly57 » Mon Feb 18, 2019 7:36 am

Thank you, straighlight, that's an option I may have to turn to. In the meantime, the smaller, less complex descriptions seem to be working okay. It's the larger descriptions with images and a lot of html that seem to be choking and simply inputting directly into the DB is the meantime fix. I really appreciate your response.

A hillbilly in America


Newbie

Posts

Joined
Thu Dec 13, 2018 11:27 am

Post by paulfeakins » Mon Feb 18, 2019 7:38 pm

Hillbilly57 wrote:
Mon Feb 18, 2019 7:36 am
Thank you, straighlight, that's an option I may have to turn to. In the meantime, the smaller, less complex descriptions seem to be working okay. It's the larger descriptions with images and a lot of html that seem to be choking and simply inputting directly into the DB is the meantime fix. I really appreciate your response.
Sounds like your web host may be blocking certain content from being sent to the server.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by Hillbilly57 » Tue Feb 19, 2019 2:33 pm

I'm the host (on a VPS), but I'm not ruling anything out. It's been working fine lately, seems to only happen when I have a heavy description with a couple of images and more html than usual.

A hillbilly in America


Newbie

Posts

Joined
Thu Dec 13, 2018 11:27 am

Post by straightlight » Tue Feb 19, 2019 10:25 pm

Hillbilly57 wrote:
Tue Feb 19, 2019 2:33 pm
I'm the host (on a VPS), but I'm not ruling anything out. It's been working fine lately, seems to only happen when I have a heavy description with a couple of images and more html than usual.
It might be possible that your provider is using an XSS prevention server module to avoid XSS vulnerabilities where extensive HTML codes are being tracked via posted forms and before being added on the database.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 7 guests