Post by tomfantini » Fri Jan 11, 2019 7:47 pm

Hi,

I have an image that will not load via https but the rest of them are? Please see a screenshot of the error below, I also have a second error when I add an item to the cart it is displaying "XML-HTTP-request" has been blocked. If someone could please help me out I would really appreciate it!

Thanks,
Tom

Attachments

Screenshot (92).png

Screenshot (92).png (32.87 KiB) Viewed 344 times


Newbie

Posts

Joined
Fri Jan 11, 2019 7:26 pm

Post by OSWorX » Fri Jan 11, 2019 11:52 pm

Seems that you - or anybody else - has added the wechat image with an absolue URL.
Either use relative or change the absolute - both may require to edit the template file.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by tomfantini » Mon Jan 14, 2019 7:20 am

Ok, thanks I'll try that.

Newbie

Posts

Joined
Fri Jan 11, 2019 7:26 pm

Post by tomfantini » Mon Jan 14, 2019 7:31 am

what would the file name be? I am doing this for a client and a previous developer has made this site.

Newbie

Posts

Joined
Fri Jan 11, 2019 7:26 pm

Post by johnp » Mon Jan 14, 2019 6:58 pm

I can't see the live site as it's down for maintenance. From the screenshot I can see it's the webchat.jpg image being called insecurely. As OSWorX said, find where that image is being called in from and corerect the call. It might be in a tpl file such as header.tpl or footer.tpl or you may have set up a content module to pull it in. It shouldn't be a hard one to fix.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.1 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK
Who is online

Users browsing this forum: No registered users and 6 guests