Post by sjgarth » Sat Jan 12, 2019 12:16 am

After upgrade to 3.0.3.1 everything works fine except the PayPal Express extension.
The only extensions I have are the included PayPal Express and purchased GDPR Module. The site was working fine before the update, and no changes were made during the update. The update was by Softaculous.
When processing the payment all the normal options are there, but when the customer clicks on the yellow/gold PayPal button they get the PayPal popup box with something like;
{"token":"EC-42Y453306A965952G"}
at the top.
The sale fails.
I have uninstalled and reinstalled the PayPal Express extension and I have regenerated the credentials all with no success.
There were no errors in the error log, so I turned on the debug function in the extension and the following was in the error log (personal details removed);

Code: Select all

2019-01-11 23:54:37 - PayPal Express debug (Call data): {"METHOD":"SetExpressCheckout","MAXAMT":2.25,"RETURNURL":"https:\/\/shop.rblr.co.uk\/ocart2\/index.php?route=extension\/payment\/pp_express\/checkoutReturn","CANCELURL":"https:\/\/shop.rblr.co.uk\/ocart2\/index.php?route=checkout\/checkout","REQCONFIRMSHIPPING":0,"NOSHIPPING":0,"LANDINGPAGE":"Login","LOGOIMG":null,"CHANNELTYPE":"Merchant","PAYMENTREQUEST_0_SHIPTONAME":"Steve Garth","PAYMENTREQUEST_0_SHIPTOSTREET":"47 Xxxxxxx Xxxxxxx","PAYMENTREQUEST_0_SHIPTOSTREET2":"Xxxxxxxx","PAYMENTREQUEST_0_SHIPTOCITY":"Doncaster","PAYMENTREQUEST_0_SHIPTOSTATE":"South Yorkshire","PAYMENTREQUEST_0_SHIPTOZIP":"XX12 2XX","PAYMENTREQUEST_0_SHIPTOCOUNTRYCODE":"GB","ADDROVERRIDE":1,"PAYMENTREQUEST_0_SHIPPINGAMT":"","PAYMENTREQUEST_0_CURRENCYCODE":"GBP","PAYMENTREQUEST_0_PAYMENTACTION":"Sale","L_PAYMENTREQUEST_0_DESC0":"","L_PAYMENTREQUEST_0_NAME0":"RBLR Branch Crest Sticker Small EXTERNAL","L_PAYMENTREQUEST_0_NUMBER0":"S004","L_PAYMENTREQUEST_0_AMT0":1.5,"L_PAYMENTREQUEST_0_QTY0":"1","L_PAYMENTREQUEST_0_ITEMURL0":"https:\/\/shop.rblr.co.uk\/ocart2\/index.php?route=product\/product&product_id=100","L_PAYMENTREQUEST_0_ITEMLENGTHVALUE0":"9.50000000","L_PAYMENTREQUEST_0_ITEMLENGTHUNIT0":"cm","L_PAYMENTREQUEST_0_ITEMWIDTHVALUE0":"7.50000000","L_PAYMENTREQUEST_0_ITEMWIDTHUNIT0":"cm","L_PAYMENTREQUEST_0_ITEMHEIGHTVALUE0":"0.00000000","L_PAYMENTREQUEST_0_ITEMHEIGHTUNIT0":"cm","L_PAYMENTREQUEST_0_NUMBER1":"shipping","L_PAYMENTREQUEST_0_NAME1":"UK Shipping  (Weight: 0.00Pnts)","L_PAYMENTREQUEST_0_AMT1":1.75,"L_PAYMENTREQUEST_0_QTY1":1,"PAYMENTREQUEST_0_ITEMAMT":"3.25","PAYMENTREQUEST_0_AMT":"3.25"}

2019-01-11 23:54:38 - PayPal Express debug (Result): "TOKEN=EC%2d1RF12894U4844163N&TIMESTAMP=2019%2d01%2d11T23%3a54%3a39Z&CORRELATIONID=edd66df6462c7&ACK=Success&VERSION=109%2e0&BUILD=51125032"
The site is using PHP 7.2 (and was for a month at least without issue).

Any help would be appreciated.
Last edited by sjgarth on Sat Jan 12, 2019 8:11 am, edited 2 times in total.

Newbie

Posts

Joined
Mon Mar 19, 2018 12:22 am

Post by xxvirusxx » Sat Jan 12, 2019 3:42 am

Better restore to 3.0.2.0

My Extensions | OC 3.0.3.1, 3.0.2.0, 2.3.0.2 with bugs fixed | 2.3.0.2 Custom version


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by nguyenhoco2002 » Sat Jan 12, 2019 1:47 pm

I using php 7.1 and Paypal Express woking fine with my website ^^


Posts

Joined
Sat Jan 12, 2019 1:45 pm

Post by sjgarth » Sun Jan 13, 2019 1:05 am

I have reduced PHP to 7.0 after trying 7.3, 7.2 and 7.1. I cannot go below 7.0 because of other software on my server.
Nothing made any difference. Everything works fine until I try to use paypal express, when i get the token message mentioned in original post.

Newbie

Posts

Joined
Mon Mar 19, 2018 12:22 am

Post by OSWorX » Sun Jan 13, 2019 1:12 am

sjgarth wrote:
Sun Jan 13, 2019 1:05 am
I have reduced PHP to 7.0 after trying 7.3, 7.2 and 7.1. I cannot go below 7.0 because of other software on my server.
Nothing made any difference. Everything works fine until I try to use paypal express, when i get the token message mentioned in original post.
No need to go back or lower.
Running myself and a view customers with php 7.2.x and PP-Express perfectly.
But, NOT 3.0.3.1 - 2.3.x and 3.0.2.x

Would suggest to use 3.0.2.x, not 3.0.3.1 without further investigation.

Forum Rules [en]: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88
Dedicated Support: https://dedicated.opencart.com/
Marketplace Support: https://www.opencart.com/index.php?rout ... rt/support
Documentation: http://docs.opencart.com/en-gb/extension/theme/

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by sjgarth » Sun Jan 13, 2019 1:45 am

I agree that 3.0.3.1 is the issue and I tried to go back to 3.0.2.0 but it didn't work. I made the error of not backing up the database before the upgrade and, although everything seems to work, the PayPal Express extension PayPal link now appears for a second then disappears before the customer can insert their details.
I have removed the express extension and installed the standard extension which works fine.
Ce La Vie for a free shop which fulfils my expectations in every other way.
I will try a future update, but only after more carefully backing up.

Newbie

Posts

Joined
Mon Mar 19, 2018 12:22 am

Post by blocks1 » Sat Mar 16, 2019 5:54 pm

Did anyone find a solution to this? i made my site with a fresh install of 3.0.3.1 so cannot downgrade..
is it not worth waiting until an upgrade can be made if there is no fix for the problem with paypal express?

New member

Posts

Joined
Thu Feb 08, 2018 11:14 am

Post by straightlight » Sun Mar 17, 2019 12:46 am

blocks1 wrote:
Sat Mar 16, 2019 5:54 pm
Did anyone find a solution to this? i made my site with a fresh install of 3.0.3.1 so cannot downgrade..
is it not worth waiting until an upgrade can be made if there is no fix for the problem with paypal express?
Sure did: viewtopic.php?f=201&t=210578

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by blocks1 » Mon Mar 18, 2019 6:40 pm

thankyou!

New member

Posts

Joined
Thu Feb 08, 2018 11:14 am
Who is online

Users browsing this forum: No registered users and 10 guests