Post by straightlight » Fri Apr 06, 2018 10:15 am

<< Please disregard this topic until further notice. It has been noticed recently that the custom fields from the core have larger problems than anticipated on GitHub and support is currently working on it. >>
Last edited by straightlight on Sun Jun 02, 2019 7:19 pm, edited 1 time in total.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by wh1t3man2nd » Sat Apr 21, 2018 10:40 pm

What i get is "Fatal error: Uncaught Exception: Error: Could not load session adaptor session! etc.. etc.. " When trying to access order details.
Plus that the order does not appear in dashboard.

New member

Posts

Joined
Wed Apr 19, 2017 8:27 pm

Post by straightlight » Wed Aug 22, 2018 6:01 pm

wh1t3man2nd wrote:
Sat Apr 21, 2018 10:40 pm
What i get is "Fatal error: Uncaught Exception: Error: Could not load session adaptor session! etc.. etc.. " When trying to access order details.
Plus that the order does not appear in dashboard.
What does that explain?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Jensdccom » Fri Sep 28, 2018 11:40 pm

Doesn't work for me.

I uploaded all the files to the folders and I get this error when I try to open the invoice.

Backend fatal error: PHP Fatal error: Uncaught Error: Call to a member function getCustomFields() on null in websitepublic_html/admin/controller/sale/order.php:1514\nStack trace:\n#0 websitestorage/modification/system/engine/action.php(79): ControllerSaleOrder->invoice()\n#1 websitepublic_html/admin/controller/startup/router.php(26): Action->execute(Object(Registry), Array)\n#2 websitestorage/modification/system/engine/action.php(79): ControllerStartupRouter->index()\n#3 websitestorage/modification/system/engine/router.php(114): Action->execute(Object(Registry))\n#4 websitestorage/modification/system/engine/router.php(103): Router->execute(Object(Action))\n#5 websitepublic_html/system/framework.php(168): Router->dispatch(Object(Action), Object(Action))\n#6 websitepublic_html/system/startup.php(104): require_once('/home//...')\n#7 /home/in websitepublic_html/admin/controller/sale/order.php on line 1514\n

As said I just uploaded the files and refreshed mods.

Newbie

Posts

Joined
Fri Sep 28, 2018 11:35 pm

Post by m_uzunov » Tue Oct 02, 2018 4:04 pm

I uploaded files too, create token field in oc_order.....and when open invoice opssss - Fatal error: Call to a member function getCustomFields() on null in /home/......../admin/controller/sale/order.php on line 1514. Is this a solution of custom fields problem , i dont think so...too

Newbie

Posts

Joined
Wed May 02, 2018 10:52 pm

Post by m_uzunov » Sun Nov 04, 2018 6:03 pm

Ooo, that was easy, just copied all section custom fields from function info() to function invoice() in admin/controller/sale/order.php . Then add
{% if account_custom_fields %}
{% for custom_field in account_custom_fields %}
<b>{{ custom_field.name }}</b> {{ custom_field.value }}<br />
{% endfor %}
{% endif %}
in order_invoice.twig, and that's all.

Newbie

Posts

Joined
Wed May 02, 2018 10:52 pm

Post by straightlight » Sun Jun 02, 2019 7:19 pm

First post has now been edited.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Jos1984 » Sat Aug 17, 2019 5:36 am

m_uzunov wrote:
Sun Nov 04, 2018 6:03 pm
Ooo, that was easy, just copied all section custom fields from function info() to function invoice() in admin/controller/sale/order.php . Then add
{% if account_custom_fields %}
{% for custom_field in account_custom_fields %}
<b>{{ custom_field.name }}</b> {{ custom_field.value }}<br />
{% endfor %}
{% endif %}
in order_invoice.twig, and that's all.
I did everything you mentioned and I have a problem, I need to add to the invoice all the custom fields, how do I have to proceed ?, please if you could give me a hand. Thank you.

Newbie

Posts

Joined
Tue Jul 23, 2019 2:01 am

Post by straightlight » Sun Aug 18, 2019 7:05 pm

Please read the first post. This concept on my behalf has been deprecated.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 7 guests