Post by bellasrestaurant.us » Sun May 07, 2017 12:47 pm

I am having an issue installing the Login and Pay With Amazon payment option using the latest version (OpenCart 2.3.0.2). When I click "Validate and use Credentials" With the Exact information provided by Amazon I am brought to a warning page that says Permission Denied! You do not have permission to access this page, please refer to your system administrator.

I thought it may have been something I messed up along the way so I started with a fresh install of everything and tried to install this first. Still no luck

Can some one please help, I'm running out of hair to pull out.


Posts

Joined
Sun May 07, 2017 12:25 pm

Post by jeremyjustus0916 » Wed May 10, 2017 11:39 am

You probably are not calling them via https, you need SSL enabled on your site to use that plugin. Also you can go to the admin panel and make sure you have the boxes checked for that plugin under the security access.

User avatar

Posts

Joined
Thu Mar 23, 2017 9:36 am

Post by bellasrestaurant.us » Wed May 10, 2017 1:55 pm

Thank you for the reply, both of the buttons seem to work fine. It is just when I click validate credentials that I get permission denied.
And, yes I am running an SSL certificate through Go Daddy, I new I forgot something in my post


Posts

Joined
Sun May 07, 2017 12:25 pm

Post by UserTitle » Wed May 17, 2017 2:12 am

I get the same error message on 2.3.0.2. I have an active SSL and permission boxes checked as well. Any help would be much appreciated.

Respected Developers: thekrotek, iSenseLabs, Dreamvention


New member

Posts

Joined
Sun Dec 21, 2014 7:53 pm

Post by joemaydew » Sat Oct 14, 2017 3:32 pm

Apologies for reopening an old post but did anyone find a fix for this.

I have a new installation of 2.3.0.2 and using a custom theme. When I go validate the keys in the Amazon Login and Pay module I get permission denied error. I have tried resetting my user group permissions to no avail. I have tried manually entering the keys and setting status to enabled and in test mode. This seems to be OK but when I go through checkout I am getting no payment options available.

User avatar
New member

Posts

Joined
Wed May 07, 2014 4:58 pm
Location - Staffordshire, United Kingdom

Post by stuto » Thu Nov 02, 2017 2:00 am

Not sure if this is helpful, but I had a similar issue and found that Business Info (First & Last Name and email address) used to set-up your Amazon Seller Account has to match the User information in Opencart. I realized I had a different email address listed in OC and once I updated it to match, it worked. Also, don't forget to update the checkout and account under design>layouts to include amazon.

Newbie

Posts

Joined
Thu Nov 02, 2017 1:49 am

Post by psh2580 » Tue Nov 20, 2018 8:09 pm

Did everyone manage to sort this one out?
I have SSL running. I have changed my user and email to match Amazon and also updated the account log in and payment to include amazon and still get Permission Denied...

Newbie

Posts

Joined
Sat Nov 30, 2013 1:41 am
Who is online

Users browsing this forum: No registered users and 2 guests