Post by tedukes » Thu Oct 06, 2016 8:34 am

Hello,

I'm running a CentOS 6.8 system with php version 5.3.3.

The system requirements on http://docs.opencart.com/requirements/ indicate 5.3.

Apparently that is not correct as I just tried to install it and got a message that 5.4 is required.

I can setup a VM with CentOS 7 for testing but I use Godaddy to host my commercial site and I want to migrate from OScommerce. Godaddy runs 5.2.17

It doesn't appear Open cart is a viable alternative if it doesn't' support a lower version.

Any work arounds?

Newbie

Posts

Joined
Thu Oct 06, 2016 8:21 am

Post by IP_CAM » Fri Oct 07, 2016 9:33 am

If Godaddy still runs 5.2.17, then, you should look around for a better Alternative ! ;)

But either OC v.1.5.6.4
http://www.opencart.com/index.php?route ... d/download
or better, OC v.1.5.6.5_rc should work
http://www.openshop.li/downloads/openca ... 6.5_rc.zip
according to this Info:
PHP 5.3+(1.5.x at least 5.2+)
then, you still would have a viable alternative :D

Compare it with, when leadfree Gasoline entered the Auto-Market, not all Car's where able to use it.
Same with OC-2, to be able to use latest programmer-technology, a Server has to support it.

Ernie

I am no longer active at this Forum.
Please don't send Personal Messages, contact: jti@jacob.ch
---
Github OC Downloads: https://github.com/IP-CAM
2'000+ FREE OC Extensions from the World's largest Github OC Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by OSWorX » Fri Oct 07, 2016 11:50 am

General OpenCart 2.x works perfect with php 7.x

Benefit in using php 7.x?
Faster, more secure and some more.

Why not using php lower than 5.4?
Because lower versions are not maintained anymore and are outdated!
Another reasons are functions not existing in lower versions or only with workarounds.
Final - and not to forget 2 more reasons: security and speed.

If a provider can not offer a php-version 5.4 or higher (e.g. 5.5.38 or 5.6.26 would be the best) and/or selectable as alternative php 7.x > leave it!
Run as fast you can, it is not worth to think about a millisecond!
And look for a better provider.

One final note: too many times I see provider (they call themselve so, I would use another term for them!) using a php-version which does not fit in general to the used server system.
You will see that unfortunetaly during the operation in conjunction with some functions.
Because this is a very specific issue, no common advice can be given here.
Only, that you read carefully what they are offering, and what - if possible - other customers of this provider have to say about their services.

Never forget: you are a shopowner and want to make money with your shop!
Therefore you are responsible for your customers security.

And if you are an agency or a developer: do not make quick money for at least a unsecure shop - and if you do not know your job, let it!

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by JNeuhoff » Fri Oct 07, 2016 5:36 pm

I would not recommend Godaddy webhost, I've heard nothing but bad news from customers using them.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 11 guests