Post by JNeuhoff » Tue Mar 23, 2010 8:42 pm

The Export/Import module has now been upgraded to support OpenCart 1.4.4.
New features include support for the specials and discounts.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by allenshea » Tue Mar 23, 2010 8:59 pm

Always appreciated your hard work. Thanks for updating.

Allen

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by peteVA » Wed Mar 24, 2010 12:04 am

Bless you!

Can't say the import works yet, but at least I got a good export and have some idea of the structure of the files.

Thanks so much!

A Trusted Wholesale Dropshipper
Web Hosting Under $ 5.00 Month! FREE Shopping Carts!
25,000+ Real Wholesale & Dropship Sources!


User avatar
Active Member

Posts

Joined
Mon Jul 20, 2009 8:25 am

Post by pesnemarn5 » Wed Mar 24, 2010 2:05 am

Thank you for this man, I appreciate it very much!

Newbie

Posts

Joined
Tue Mar 16, 2010 3:32 am

Post by rph » Wed Mar 24, 2010 10:59 am

Great work!

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by OCyvon2 » Thu Mar 25, 2010 7:02 pm

My hosting provider tell me that I cannot use PEAR because its not save on a shared hosting.
Is there another option to use this import/export module?

OpenCartstore
Gebruikersgids (admin handleiding)


User avatar
Active Member

Posts

Joined
Sun Jan 31, 2010 8:00 pm
Location - Zaandam, The Netherlands

Post by tilesupply » Fri Mar 26, 2010 8:12 am

Hi JNeuhoff

Can you help me with your mod.
The old one was working for me on my old site. I am having a problem when I run the export.

When i run it it's fine but when i open the file i get this
Slide1.JPG

Slide1.JPG (27.18 KiB) Viewed 4080 times

I was running V1.40 with a few mods from Q.
Then i used the upgrade mod from Q to change over to 1.44.

When i had 1.40 I had added special prices and discounts to some of the products.
What it tends to do some times is download the cats, specials and discounts and leave the products blank.
Another time it only download half the discounts special and products but all the cats.

I have now set up a local test server so i have full access to the sql database.
If I send you the DB backup are you able to fix it for me.

Also what would your rate be for fixing this?
If possible i need to get this sorted ASAP.

Many Thanks

Active Member

Posts

Joined
Wed Aug 26, 2009 7:48 am


Post by JNeuhoff » Sat Mar 27, 2010 1:01 am

OCyvon2 wrote:My hosting provider tell me that I cannot use PEAR because its not save on a shared hosting.
Is there another option to use this import/export module?
Change your web host. I recommend Hostgator, you can find a summary of their packages on my website.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Sun Mar 28, 2010 5:13 am

tilesupply wrote:Hi JNeuhoff

Can you help me with your mod.
The old one was working for me on my old site. I am having a problem when I run the export.

When i run it it's fine but when i open the file i get this
Slide1.JPG
I was running V1.40 with a few mods from Q.
Then i used the upgrade mod from Q to change over to 1.44.

When i had 1.40 I had added special prices and discounts to some of the products.
What it tends to do some times is download the cats, specials and discounts and leave the products blank.
Another time it only download half the discounts special and products but all the cats.

I have now set up a local test server so i have full access to the sql database.
If I send you the DB backup are you able to fix it for me.

Also what would your rate be for fixing this?
If possible i need to get this sorted ASAP.

Many Thanks
As I said in my PM, I accidentally uploaded the wrong version of the Export/Import module for OpenCart 1.4.0, I have now corrected it.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by peteVA » Sun Mar 28, 2010 6:20 am

It's exporting great.

I could not quite figure out how to enter categories / sub-categories, so I entered online and exported. Gave me a good lesson in how that works.

But, nothing I added to the categories came back.

Images for the categories, meta description, keywords - none imported.

Went back and deleted the categories in the cart. Tried again. And again. And again.

Looked at the xls file, everything there. Looked again, etc.

Tried it with the xls saved, open, no difference. Everything is there, but not coming into the cart.

A Trusted Wholesale Dropshipper
Web Hosting Under $ 5.00 Month! FREE Shopping Carts!
25,000+ Real Wholesale & Dropship Sources!


User avatar
Active Member

Posts

Joined
Mon Jul 20, 2009 8:25 am

Post by JNeuhoff » Sun Mar 28, 2010 10:44 pm

peteVA wrote:It's exporting great.

I could not quite figure out how to enter categories / sub-categories, so I entered online and exported. Gave me a good lesson in how that works.

But, nothing I added to the categories came back.

Images for the categories, meta description, keywords - none imported.

Went back and deleted the categories in the cart. Tried again. And again. And again.

Looked at the xls file, everything there. Looked again, etc.

Tried it with the xls saved, open, no difference. Everything is there, but not coming into the cart.
Just sent you a PM, need a copy of your XLS file to investigate.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by saint » Tue Mar 30, 2010 7:03 am

Hi J.

I'm having a problem. I'm able to import and export just fine. However on export with the description when I open it in excel the description gets cut in half when I open it. Mind you, my version of excel is from 2001 and I know inner pinnings of the software have changed a lot.

When I open it with openoffice.org the descriptions are still there, so I know it's not the export that is bad, but when I save the excel file it saves it in a format that causes an error on import. Also, saving the saved openoffice.org file in excel is useless and just shows another error message.

I don't know. I'm guessing it would be best for my mental health to just accept the fact that if I want to do a mass upload of products, it's best to keep the product descriptions to a shorter length and just forget about having beautiful product descriptions.

- -S

Newbie

Posts

Joined
Tue Mar 23, 2010 1:15 am

Post by JNeuhoff » Tue Mar 30, 2010 6:41 pm

When using OpenOffice, do a Save As MS Excel 97/2000/XP (.XLS) , and it will preserve the whole length of your descriptions beyond the 255 character limitation.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by saint » Wed Mar 31, 2010 2:32 am

J, Thank you so much. Awesome awesome awesome.

I swear I tried this but i've tried so many techniques it's possibly I missed it somehow. Either way, you get the star for the day. This is rad. So much to update now!

Newbie

Posts

Joined
Tue Mar 23, 2010 1:15 am

Post by Affableaardvark » Thu Apr 01, 2010 11:25 pm

I am using the module with 1.4.5 clean install. I can import 2000 products then when I try to import another 2000 products the response says successful though still just the original 2000 products.
All the product ID's are different as well as model and sku.
Any advice would be appreciated.


Posts

Joined
Thu Apr 01, 2010 11:19 pm

Post by JNeuhoff » Thu Apr 01, 2010 11:46 pm

First of all, the current version of the Export/Import module hasn't yet been officially ported by me to versions of OpenCart later than 1.4.4, though chances are it will work.

As regards the Import not going beyond a certain number of products: This looks like an issue with your PHP settings. In particular, the Import can by quite memory hungry and your memory_limit setting may not be enough, see this thread for more details.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by kkk26 » Sat Apr 03, 2010 5:29 pm

It does not work in 1.4.6

Could you please update this?

Thanks!
Last edited by i2Paq on Sat Apr 03, 2010 9:41 pm, edited 1 time in total.
Reason: Made reply more friendly

Christian Louboutin


New member

Posts

Joined
Wed Jan 06, 2010 3:35 pm


Post by tilesupply » Sun Apr 04, 2010 7:13 am

I have it working in 1.46.

But the fixes from 1.44 to 1.46 like google site map dont work.

Once I installed it site map stopped working in google.
So in short backup a copy of your site and you should be fine to have it running as a temp fix till a new one comes out.

Active Member

Posts

Joined
Wed Aug 26, 2009 7:48 am


Post by squeaky » Tue Apr 06, 2010 12:51 am

Am I understanding this correctly? I must first export from the system, make my changes, and then re-import the updated file?

Is there anyway to mass import new products?

One more - Any idea when the mod will be updated to work with the latest oc version 1.4.6?

thanks in advance.
Last edited by i2Paq on Tue Apr 06, 2010 1:08 am, edited 1 time in total.
Reason: Merged

User avatar
New member

Posts

Joined
Thu Dec 03, 2009 1:01 am


Post by Affableaardvark » Tue Apr 06, 2010 6:53 pm

JNeuhoff wrote:First of all, the current version of the Export/Import module hasn't yet been officially ported by me to versions of OpenCart later than 1.4.4, though chances are it will work.

As regards the Import not going beyond a certain number of products: This looks like an issue with your PHP settings. In particular, the Import can by quite memory hungry and your memory_limit setting may not be enough, see this thread for more details.
Thank you for your reply. I have done further tests and have split the import file into smaller chunks. The imported file overwrites the original for example I had 2000 products stored and imported 650 all with different product_id, sku and model and the shop now only shows the 650 products.
Is there a way of importing in chunks to get round my hosts php.ini limits?

Thank you for an excellent module much better than easypopulate! (Zencart)


Posts

Joined
Thu Apr 01, 2010 11:19 pm
Who is online

Users browsing this forum: No registered users and 6 guests