Post by OpenTeam » Fri May 22, 2015 5:25 pm

Hello,

Can you please tell which hosting provider you are using to host your website? Some hosting provider do block the port 25 by default.

Regards.

User avatar
Active Member

Posts

Joined
Tue May 19, 2015 2:31 am

Post by EvilHit » Fri May 22, 2015 5:49 pm

its not order its registering account

pm-netti wrote:
EvilHit wrote:ive just installed 2.0.3.0 and its still the same so i dont know whats happening
Is setting `New Order Alert Mail` status `Yes`?

New member

Posts

Joined
Fri Jun 06, 2014 6:53 pm

Post by EvilHit » Fri May 22, 2015 5:50 pm

godaddy - ive not had a problem up to 2.0 then emails stopped from there
OpenTeam wrote:Hello,

Can you please tell which hosting provider you are using to host your website? Some hosting provider do block the port 25 by default.

Regards.

New member

Posts

Joined
Fri Jun 06, 2014 6:53 pm

Post by pm-netti » Fri May 22, 2015 5:52 pm

EvilHit wrote:its not order its registering account

pm-netti wrote:
EvilHit wrote:ive just installed 2.0.3.0 and its still the same so i dont know whats happening
Is setting `New Order Alert Mail` status `Yes`?
And `New Account Alert Mail` is `Yes`?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by EvilHit » Fri May 22, 2015 7:28 pm

yes i have

heres a screenshot see if you can see if wrong http://prntscr.com/781oov

New member

Posts

Joined
Fri Jun 06, 2014 6:53 pm

Post by EvilHit » Fri May 22, 2015 10:41 pm

i got my email working again now :)

New member

Posts

Joined
Fri Jun 06, 2014 6:53 pm

Post by OpenTeam » Fri May 22, 2015 11:59 pm

EvilHit wrote:i got my email working again now :)

Can you please propose the solution so that it might help others, stuck in the same situation ?


Regards.

User avatar
Active Member

Posts

Joined
Tue May 19, 2015 2:31 am

Post by EvilHit » Sun May 24, 2015 12:13 pm

i had to call up my host to fix the issue

New member

Posts

Joined
Fri Jun 06, 2014 6:53 pm

Post by conticreative » Sat Jun 06, 2015 7:43 am

Any idea what they did? I have a similar problem but I have a VPS. I have had to recompile easy apache 4 or 5 times already because things were missing. If you even have a hint it will help a lot.

BTW there is a link to an update in a previous post on this thread. From what I read, it may also fix another issue I am having, but the download is not longer valid. Any chance it can be reposted? Or is it obsolete by now?

Newbie

Posts

Joined
Sat Apr 25, 2015 5:23 am

Post by neorai17@gmail.com » Mon Feb 01, 2016 7:44 pm

Hello any one can help me i've install Opencart 2.0.1.1 but my email function is not working i;ve check mail setting and all are correct but email is not sending on any activity so please guide me http://www.avarikar.com/


Posts

Joined
Mon Feb 01, 2016 7:37 pm

Post by tulanch » Fri Feb 19, 2016 12:47 am

I have same issues with 2.1.0.2 hosting at godaddy I created a sub-domain specifically for the implementation

I have zencart working on this server using simple php mail

I have copied the same settings from there: email addressed, local host, port 25

the OC contact email works

but no order confirmation, etc... emails are being received by the buyer or admin

I also have this OC implementation connected to a developer.authorized.net sandbox, emails from authorize are coming through.

orders are seen in OC

there are no email related error in log files

suggestions?

would I need the sub domain on the email address in the OC setup? The actual email address on the subdomain does not exist.
Last edited by tulanch on Sat Feb 20, 2016 9:29 am, edited 1 time in total.

Newbie

Posts

Joined
Thu Feb 11, 2016 7:44 am

Post by tulanch » Sat Feb 20, 2016 2:17 am

I host at Godaddy. I have Linux cpanel hosting. I worked with their support last night. I have a PHP script that will test email delivery using php sendmail or a phpstmp method.

Using the same to and from email addresses I have configured in Opencart, coming from the same folder location where Opencart index.php resides, I get emails delivered as expected with either method. This test script also seems to be making use of localhost, port 25 with a 5 second setting.

This leads me to belive the version of Opencart I have installed has some email issues that need to be addressed.

Also, various areas from Google search's of this issue indicate I should be able to send an email to an opencart customer from the Admin opencart user interface. The version I have installed does not have this feature available.

This version came from the list of available applications to install from the Godaddy application list. It pointed to the Opencart site so I am rather confident I have a good install.

Anyone have suggestions? Would it be appropriate to hack away at the basic email component?

Newbie

Posts

Joined
Thu Feb 11, 2016 7:44 am

Post by tulanch » Mon Feb 22, 2016 5:15 am

I got it working by incorporating SMTP code from hosting provider

Newbie

Posts

Joined
Thu Feb 11, 2016 7:44 am

Post by ainmkj » Mon Feb 22, 2016 10:45 am

Choose

Mail Protocol: SMTP (not mail)
mail Parameters : -fname@domain.com
smtp hostname: mail.domain.com
smtp username: your@domain.com
smtp password: *******
smtp port: 25
smtp out :5


It's working!!

Newbie

Posts

Joined
Mon Feb 22, 2016 10:40 am

Post by daritehnologies » Thu Mar 10, 2016 6:24 am

This answer working fine with Opencart 2.1.0.2
I have searched all week to fix this issue.
And finally this works!!

Thanks ainmkj ! :D


Posts

Joined
Fri Jan 16, 2015 5:16 am

Post by daritehnologies » Thu Mar 10, 2016 6:51 am

ainmkj wrote:Choose

Mail Protocol: SMTP (not mail)
mail Parameters : -fname@domain.com
smtp hostname: mail.domain.com
smtp username: your@domain.com
smtp password: *******
smtp port: 25
smtp out :5


It's working!!
Thanks ainmkj ! :D

This answer working fine with Opencart 2.1.0.2
I have searched all week to fix this issue.
And finally this works!!

In System -- Settings -- Stores -- Settings - Store tab the address must be identical to that used in the Mail tab ! So, youremail@yourdomain.com !
Mail Protocol: SMTP (not Mail)...i dont know why, ițm not a specialist
Mail Parameters: -fname@yourdomain.com
SMTP Hostname: mail.yourdomain.com
SMTP username: youremail@yourdomain.com
SMTP Password: your password for youremail@yourdomain.com
SMTP port: 25
SMTP timeout: 5
Additional Alert E-mails: add a second email adress eg. youremail@yourdomain-2.com (it is not neccesary, but is your choice)

Attachments

setari trimitere emailuri din opencart 2.1.0.2 - Copie.JPG

How to fix the email notification sending error on Opencart 2.1.02 - setari trimitere emailuri din opencart 2.1.0.2 - Copie.JPG (74.16 KiB) Viewed 2181 times



Posts

Joined
Fri Jan 16, 2015 5:16 am

Post by bvi8370 » Mon Mar 21, 2016 7:30 am

Thank you ainmkj! Two days of searching and testing, and it's finally working with Hostgator. Now if the newsletter mail would start working and SSL worked correctly, opencart would rock!
ainmkj wrote:Choose

Mail Protocol: SMTP (not mail)
mail Parameters : -fname@domain.com
smtp hostname: mail.domain.com
smtp username: your@domain.com
smtp password: *******
smtp port: 25
smtp out :5


It's working!!

Newbie

Posts

Joined
Mon Mar 21, 2016 1:56 am

Post by rasheedraj » Thu Apr 07, 2016 3:03 pm

i have used SMTP email and followed as per the previous msgs.
But unfortunately it is not working with me
i am using open cart 1.5.6

Newbie

Posts

Joined
Sat Apr 02, 2016 3:05 pm

Post by tjadekoya » Tue Aug 16, 2016 11:16 pm

my email notification and new account signed up is working now .
i used this code

Mail protocol: Mail
Parameters: -femail@mydomain.com (notice how there is no space -f and the email)
Hostname: 127.0.0.1
Username: Blank
Password: Blank
Port: 25
Timeout: 5 secs

Newbie

Posts

Joined
Sun Aug 14, 2016 8:02 pm

Post by tjadekoya » Tue Aug 16, 2016 11:25 pm

I would like to change the new order notification Subject from Order 1 to something else ..maybe to Order 20019..

Pls, How do i achieve this..

I await your answer
thanks

Newbie

Posts

Joined
Sun Aug 14, 2016 8:02 pm
Who is online

Users browsing this forum: Bing [Bot] and 41 guests