Post by michaeltheone » Wed Nov 04, 2015 4:38 am

Good evening,

I have a question about the image cache function, when i upload a product image onto the webshop then the system generates a new image in diverse sizes, how come that the cache function also changes the image quality (even tho it's setup on 100%) and changing the image colors also?

This is how the image looks when i upload it (as it should be):
before - uploaded.jpg

before - uploaded.jpg (48.45 KiB) Viewed 1367 times


And this is how the image looks after it was created by the cache system (as it shouldn't be):
after- uploaded.jpg

after- uploaded.jpg (48.67 KiB) Viewed 1367 times


As you can see the image is brighter, lesser of quality how can i stop this?
Have been searching google and search function on this forum without a solution to this :( .

Thanks.

Regards,
Michael

New member

Posts

Joined
Mon May 28, 2012 10:10 pm

Post by viethemes » Wed Nov 04, 2015 9:04 pm

You can open file system\library\image.php and find

Code: Select all

$quality = 90
and replace with

Code: Select all

$quality = 100

http://www.viethemes.com - OpenCart turtorials, news, tips and stricks, extension

Our extensions:
Visual Theme Editor - Powerful tool for customizing style of any theme visually
Live Theme Editor - Customize layout, colors, backgrounds, fonts of the default theme
Theme Animation - Animation Editor for any theme

Extra Positions PRO, Custom JavaScript, Custom CSS and others


User avatar
Active Member

Posts

Joined
Thu Jan 08, 2015 12:17 pm


Post by michaeltheone » Thu Nov 05, 2015 3:07 am

viethemes wrote:You can open file system\library\image.php and find

Code: Select all

$quality = 90
and replace with

Code: Select all

$quality = 100
Hello,

Thanks for your reply but i have anounced it on TS that it has been setup at quality 100 (100%), it isn't working at all, the image color is still changing as i placed the example of before and after.

There must be a problem with the standard cache method the system is using why it is changing the colors to a brighter one. ???

New member

Posts

Joined
Mon May 28, 2012 10:10 pm

Post by michaeltheone » Thu Nov 05, 2015 3:40 pm

No one knows a solution or could lend out a hand to help for this issue ???

New member

Posts

Joined
Mon May 28, 2012 10:10 pm

Post by clorne » Thu Nov 05, 2015 5:57 pm

Do you have to use jpg?

Have you tried png?

Active Member

Posts

Joined
Fri Dec 23, 2011 6:03 pm

Post by michaeltheone » Thu Nov 05, 2015 6:34 pm

clorne wrote:Do you have to use jpg?

Have you tried png?
Very strange, with PNG it shows as how it should be, but how come jpg changes the color when it gets resized ???
Anyway thanks for your thought it works for me :)

New member

Posts

Joined
Mon May 28, 2012 10:10 pm
Who is online

Users browsing this forum: No registered users and 25 guests