Post by MatthewB » Mon Oct 05, 2015 12:55 am

Hi

All of the sudden out of no where I am noticing problems in my admin.

I can login no problem but say I then want to edit a product.

I click "edit" on product listing page and it takes a good few mins for the product to open.

then I noticed the category section was blank so the product is not visible on the frontend (yet it was before I clicked edit)

if I try to set a special it appears in the admin but not on the fronted, then if I click special again in the admin the special disappears.

It is happening with a few of the product details side of things like options disappear if I click options.

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by MatthewB » Thu Oct 08, 2015 1:27 am

I've just noticed another problem.

when I click "edit" on a product and adjust say the quantity and click save and go to the frontend the product has disappeared
if I then go back in the product edit it has deleted the product category links, options and additional images

I have contacted my hosting (1and1.co.uk) but they are no use

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by straightlight » Thu Oct 08, 2015 1:55 am

Which OC version are you using? Are you also using any installed contributions that reflects your products change?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MatthewB » Thu Oct 08, 2015 2:21 am

Hi

Sorry thought I'd put it in first post, I'm using 2.0.2.0

I don't have anything installed that touches products.

It was fine for couple of month it's just all the sudden happened.
I was thinking it was hosting as only been with couple of month and never had a problems with previous host

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by straightlight » Thu Oct 08, 2015 2:34 am

If you verify recent activities in your system/logs/error.txt file, do you notice any recent errors on that end for products?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MatthewB » Thu Oct 08, 2015 2:42 am

Hi

No nothing in the log, even when I had the problem yesterday there is nothing in the for it

this the log
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/index.php on line 138
2015-10-04 14:49:15 - PHP Notice: Undefined index: en in /homepages/5/d582899598/htdocs/index.php on line 173
2015-10-04 14:49:15 - PHP Notice: Undefined index: en in /homepages/5/d582899598/htdocs/index.php on line 174
2015-10-04 14:49:15 - PHP Notice: Undefined index: en in /homepages/5/d582899598/htdocs/index.php on line 177
2015-10-04 14:49:15 - PHP Notice: Undefined index: en in /homepages/5/d582899598/htdocs/index.php on line 178
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM currency in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/currency.php on line 15
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/currency.php on line 15
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT tr1.tax_class_id, tr2.tax_rate_id, tr2.name, tr2.rate, tr2.type, tr1.priority FROM tax_rule tr1 LEFT JOIN tax_rate tr2 ON (tr1.tax_rate_id = tr2.tax_rate_id) INNER JOIN tax_rate_to_customer_group tr2cg ON (tr2.tax_rate_id = tr2cg.tax_rate_id) LEFT JOIN zone_to_geo_zone z2gz ON (tr2.geo_zone_id = z2gz.geo_zone_id) LEFT JOIN geo_zone gz ON (tr2.geo_zone_id = gz.geo_zone_id) WHERE tr1.based = 'shipping' AND tr2cg.customer_group_id = '1' AND z2gz.country_id = '222' AND (z2gz.zone_id = '0' OR z2gz.zone_id = '3563') ORDER BY tr1.priority ASC in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/tax.php on line 28
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/tax.php on line 28
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT tr1.tax_class_id, tr2.tax_rate_id, tr2.name, tr2.rate, tr2.type, tr1.priority FROM tax_rule tr1 LEFT JOIN tax_rate tr2 ON (tr1.tax_rate_id = tr2.tax_rate_id) INNER JOIN tax_rate_to_customer_group tr2cg ON (tr2.tax_rate_id = tr2cg.tax_rate_id) LEFT JOIN zone_to_geo_zone z2gz ON (tr2.geo_zone_id = z2gz.geo_zone_id) LEFT JOIN geo_zone gz ON (tr2.geo_zone_id = gz.geo_zone_id) WHERE tr1.based = 'store' AND tr2cg.customer_group_id = '1' AND z2gz.country_id = '222' AND (z2gz.zone_id = '0' OR z2gz.zone_id = '3563') ORDER BY tr1.priority ASC in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/tax.php on line 56
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/tax.php on line 56
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM weight_class wc LEFT JOIN weight_class_description wcd ON (wc.weight_class_id = wcd.weight_class_id) WHERE wcd.language_id = '0' in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/weight.php on line 11
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/weight.php on line 11
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM length_class mc LEFT JOIN length_class_description mcd ON (mc.length_class_id = mcd.length_class_id) WHERE mcd.language_id = '0' in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/length.php on line 11
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/length.php on line 11
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM extension WHERE `type` = 'openbay' in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/library/openbay.php on line 118
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/library/openbay.php on line 118
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM event in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/index.php on line 235
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/index.php on line 235
2015-10-04 14:49:15 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM `setting` WHERE store_id = '0' OR store_id = '0' ORDER BY store_id ASC in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 14:49:15 - PHP Notice: Trying to get property of non-object in /homepages/5/d582899598/htdocs/system/addist/library/config.php on line 19
2015-10-04 14:49:15 - PHP Warning: Invalid argument supplied for foreach() in /homepages/5/d582899598/htdocs/system/addist/library/config.php on line 19
2015-10-04 18:42:13 - PHP Warning: mysqli::query(): MySQL server has gone away in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:13 - PHP Warning: mysqli::query(): Error reading result set's header in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:13 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM `language` in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 18:42:13 - PHP Warning: mysqli::query(): MySQL server has gone away in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:13 - PHP Warning: mysqli::query(): Error reading result set's header in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:13 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM `language` WHERE status = '1' in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-04 18:42:20 - PHP Warning: mysqli::query(): MySQL server has gone away in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:20 - PHP Warning: mysqli::query(): Error reading result set's header in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
2015-10-04 18:42:20 - PHP Notice: Error: MySQL server has gone away<br />Error No: 2006<br />SELECT * FROM `language` WHERE status = '1' in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 41
2015-10-07 11:59:21 - Before update reward points 1

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by straightlight » Thu Oct 08, 2015 2:47 am

PHP Warning: mysqli::query(): MySQL server has gone away in /homepages/5/d582899598/htdocs/system/library/db/mysqli.php on line 19
You'd need to contact your host regarding this issue. Here are the details on why this error message may constantly appear:

https://dev.mysql.com/doc/refman/5.0/en/gone-away.html

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MatthewB » Thu Oct 08, 2015 2:53 am

Hi

I've just emailed them about it thanks, so would that effect the product admin side when editing products

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by straightlight » Thu Oct 08, 2015 2:55 am

Yes, definitely.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by MatthewB » Thu Oct 08, 2015 2:57 am

Hi

Great thank you very much for help I appreciate it

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by MatthewB » Sat Oct 10, 2015 7:31 pm

So far my hosting company have been a waste of time

I just the same email back no matter what I say to them

" we need to see the error but can't replicate it"

any ideas how I can show them or give them the main problem

Or does anybody know a decent UK hosting company that can host a opencart website
I would need them to move all my files and database over as i'm no good at that sort of thing

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by MatthewB » Sat Oct 17, 2015 2:47 pm

Well hosting company finally getting back to after weeks of emails

They have said it is a database problem and have said it must be an extension causing the problem.
I have not added any new extension that alters the product in frontend or admin

I'm at a loss with this can anyone help please

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by EvolveWebHosting » Sun Oct 18, 2015 7:30 am

MatthewB wrote:So far my hosting company have been a waste of time

I just the same email back no matter what I say to them

" we need to see the error but can't replicate it"

any ideas how I can show them or give them the main problem

Or does anybody know a decent UK hosting company that can host a opencart website
I would need them to move all my files and database over as i'm no good at that sort of thing
Hi,

We are not located in the UK but we do host UK based Opencart websites. Does your current provider use cPanel? We also work extensively with Opencart and I'm sure we can help you clear up the issue you're having with your store.

If you're interested, feel free to respond here and checkout our website at https://www.evolvewebhost.com

Regards,

Doug

Evolve Web Hosting

www.evolvewebhost.com

Image
Hosting and Domain Specials until 01/01/2021 https://www.evolvewebhost.com/blog/blac ... riday_2020
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by MatthewB » Sun Oct 18, 2015 3:12 pm

Hi thank you for commenting I've been told I need UK hosting as I'm in the UK so it wouldn't slow the website down.

Do you have any examples I can check out of UK websites you host.

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by MatthewB » Sat Nov 07, 2015 9:41 pm

Still got the problem but now all I get when I click "edit" on product listing page is a blank white screen.

I don't get any error messages and there is nothing in my error log in admin

My hosting company are still saying it is nothing to do with anything on their end, but I don't understand how it can just stop working when I haven't installed anything new

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by daniGo » Sat Nov 07, 2015 9:56 pm

Copy files and db and install it local. If everything working fine is the problem in your hosting company and their settings, otherwise is something in your code.

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by MatthewB » Sat Nov 07, 2015 10:00 pm

Sorry don't know how you install or do anything local

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear

Post by MatthewB » Sat Nov 14, 2015 10:50 pm

Is there anyone who can have a look at website for me to see if they can fix it.

The hosting company are saying it's not there end.

I've had an opencart extension developer promise they would look at it but not heard back for about a week.

I have products I need to list but can't due to not being able to get access to product edit page

Matthew


Active Member

Posts

Joined
Sat Jul 23, 2011 5:18 am
Location - Sunderland Tyne and Wear
Who is online

Users browsing this forum: No registered users and 35 guests