Post by virgotch » Tue Aug 25, 2015 7:26 pm

i have downloaded and installed master from github for next oc version and all my old modules and templates not working because of engine/loader.php and some classes change and need to update all templates and modules for it

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by straightlight » Tue Aug 25, 2015 9:08 pm

If the system/engine/loader.php file from the core is working out of the box, this is not an opencart issue. However, I would suggest to contact the author on github to resolve this issue. While you wait for a possible patch on their behalf, replacing the original loader.php file would be ideal in order to bring back your modules and templates.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by virgotch » Tue Aug 25, 2015 9:41 pm

i already use original loader.php file , my modules or templates doesnt change any core files , it is problem abt some acts and class name changed. for example some templates give me this error.

Fatal error: Class 'Controllermodule' not found in C:\xampp\htdocs\test\system\engine\loader.php on line 28

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am

Post by straightlight » Tue Aug 25, 2015 9:55 pm

It looks like you're missing some files that might of had rather been corrupted during your last upload. Make sure your FTP default upload settings is set to ASCII for all the files that are not about images. Images should be set to BINARY. These events may occur when the AUTO settings has not been configured properly by the host regarding FTP settings.

The best and quickest solution whenever you upload a package to your server, in this case, would be to use the file manager from the host console to extract the ZIP file with only one click event. Then, all the files and folders will be automatically extracted within seconds.

This error can also be lead to one of the modules in the module folder (either admin or catalog-end side) that hasn't been properly set; such as a missing argument to the relative path. If you disable all the modules from the admin, and you do have access to the admin-end, can you tell me if this error message persists?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Tue Aug 25, 2015 11:28 pm

just to mention it, I have been working on the latest GitHub v.2.0.3.2_rc Download, for the past few days, wasting my time, by trying to install a few bloody Add-On's, like CodeManager, and/or other Extensions, or trying to get the eMail Section to work. It's of absolutely no use, for OC Newbie's, this way, if not even I am able, to get that piece of crab to work.

This must be the worst installer-nightmare I ever experienced, so far. Mod's exist, are enabled, produce no errors, some show no links, anywhere, others give me an Admin 'not allowed to use' Error, beeing installed, and enabled everywhere, where required, and I sure don't belong to those, usually not beeing capable, to handle such Gizmo's.

I would NOT have installed OC2, if I would NOT have planned, to frequently support some users around here. But under such circumstances, it a plain waste of time, trying to get something like this to do it's Job. It simply won't. At least not, the way, it comes, and interact's, at present.

From my point of View, what's really missing, is a Decal on the Download Page, declaring loud and clear:
BE AWARE, this Software, and it's optional Extensions, are for Testers only, and NOT YET TO BE USED, to eventually replace existing OC v.1.5.x Shop Installations, you eventually risk, to destroy your Online-Business and so -Existence. It's just too much different, and unfinished, as a 'Whole', compared to, what you ever knew before...!!

Sorry! It's my personal View and experience, I can't change it...
http://www.ipc.li/os/opencart_2_fehler.jpg
and all the books, I have, don't mention any of it... :o
Ernie

I don't use the Forum Mailer, to reach me, contact: jti@jacob.ch
-
Demoversions:
OpenCart LIGHT v.1.5.6.5 http://www.bigmax.ch/
OpenCart V-PRO v.1.5.6.5 http://www.ebikes.li/shop/
-
1'700+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by virgotch » Wed Aug 26, 2015 5:14 pm

thank you for your answer , and you say that we must use last oc 1.5.6.4 version for real web business ? and oc 2.x is not ready for real business yet ?

about the new version changes i asked to daniel but he answered me as usual his style )))
im not hear to answer your personal problems. this is a development tracker for the main opencart master.

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am
Who is online

Users browsing this forum: No registered users and 34 guests