Post by cactustactical » Wed Aug 05, 2015 3:57 am

I am trying to install the Open Cart latest version on a 1and 1 managed server. We have moved all the files as directed, created a database and user on the server and are attempting to run the install script.

It fails repeatedly in step 3 of the 4 step process with the following error:  Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2). I've attached a screen capture of the screen with the error message. I've tried ports 3306 and 3316, neither made a difference.

I've contacted 1and1 support, and other than telling me that the database was created successfully and is accessible, they were not much help.

I used the following script as a file on the root drive of the server to test the database connection and connected, so there is no issue with the MySQL database.

<?php
$hostname="localhost:/tmp/mysql5.sock";
$username="dbo585945742";
$password="myPassword";

$link = mysql_connect("$hostname", "$username", "$password");
if (!$link) {
die('Connection failed: ' . mysql_error());
}
echo 'Connection successful';
mysql_close($link);
?>

Several questions, is there some sort of issue that I haven't seen with the install process for version 2.0.3.1?

Barring that, is there some sort of known issue with the installer on a 1and1 managed server?

Failing any solutions to correct the issue with the installer, does Open Cart have a step by step process to manually install the cart? I've used oscommerce for years, so am able to manually setup carts. I did some searches on the forums, but haven't run into any posts with the same sort of issue.

regards

Attachments

opencart-install-failure.jpg

opencart-install-failure.jpg (187.36 KiB) Viewed 5486 times



Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by JPC60 » Thu Aug 06, 2015 1:36 pm

I'm running in to exactly the same problem, and I've set up several pre-2 versions of OC. I'm on the line now with HostGator hoping for an answer.

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by JPC60 » Thu Aug 06, 2015 2:30 pm

Have been at this awhile with a rep from HostGator, gave them access to my site and they couldn't figure it out either. Very frustrating to blow a couple of hours just to get past this page 3.

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by pm-netti » Thu Aug 06, 2015 5:08 pm

JPC60 wrote:Have been at this awhile with a rep from HostGator, gave them access to my site and they couldn't figure it out either. Very frustrating to blow a couple of hours just to get past this page 3.
http://www.tech-recipes.com/rx/762/solv ... mysqlsock/

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by cactustactical » Thu Aug 06, 2015 10:40 pm

Sadly, I had about the same level of support from the csr's at 1and1. Spent 2 days going back and forth with them and they really did not provide much help.

So, it seems that the installer for v2.xx is not robust enough to handle somewhat common server setup situations. Coming from another ecommerce cart world, I really hoped that Open Cart was going to be a step up. Is using v1.x still a viable solution to meet the demands of current ecommerce needs?


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by pm-netti » Fri Aug 07, 2015 1:56 am

cactustactical wrote:Sadly, I had about the same level of support from the csr's at 1and1. Spent 2 days going back and forth with them and they really did not provide much help.

So, it seems that the installer for v2.xx is not robust enough to handle somewhat common server setup situations. Coming from another ecommerce cart world, I really hoped that Open Cart was going to be a step up. Is using v1.x still a viable solution to meet the demands of current ecommerce needs?
You're barking up the wrong tree? ;)

MySQL server settings are not correct.
A lot of repair advice can be found on Google:

https://www.google.fi/search?client=ubu ... -2cMKQhZgK

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by cactustactical » Fri Aug 07, 2015 2:19 am

We currently have several ecommerce sites running on this server, the most recent being set up about a month ago. So, I will take a look at the links and try and make sense of them, but why would the current settings work for other open source shopping carts we have setup and not open carts installer script? This server is running the default settings it was setup with years ago.


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by IP_CAM » Fri Aug 07, 2015 2:51 am

just, to mention it, my Host only accepts things like:
Host: - - mydbfilename.mysql.db.internal
but not:
Host: - - localhost

Good Luck
Ernie
hitline.info/shop/

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by JPC60 » Fri Aug 07, 2015 2:44 pm

I think I may be fairly typical of many users, I've set up several sites with OC now but beyond the basics of adapting vQmod paths to a 3rd party theme and tweaking a little CSS here and there... not so much. I appreciate the MySQL advice but I'd get in to more trouble than I'd solve.

Today I started again, fresh install on a fresh reseller account. I went as far as to delete the account last night (I know, probably unnecessary) and recreate it this morning.

Anyway today it took, I was able to install 2.0.3.1, not a single rejection on page 3 of 4 of the install. The only thing I did different was to set permissions on the needed folders to 0755 instead of 0777, and I didn't use punctuation or special characters in any of my passwords.

I don't see how this could have solved anything, but the install did go well today. I realize anecdotal tidbits like this aren't worth a heck of a lot... still I thought I'd pass along my follow-up.

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by pm-netti » Fri Aug 07, 2015 5:15 pm

JPC60 wrote:I think I may be fairly typical of many users, I've set up several sites with OC now but beyond the basics of adapting vQmod paths to a 3rd party theme and tweaking a little CSS here and there... not so much. I appreciate the MySQL advice but I'd get in to more trouble than I'd solve.

Today I started again, fresh install on a fresh reseller account. I went as far as to delete the account last night (I know, probably unnecessary) and recreate it this morning.

Anyway today it took, I was able to install 2.0.3.1, not a single rejection on page 3 of 4 of the install. The only thing I did different was to set permissions on the needed folders to 0755 instead of 0777, and I didn't use punctuation or special characters in any of my passwords.

I don't see how this could have solved anything, but the install did go well today. I realize anecdotal tidbits like this aren't worth a heck of a lot... still I thought I'd pass along my follow-up.
There is no safe place full permissions to directories.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by cactustactical » Mon Aug 10, 2015 8:31 am

This weekend, I did try to connect using the actual name of the socket instead of just using localhost. It still failed to connect, so that was not the issue, but was definitely worth a try.

I loaded and installed a new version of the latest oscommerce cart without issue, so I don't see any reason there would be an issue with the MySQL server settings in such a way that only the latest version install of open cart is impacted.

I am curious as to whether anyone has actually installed a cart of c2.0.3.1 on a 1and1 server successfully.

At this point, I am going to give the 1.x version a try to see if the install process will work.


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by IP_CAM » Mon Aug 10, 2015 9:35 am

I remember such a Case, where CHMOD 777 failed, in every case, to even function,
because the Host/Server did only accept that setting in 'very selected' Sections.
The MOST setable value then was 775, to avoid any 'remote' WRITING on
such files. But for OC, 755 should be the highest value, allowed, in most Sections.
Good Luck!
Ernie
Just in Case, here is the latest v.1.5.6.5_rc, ever published on Github:
http://www.opencart.li/downloads/openca ... 6.5_rc.zip

More information on CHMOD Settings, and their purpose,
can be found here. I made this up about a decade ago:
http://everyauction.info/serverinfo.html#5

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by pm-netti » Mon Aug 10, 2015 4:03 pm

cactustactical wrote: I am curious as to whether anyone has actually installed a cart of c2.0.3.1 on a 1and1 server successfully.
I am did upgraded to 1and1 sever.
There were no problems.
Can reason is serverpack level of 1and1?

ps. Your need introduce remote mysql
DB_HOSTNAME is then: xxxxxxxxx.db.1and1.com

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by cactustactical » Wed Aug 19, 2015 7:44 am

I spent some time on this over the weekend. I completely deleted and re-installed v2.0.3.1 twice just for grins. Both times the same error message stopped the install.

So, I got rid of all the v 2.xx scripts and uploaded the current 1.5.xx version. The install worked the first time. Been pretty pleased with the functionality of Open Cart, very intuitive and way ahead of the carts have used in the past.

But, the failed install for v2 almost pushed me to another cart through frustration. The install scripts should not fail on a server rented from one of the largest server farms in the world. Whomever supports those install scripts is welcome to contact me for info because they need to be updated.


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by IP_CAM » Wed Aug 19, 2015 10:38 am

so, what keeping you from just using the latest v.1.5.6.x ? :D
they won't listen to you anyway, especially not, since another Fellow
claim's, to have done it, one the same Environment, without any problem...

But better don't ever take anything personal, around here. It's all about
Money, for everyone, involved, down to the last visitor, coming here, to
hopefully find the long awaited get-rich-quick - Tool, for free, and without
any obligations. Therefore, there is just no Room left for Emotions on OC! 8)

In short:
Take it, or leave it.
Or, as I would say: Take, what works for you, and is proven to work, and just don't (yet) bother about the Rest ;)
Good Luck, NO offense!!
Ernie (_rc-Fan!)

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by cactustactical » Wed Aug 19, 2015 12:11 pm

I am going forward with the 1.5.xx version. Like I said, I find it easier to work with than some of the other open source carts I have used over the last 10 years. I have been quite pleased with how easy it is to setup and get the store running.

Its just it bugs me that people have spent 100's of hours putting together a 2.0 version and it doesn't install correctly on a baseline default server in one of the largest server farms in the world. But, if no one cares, I don't care, I am happy with v1.5.xx.

thanks for the responses :D


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by pm-netti » Wed Aug 19, 2015 3:02 pm

cactustactical wrote:I am going forward with the 1.5.xx version. Like I said, I find it easier to work with than some of the other open source carts I have used over the last 10 years. I have been quite pleased with how easy it is to setup and get the store running.

Its just it bugs me that people have spent 100's of hours putting together a 2.0 version and it doesn't install correctly on a baseline default server in one of the largest server farms in the world. But, if no one cares, I don't care, I am happy with v1.5.xx.

thanks for the responses :D
Do you use this fom config.php?

Code: Select all

define('DB_HOSTNAME', 'xxxxxxxx.db.1and1.com');
Maybe your need do connect to your host, so you can used this way,

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by markjacks » Wed Sep 30, 2015 10:53 pm

Hi Cactus, just curious here. How did the new version upgrade went out for you? Were there any significant improvements?

User avatar
New member

Posts

Joined
Sun Nov 30, 2014 1:48 pm

Post by cactustactical » Wed Sep 30, 2015 11:49 pm

We are playing around 1.5.6.4, learning how it works and the scripts underneath it. We have not tried to do an upgrade to 2.x as of yet, although that is still in the plans.

But, 1.5.6.4 is a pleasure to work with compared to the cart we had been using for our various web sites in the past.


Posts

Joined
Wed Aug 05, 2015 3:38 am

Post by IP_CAM » Thu Oct 01, 2015 11:13 am

Just to keep you updated:
I played around today, after finding this Database Converter to OpenCart 2 Extension, actually by Accident, and I wondered, what it would do, after reading some negative Comments about it. It was my first attempt, to try such a task with a v.1.5.6.x DB on V2, beeing/staying 1.5-freak by Design :D

https://www.opencart.com/index.php?rout ... n_id=20423
---
So, I took my working v.1.5.6.5-DB, containing 4'003 Products, and 'created+downloaded' a V2-compatible DB out of it. It's a one Button Task, by the way, in the OC Admin Section. I THEN JUST had, locally, to Bulk-modify the 16'029 matching image Links, by use of the NOTEPAD++ Bulk Change Function, because on V2, it's not longer:
(image/) data/demo/...
but:
(image/) catalog/demo/...
where images are to be placed, by OC-Default. ( just to make it different, a little, I assume... :-[ )
---
By NATURE OF THINGS, I made sure to have/use the same DB prefix 'oc_', in my first
test, it needed to change 45'000+ prefix entries troughout the DB. to match the Derrivate v2 Shop Configuration!
---
Then, I used a V2 Derrivate Test Site, and restored this V-2 UPGRADED DB by use of a V2 Admin DB Restore Function.
---
It produced a single line error message, on top of the Browser Page, during the DB installation process, telling me, that the INDEX 'de' is missing, or not defined, probably some leftover from an earlier german Translation, on one
of the 'Places', I assume. Then, later on, after Upload STILL ended full in Order, and I started the SHOP, it told me, that EURO seems not VALID yet, als Value, seemengly called/used from/by 'somewhat'. So, I defined EURO to be my second Currency, in the Admin Section, went back to the Shop and reloaded the Page, and the Error was gone.
---
I then killed the Derrivate Shop, used for some v2 Tests before, and installed OC Release Candidate v2.1, just to find out, on a virgin OC, and after defining the EURO as well, like in the first v2-(derrivate), it worked ::) !

http://www.jti.li/shop/

Conclusion: Great to make first steps, and tests, by use of a real LOADED DB! Then, one can compare! For this, it seems, that , this Database Converter to OpenCart 2 Extension does am ecellent Job. It will make even an Enriched/Mod-added V.1.5.x DB compatible with V.2. But it CANNOT Know, what Extensions, and Add-On's, one has possibly used in an older Version Shop. Therefore, it is advised, to either uninstall or even remove as many as possible Custom Extensions, in order to avoid, having their Values 'active', or the chance will raise, that the NEW Shop cannot handle them, eventually! But then, it's not a Problem of this Mod! AND ALL SUCH TASKS should be made exclusively by USE of the OC DEFAULT THEME, and possibly english Language!

Good Luck
Ernie
openshop.li/shop/

PS. Not to forget, what happen, the first time, trying to start OC v.2.1, TRYING TO GET IN, as ADMIN, and just,
because I put some unused yet images into the default 'regular' Size image Sub, and one of them was possibly a little 'bent', due to a prematurly ended upload, or then the Shop did/does not accept 'foreign' images in general ?! I have no idea so far, why such can happen... ???

New virgin Opencart v.2.1 Install:
Notice: getimagesize() [function.getimagesize]: Read error! in /home/.... :o
http://forum.opencart.com/viewtopic.php ... 21#p566556

and all this just, because, unfortunately, my Subdomain Image v.1.56.x Solution does not longer work on/with OC2.
I had to reupload 1700 main images to see one of them... :-\

I have to find/talk with someone on this..., it needs to be solved.

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 10 guests