Post by Coolguy Sai » Fri Apr 24, 2015 7:41 pm

Hi,

i going to start new site for my store.

can someone please help for selecting which version i have to choose.

After reading topics i came to know that OC 1.5.6 was the stable version.

But i need responsive as many of my customers only use mobile.

Please confirm me can i use OC 2.0.2.0 in my live shop or it is still in beta.

Also confirm me best stable version in OC.

T&R
Coolguy

Newbie

Posts

Joined
Sat Apr 04, 2015 6:29 pm

Post by pm-netti » Fri Apr 24, 2015 7:53 pm

Version 2.0.20 is not Stable, best 2.x version is yet 2.0.1.1, but also it is few bugs.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by Coolguy Sai » Sat Apr 25, 2015 12:47 am

tnx for reply

Please post top sites that are running on OC 2.0

Newbie

Posts

Joined
Sat Apr 04, 2015 6:29 pm

Post by EvolveWebHosting » Sat Apr 25, 2015 5:42 am

All software has bugs to some degree. Overall, I think 2.0.2.0 is just fine for most shops. The biggest problem I see is the lack of modules but I've got sites using 2.0.2.0 with no major downfalls.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by rph » Sat Apr 25, 2015 6:26 am

SMTP is broken in several places which is a significant issue. Given the state of the GitHub repo there's no chance of a quick bug fix release either. There were also backwards compatibility breaks for ocMod scripts using multi-pathing. That was never stated in the change log, so yeah.

At this point every 2.x release has had issues. Every. Single. One. It would be crazy to use it in production unless you were a dev or had very strong troubleshooting skills.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by IP_CAM » Sat Apr 25, 2015 7:05 pm

>> it would be crazy to use it in production unless you were a dev or had very strong troubleshooting skills.<<

But then, it should, at least, be published, in some way, on the Page, where it can be downloaded. I guess, it would help peoples to, at least, understand, that they're just playing around with a, kind of, prototype-version, Software, and not a real working shop. :-\

Just my personal point of view! Sorry!
Ernie

I don't use the Forum Mailer, to reach me, contact: jti@jacob.ch
-
Demoversions:
OpenCart LIGHT v.1.5.6.5 http://www.bigmax.ch/
OpenCart V-PRO v.1.5.6.5 http://www.ebikes.li/shop/
-
1'700+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by rph » Sun Apr 26, 2015 3:06 am

The community has been trying to get the situation improved for years and years. The only time it improved was when Qphoria was in charge of maintenance on the 1.4.x branch.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by yodapt » Sun Apr 26, 2015 6:49 am

rph wrote:The community has been trying to get the situation improved for years and years. The only time it improved was when Qphoria was in charge of maintenance on the 1.4.x branch.
It will happen eventually. I've been scratching myself to get on with it but accepted about some weeks ago a big project and it's gonna take a bit longer to finish so I couldn't afford yet to get my hands on it, but there are more people as far as I know that are doing their part.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by vnabc » Sun Apr 26, 2015 7:32 am

If it's a new store, I suggest to go with this new version. I have my site up and running. It still have issue with extension installation, but I did manage to overcome a few.

I bought 3 extension and 1 theme for my site
1. Theme installed no issue
2. 1 extension installed no issue
3. 1 extension I asked Dev who created the extension that I bought to install manually for me
4. 1 extension I manually installed it and create table in MySQL to make it works.

Also, search for bug fixes in the forum or Google around is also a good idea ;D

Newbie

Posts

Joined
Thu Apr 16, 2015 1:51 am

Post by virgotch » Sun Apr 26, 2015 8:47 pm

if you want to make a live webshop OC 1.5.6.4 is most stable version for now . all 2.x versions has own bugs and problems
almost everymonth new 2.x version release before they fix older release problems )) it is business style . we still use 1.5.6.4 version and i recommend you also to use 1.5.x versions with mobile template.

New member

Posts

Joined
Sun Oct 26, 2014 4:10 am
Who is online

Users browsing this forum: No registered users and 43 guests