Post by zedrally » Wed Feb 25, 2015 2:21 pm

Just an addition, I asked my host if they had loopback enabled, to which they confirmed they had.

So, it may not just be this that is affecting the smooth running.

I'm reluctant to "junk" this store so if anyone has any further suggestions, I'm all ears.

Active Member

Posts

Joined
Mon Sep 29, 2014 12:12 pm

Post by wgarciajr » Wed Feb 25, 2015 7:26 pm

I am very disappointed with this situation. Unfortunately OpenCart 2.0.1.1 just does not work. Or you produce a platform that works on most servers or mandatory at the time of installation should check the minimum requirements for its operation.

I feel orphaned without having to turn to.

But I am sure that the problem is platform really and not the server.

Newbie

Posts

Joined
Mon Feb 23, 2015 10:06 pm

Post by nhucbcb » Thu Feb 26, 2015 6:47 pm

spawacz_rider wrote:Hi


I have just install new version of open cart 2.0.1.1
And i have similar problem to version 2.0.1.0

I can't edit orders when i press on Continue buton nothing is happening

But this time I don't have any pop-up with errors on Chrome and IE
but on Firefox i have SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data
deleting order is not possibile as well
The php error log is clear from any faults.



Any idea?

I'm not php master I just have average level of html5 and css.
Please help
Hi,

Your problem is caused by:
1) Your site is Maintenance Mode. Please try disable it in In Opencart Admin, go to System >> Settings >> Edit >> Server tab >> Maintenance Mode: NO
2) Your language(new language) was error. Please try re-install the English language.
3) API user: In Opencart Admin, go to System >> Settings >> Users >> API and create a new user then go to System >> Settings >> Edit >> Option tab >> API User >> choose new API
4) Your hosting did disable the 443 port. Please try edit the file: admin/config.php
find the code:
define('HTTPS_CATALOG', 'https://yoursite.com/');
change to:
define('HTTPS_CATALOG', 'http://yoursite.com/');

change "https" to "http"

Newbie

Posts

Joined
Thu Feb 26, 2015 6:22 pm

Post by zedrally » Mon Mar 02, 2015 12:11 pm

Update:

After re-reading this thread and attempting all the suggestions except the Server side possibility, I called my hosting company and explained the situation, initially they pointed the finger at OC, however when confronted with the question if http loopback was active, I received a wait a moment I'll check. After about 10 mins I was informed that it was, the tone of voice indicated that they had done something, yes...OC 2.0,1.1 is now fully operational, so never think it can't happen to me, because it can and most likely will.

Active Member

Posts

Joined
Mon Sep 29, 2014 12:12 pm

Post by octavian13 » Wed Mar 04, 2015 11:52 pm

After I have read all the answers and none was resolving my same problem, I have found this solution:

add in admin/config.php

define('HTTPS_CATALOG', 'http://www.yoursite.com/');

Newbie

Posts

Joined
Wed Mar 04, 2015 11:49 pm

Post by rlasmar » Sun Mar 15, 2015 2:55 am

Someone know how to enable loopback on server by yourself, it is a VPS. What can be changed? Wich file?

Newbie

Posts

Joined
Mon Nov 26, 2012 10:15 pm

Post by corphunter » Sun Mar 15, 2015 10:49 pm

I had the same problem for a long time, but this is what i did to fix it.

1. Disable the Maintenance Mode in admin > System > Stores > Your store > tab Server.
2. Go to Admin > System > Users > API > Create new API account.
3. Go to Admin > System > Settings > Edit your store > Select tab Option > Checkout section > set API User to the created account.
4. Try to edit order again, you will see the problem is fixed.

Newbie

Posts

Joined
Sun Mar 15, 2015 10:44 pm

Post by adamccol » Thu Mar 19, 2015 8:51 am

THANK YOU DAZZYWEB!!

This issue had me stumped for weeks. Your solution works a treat for me. Sorry, I have no idea why it works. Perhaps it is a typo and it should actually be a https address defined?

I wonder if we should also change the https in the root config.php file also?

If an experienced person could explain why this fix appears to work, I would also like to know.

Thanks again dazzyweb!

For anyone else who may have missed this fix, it is here:
http://forum.opencart.com/viewtopic.php ... 40#p539225

Newbie

Posts

Joined
Thu Mar 19, 2015 8:46 am

Post by sli1 » Thu Mar 19, 2015 8:03 pm

I have the same problem and fixed it by ensuring the httpd settings are correct. :)

Newbie

Posts

Joined
Thu Mar 19, 2015 7:45 pm

Post by suntzu » Fri Mar 20, 2015 3:19 pm

I have the same problem also!

I submitted a help request to Opencart staff, but they did not answer. I think no one knows what is wrong!

P.S. also did tryed everything---API user, maintainance mode, changed payment methods, etc

Newbie

Posts

Joined
Thu May 26, 2011 6:31 pm

Post by webfeetdesign » Sat Mar 21, 2015 10:06 pm

I've had enough of this version of OC. I highly recommend binning this version. I have taken a huge risk and won't do it again. I feel like i've wasted months of hard work and all I keep finding is new bugs. OC 1.5 was just running perfect but I was too blind by the fancy responsive admin panel.

I can't fix the 'edit order' bug so think i'll give up.

RANT OVER

Active Member

Posts

Joined
Fri Feb 05, 2010 1:28 am
Location - Dubai

Post by BnetAdmin » Sun Mar 22, 2015 9:21 am

SO... I'm in the middle of trouble shooting this one and I've done almost everything that has been described in this thread plus more..

Removed and re-added API user, ensured it was properly mapped in the SQL database, checked and added missing HTTPS_CATALOG entry, changed that from http to https as some noted and still have the same basic useless error of syntaxerror unexpected end of input.

What is this deal with hosts having Loopback blocking enabled? Can I get some more info so I can contact my host about this and see what they say.

This is very frustrating since we use this store but once a year to have members register for a car event and now I'm in the middle of registration and I can't complete their orders and send them the correct info for hotel arrangements... I need this fixed asap.

Newbie

Posts

Joined
Sun Mar 22, 2015 9:15 am

Post by JohnFPL » Tue Mar 24, 2015 3:14 pm

I too have the same problem.

I have tried the https solution, a new API user, and switching maintenance mode on then off. Last resort, I have asked the hosting company (namesco) to check regarding http loopback. I'm not too hopeful as they have proved non too helpful in the past.

I have spent a long time trying to emulate an OC 1.5.2.1 site and this final hurdle is a real show-stopper. I have a number of other sites to upgrade but if the order editing can not be fixed I guess it is the end of the road for 2.0.1.1 at least.

New member

Posts

Joined
Sat May 04, 2013 7:43 pm

Post by JohnFPL » Thu Mar 26, 2015 3:29 am

Well, I finally have a response from Namesco regarding http loopback. No surprises, HTTP Loopback is not available on the shared platform!

They recommend checking with the creators of the software to see if this feature is entirely essential and if they have any workaround for servers that do not support this specific functionality.

Alternatively, if I require this feature enabled then I can take out a VPS or Dedicated Server where I would be in control of the resources of the entire server. And the cost is way beyond what a small business can justify.

Good old Namesco, whatever the cause of an issue (emails going missing from web servers, emails being bounced as Namesco have been blacklisted) they never miss the opportunity to try an upsell.

I could really do with an alternative solution as being unable to edit orders is a major issue. Anyone...please...

New member

Posts

Joined
Sat May 04, 2013 7:43 pm

Post by gremaley » Tue Mar 31, 2015 10:39 pm

Observation only - maybe this will help somebody....

2.0.1.1 installed on windows server - edit order works fine!
2.0.1.1 installed on Ubuntu server - edit order works fine!
2.0.1.1 installed on Linux server (Centos6) - edit order EPIC FAIL!

Newbie

Posts

Joined
Sun Mar 29, 2015 10:12 pm

Post by WCS » Mon May 11, 2015 5:15 pm

My problem is with 2.0.2.0, but as it is the same I will reply here.

I too get the error Warning: CURL error Failure when receiving data from the peer(56)!

I have made the changes suggested here; API, config.php, etc.

I have spoken to my hosting supplier, CloudNext and they (quite rightly) say:

"This looks to be caused by the fact that open cart are now attempting to create loopback connections which are not support on the shared platform.

Loopback connections are blocked for a good reason on shared hosting (used incorrectly or maliciously it could take down the server) and many shared hosting companies do the same thing. So if OpenCart now require this on their very latest version then they're going to encounter a lot of people with non-functioning OpenCart sites, therefore I'll assume they'll release a work around or update."

Luckily, I expected there to be problems so I made sure that I could revert quickly and easily, which I have now done.

I really needed and wanted the default responsive theme, so if OpenCart can't/won't change this then I will need to look elsewhere, which I really don't want to do.

Many thanks,

Andrew

Andrew

Andrew Hopps

[url]htttp://www.crystalsuncatchers.co.uk[/url]

[url]htttp://wholesalecrystalsuncatchers.co.uk[/url]


WCS
Newbie

Posts

Joined
Wed Jan 23, 2013 6:35 pm
Location - United Kingdom

Post by sculptex » Mon May 11, 2015 5:23 pm

I just posted a WORKAROUND for this, only tested with 2.0.2.0 at the moment
http://forum.opencart.com/viewtopic.php?f=190&t=144618

ImageImage


User avatar
Active Member

Posts

Joined
Tue Sep 13, 2011 3:07 am
Location - UK

Post by JNeuhoff » Mon May 11, 2015 6:42 pm

I haven't had a chance to test it on a shared webhost account yet, but will do so soon, and will then have to find a workaround for this local loopback issue. Has anyone written up a bugfix for this yet, e.g. as a VQmod XML script? It shouldn't be too hard to do so.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by WCS » Tue May 12, 2015 3:01 pm

Hi,

To add to my previous post, other than the obvious fact that it doesn't work on a shared host, OC2 is a major improvement on OC1.5. When I looked at our site side by side in OC1.5 and 2, the new version was massively fresher looking and much, much neater. Add to that the fact that it is responsive, it is a no-brainer to want/need to migrate to it.

I am really looking forward to a fix to the loopback issue as I am keen to make my migration to OC2 permanent.

Thanks,

Andrew

Andrew

Andrew Hopps

[url]htttp://www.crystalsuncatchers.co.uk[/url]

[url]htttp://wholesalecrystalsuncatchers.co.uk[/url]


WCS
Newbie

Posts

Joined
Wed Jan 23, 2013 6:35 pm
Location - United Kingdom

Post by mcpop » Wed May 13, 2015 9:39 am

I had similar problems. And frustration. And anger.

It turned out to be my fault. I had set Basic Auth in .htaccess (while I was building the site) and this borked the admin module.

I removed the Auth requirements in .htaccess and now the orders mod/delete all works fine.

HTH

McPop.

Newbie

Posts

Joined
Wed May 13, 2015 9:22 am
Who is online

Users browsing this forum: No registered users and 33 guests