Post by spawacz_rider » Sun Dec 07, 2014 4:35 am

Hi


I have just install new version of open cart 2.0.1.1
And i have similar problem to version 2.0.1.0

I can't edit orders when i press on Continue buton nothing is happening

But this time I don't have any pop-up with errors on Chrome and IE
but on Firefox i have SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data
deleting order is not possibile as well
The php error log is clear from any faults.



Any idea?

I'm not php master I just have average level of html5 and css.
Please help

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by spawacz_rider » Sun Dec 07, 2014 10:07 pm

No one have the same problem??

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by JNeuhoff » Sun Dec 07, 2014 10:29 pm

spawacz_rider wrote:No one have the same problem??
Nope, it's just you :)

Use Firefox, works fine. Why is anybody using IE?

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by lz1nud » Sun Dec 07, 2014 11:30 pm

spawacz_rider wrote:No one have the same problem??
It works fine for me too.

Sky-Mag Bulgaria


Active Member

Posts

Joined
Thu Feb 13, 2014 5:35 am
Location - Bulgaria

Post by spawacz_rider » Mon Dec 08, 2014 2:39 am

Use Firefox
Im having error with Firefox Chrome and IE

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by pm-netti » Mon Dec 08, 2014 2:59 am

spawacz_rider wrote:Hi


I have just install new version of open cart 2.0.1.1
And i have similar problem to version 2.0.1.0

I can't edit orders when i press on Continue buton nothing is happening

But this time I don't have any pop-up with errors on Chrome and IE
but on Firefox i have SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data
deleting order is not possibile as well
The php error log is clear from any faults.



Any idea?

I'm not php master I just have average level of html5 and css.
Please help
Have you created an API user (if you only updated files)?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by spawacz_rider » Mon Dec 08, 2014 5:36 am

yes i have API set

i did not update anything is clean install on FTP server

I have same problem since 2.0.0.0 v

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by gob33 » Tue Dec 09, 2014 2:05 am

All these JSON errors you see there came from API and Curl. Curl returns in certains conditions an error message which breaks json data. Then parsing that data in ajax fails. In 1.5.6.4 html was returned, now it's json and many problems occurs because of the conception.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by spawacz_rider » Tue Dec 09, 2014 2:24 am

So what I need to do to fix this.
Like I said I'm not expert can somone point to me how I can fix it?

It looks like I only have this problem?

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by pm-netti » Tue Dec 09, 2014 2:54 am

spawacz_rider wrote:So what I need to do to fix this.
Like I said I'm not expert can somone point to me how I can fix it?

It looks like I only have this problem?
And api_id is 1 in table api?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by spawacz_rider » Tue Dec 09, 2014 3:24 am

In api_id i have only one user and is maching the one from back end from OpenCart

I just set the same version of OC 2.0.1.1 on XAMPP on my pc and everything is runing fine.

So i just guess the problem is in my FTP provider
I'm using Hart Internet

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by pm-netti » Tue Dec 09, 2014 3:33 am

spawacz_rider wrote:In api_id i have only one user and is maching the one from back end from OpenCart

I just set the same version of OC 2.0.1.1 on XAMPP on my pc and everything is runing fine.

So i just guess the problem is in my FTP provider
I'm using Hart Internet
Sorry, what is value in your database in table 'api', field 'api_id'?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by spawacz_rider » Tue Dec 09, 2014 3:44 am

Image

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by pm-netti » Tue Dec 09, 2014 3:54 am

And API status is 'Enabled' ( in route user/api/edit ) ?
----
Ps. My test in route sale/order/edit:

Code: Select all

 Payment method required! 
Payment method is selected.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by spawacz_rider » Tue Dec 09, 2014 4:45 am

The API is enabled in back end of Open Cart do I need to enable this somewhere else?

What you mean payment method is required

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by pm-netti » Tue Dec 09, 2014 5:40 am

spawacz_rider wrote:The API is enabled in back end of Open Cart do I need to enable this somewhere else?

What you mean payment method is required
That 'red' warning text show in order edit page.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by huha » Tue Dec 09, 2014 6:02 am

Hello.
I have the same problem.
On a fresh install i cannot modify orders or delete them.
When i install Open Cart i see in system=>settings=>default sore name => option=> API User that was empty.


From there i go to system => users=> api and create a user with a generated password.
After this i start configuring the store.

Now i`m trying to modify orders and i can not . I delete the API user , created another one with a generate password again and modify the api ID back to 1, logout , i create an order , the login to the admin user and still can not modify the orders.

The store is not on Maintenance Mode

On others installs there was a API user created by the install and i had no problems with editing orders. On one install , again i did not have an API user and i had the same problem with "SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data OK"

Anything else that could help me or you guys to figure out the problem ? How can i have a working API user again ?

Thank you.

Attachments

open cart error2.JPG

the api id is 1 - open cart error2.JPG (93.22 KiB) Viewed 14354 times

open cart error.JPG

the error when i try to edit an order - open cart error.JPG (62.46 KiB) Viewed 14354 times


Newbie

Posts

Joined
Tue Dec 09, 2014 5:37 am

Post by spawacz_rider » Tue Dec 09, 2014 7:00 am

pm-netti wrote:
spawacz_rider wrote:The API is enabled in back end of Open Cart do I need to enable this somewhere else?

What you mean payment method is required
That 'red' warning text show in order edit page.


There is no warning. only pop up from browser

SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data

OK

Newbie

Posts

Joined
Fri Nov 28, 2014 6:46 am

Post by gob33 » Tue Dec 09, 2014 7:09 am

Dont try to debug JSON alerts. It is burried deep inside and is a conception problem.
How many people have already signaled SyntaxError: JSON.parse: unexpected end of data ... ?
Stop using 2.0, it is not reliable, wait until the situation becomes clear, and team get concious something wrong with curl and json.

All my extensions


Active Member

Posts

Joined
Wed Feb 10, 2010 8:43 am
Location - France

Post by pm-netti » Tue Dec 09, 2014 8:58 pm

gob33 wrote:Dont try to debug JSON alerts. It is burried deep inside and is a conception problem.
How many people have already signaled SyntaxError: JSON.parse: unexpected end of data ... ?
Stop using 2.0, it is not reliable, wait until the situation becomes clear, and team get concious something wrong with curl and json.
Check, is it cURL in use your Server:
This can save to name 'wwwstorecom/curl.php' and check it:

Code: Select all

<?

// Script to test if the CURL extension is installed on this server

// Define function to test
function _is_curl_installed() {
    if  (in_array  ('curl', get_loaded_extensions())) {
        return true;
    }
    else {
        return false;
    }
}

// Ouput text to user based on test
if (_is_curl_installed()) {
  echo "cURL is <span style=\"color:blue\">installed</span> on this server";
} else {
  echo "cURL is NOT <span style=\"color:red\">installed</span> on this server";
}
?>

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland
Who is online

Users browsing this forum: No registered users and 56 guests