Post by alevel18 » Fri Nov 14, 2014 2:29 am

Hi everyone,

I appreciate your support.

When I search for a product a sidebar appears on my page (example): http://******.co.uk/index.php?route=product/search_tyre&filter_type=A

This also appears on pretty much all pages, however, when I click on the 'products' page it doesn't appear (example): http://******.co.uk/index.php?route=product/manufacturer/info&manufacturer_id=16

I've tried searching in system settings and templates, but can't find anything.

Kindly help ???
Last edited by alevel18 on Thu Nov 20, 2014 5:30 am, edited 1 time in total.

Newbie

Posts

Joined
Mon Mar 19, 2012 11:53 pm

Post by uksitebuilder » Fri Nov 14, 2014 3:08 am

Check your Extensions - Modules - edit Category Module

See if there is a layou for the Product Layout added with all the others

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by alevel18 » Wed Nov 19, 2014 4:18 am

When I got there I see this:

Layout: Position: Status: Sort Order:
Product Column Left Enabled 1

It seems that it is enabled, but no matter what settings I change it still doesn't show.

Could something be over riding it?

Newbie

Posts

Joined
Mon Mar 19, 2012 11:53 pm

Post by uksitebuilder » Wed Nov 19, 2014 4:47 am

Ahh looking at it now, it does not seem to be the category module, but a different module altogether.

In your extensions - modules, check the list of modules to see if yu can figure out which one it is and then make sure it has a layout set for the product layout.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by alevel18 » Wed Nov 19, 2014 11:39 pm

You're right! I've managed to locate the module called 'Information Page' that has an option to choose where to place modules created from 'Catalog --> information'

I'm assuming they are addons I've installed and not part of the original opencart?

The problem is, when i play around with the module I am able to edit every single page (default, product, checkout etc) but NOT the manufacturer page. It just seems to NOT display any left sidebar. It does work when I select 'column right' but not 'column left'

Any idea why?

Newbie

Posts

Joined
Mon Mar 19, 2012 11:53 pm

Post by uksitebuilder » Thu Nov 20, 2014 12:05 am

Well, it's a custom theme, so I am guessing the template (.tpl) file for manufacturers is missing the the left content coding

On the default theme, the very top of the page code looks like the following:

<?php echo $header; ?><?php echo $column_left; ?><?php echo $column_right; ?>


Notice the column left

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by alevel18 » Thu Nov 20, 2014 5:28 am

That's what it was! Fantastic - I really really appreciate you taking time to help. You're a supperstar!!!! ;D

Newbie

Posts

Joined
Mon Mar 19, 2012 11:53 pm

Post by edgarcelso » Sun Dec 22, 2019 10:01 am

uksitebuilder wrote:
Wed Nov 19, 2014 4:47 am
Ahh looking at it now, it does not seem to be the category module, but a different module altogether.

In your extensions - modules, check the list of modules to see if yu can figure out which one it is and then make sure it has a layout set for the product layout.
thanks a lot uksitebuilder, it works for me

Newbie

Posts

Joined
Mon Dec 09, 2013 6:08 am
Who is online

Users browsing this forum: No registered users and 9 guests