Post by blmg911 » Mon Oct 13, 2014 6:34 pm

Hi, I have set up a test environment for my store which runs 1.5.5.1;

Updating to 2.0, I have the usual issues and managed to fixed them by editing the code.

However I still get this error:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 64 bytes) in /system/library/db/mysql.php on line 40

I have changed the allowed memory size as high as 500M.

And still this error is thrown out.

Any ideas?

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by alin » Mon Oct 13, 2014 6:54 pm

It's depend on what Virtual Server software you are using

For me, I'm using Appserv, I do the setting for php.ini from config menu of Appserv.

The right php.ini location for my case is Windows/php.ini (I'm using Appserv on Windows 7)

Hope this help

GOLDEN LEOPARD SYSTEM SOLUTION
An ICT System Solution Company in Vietnam
Website: Store: http://shopcartplus.com or http://www.opencart.com/index.php?route ... rname=alin


User avatar
Active Member

Posts

Joined
Fri Jun 10, 2011 8:16 pm


Post by blmg911 » Mon Oct 13, 2014 6:59 pm

I have set this up on my virtual private sever; Which is online;

OS is Debian GNU/Linux.

I'm not testing locally.

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by pm-netti » Mon Oct 13, 2014 7:16 pm

blmg911 wrote:I have set this up on my virtual private sever; Which is online;

OS is Debian GNU/Linux.

I'm not testing locally.
My php.ini:

Code: Select all

post_max_size = 20M
upload_max_filesize = 20M

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by blmg911 » Mon Oct 13, 2014 7:27 pm

It doesn't seems to be the allowed memory setting in the php.ini file, as if I change this as high as 500M it will still create an error.

There must be some bad code somewhere that is using all this memory.

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by blmg911 » Mon Oct 13, 2014 7:29 pm

If I change to mysqli, I still get the following error:

Fatal error: Allowed memory size of 260046848 bytes exhausted (tried to allocate 523800 bytes) in /system/library/db/mysqli.php on line 16

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by i2Paq » Mon Oct 13, 2014 7:46 pm

What if you do a clean install of 2.0?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by pm-netti » Mon Oct 13, 2014 8:08 pm

blmg911 wrote:If I change to mysqli, I still get the following error:

Fatal error: Allowed memory size of 260046848 bytes exhausted (tried to allocate 523800 bytes) in /system/library/db/mysqli.php on line 16
Have you made changes in file /etc/php5/... php.ini file, or only trade of root to the file?

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by blmg911 » Mon Oct 13, 2014 8:43 pm

I have changed both the file in the root folder, and the php.ini within my sever.

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by blmg911 » Mon Oct 13, 2014 9:00 pm

i2Paq wrote:What if you do a clean install of 2.0?
Yeah I have also done a clean install, again on a VPS as a test (this issue does not exist).

It seems that the issue is only present when upgrading from 1.5.5.1.

As mentioned, this currently isn't affecting my web store as I have duplicated my original store's scripts and database and set it up online to test out the code and help find any bugs present.

New member

Posts

Joined
Fri Oct 10, 2014 10:36 pm

Post by i2Paq » Mon Oct 13, 2014 9:15 pm


Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by kwton » Tue Oct 14, 2014 5:52 am

pm-netti wrote:
blmg911 wrote:If I change to mysqli, I still get the following error:

Fatal error: Allowed memory size of 260046848 bytes exhausted (tried to allocate 523800 bytes) in /system/library/db/mysqli.php on line 16
Have you made changes in file /etc/php5/... php.ini file, or only trade of root to the file?
but, that is not the case!
I believe allowed memory is meant either accessing the available ram or writing to the database, php uploading & http post has nothing to do with that error.

Try a clean install first, do not try to merge the opencart versions.

add to that, opencart includes it is own php.ini configuration ( apache module enabled by default ? ).

And yeah, return the php.ini to default value, 500Mb will break your server.
did you even run

Code: Select all

 # service apache2 restart 
to apply the changes ?

Newbie

Posts

Joined
Tue Oct 07, 2014 7:52 pm

Post by rph » Tue Oct 14, 2014 6:38 am

Yeah, we're definitely at an early point where you shouldn't be upgrading to 2.0 unless you have strong dev skills.

@blmg911 - the error states you have a 260MB memory limit. Without knowing exactly what SQL query is being run you'll need to increase the memory limit again to complete the operation. You'll need to make sure that your global php.ini setting isn't overriding the local memory limit.

If that doesn't work fall back to your local machine to run the upgrade. That way you can leverage as much RAM as your local machine has. Then upload the upgaded database to your VPS.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska
Who is online

Users browsing this forum: No registered users and 1 guest