Post by dfumagalli » Fri Apr 18, 2014 3:45 pm

@Ernie

I really see where you are coming from (my first computer was a Commodore Vic 20, with all of it's massive 3583 bytes free!).

I feel some of your concerns could use a richer discussion but here it's not on topic. Where i's really on topic is on my thread: OpenCart needs and deserves more "meta" and visibility which covers some of your concerns and adds more.

In closing, yes, I have been quite surprised to see how the official 1.5.6 Zip distribution had that bug.
I did not go check some exotic Github nightly build or something, like thousands of other guys new to this fantastic product I just went to the official downloads page and got the stable release available at the time.
By the way I have just re-checked to make sure I am not dreaming: that very same 1.5.6 ZIP file is still available on the official download page on this website) right today and I have just re-downloaded, unzipped and checked it still has that bug.

But the surprise was not really about the bug per se (I program since 33 years, I have seen a TON!) but seeing random people posting again and again about how order emails would not work and yet not be believed and some times belittled (by other posters, not the OpenCart team).

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by IP_CAM » Sat Apr 19, 2014 11:14 am

The OC Mailings are generally poor, I agree, I was used to create beautyfull Text-Mailforms for my Auction Scripts, they started with "Congratulations, Steve ... or whoever ", lined out and containing everything down to the last detail and link.

I am used to downloading/opening Mails in Textformat ONLY, after prechecking them with my old Email Remover on the Server for Content first, I hate to be forced to open Mails in HTML just to get the information I need to know. On the other Hand, I never had any of my PC's infected ever, downloading thousands of things and visiting thousands of Sites during all those Years.

The OS/OC Mail Part will be one of those things I still need to have a look into.
Ernie

PS: regarding Posters, I was not expecting lots of enthusiastic free 'Donators', when I came here, there is to much money involved. I am also used to some styles on Forums, it does not bother me, if some think I'm an Idiot. I know I'm one, or then, I would be in Bed, not here...

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by JNeuhoff » Sat Apr 19, 2014 10:20 pm

dfumagalli wrote: But the surprise was not really about the bug per se (I program since 33 years, I have seen a TON!) but seeing random people posting again and again about how order emails would not work and yet not be believed and some times belittled (by other posters, not the OpenCart team).
In all fairness, we get so-called bug/error reports all the time which are so insufficient, no details, no attached error messages, that I usually tend to ignore them now. Here is a recent example:
Hi! on my version of your module does not work. help configure
And then, quite often when we post suggestions on how to narrow it down or solve it, we don't hear back from them!

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by IP_CAM » Sat Apr 19, 2014 11:59 pm

dfumagalli wrote:@Ernie
I really see where you are coming from (my first computer was a Commodore Vic 20, with all of it's massive 3583 bytes free!).
my reply to computing, it would not match here...
http://forum.opencart.com/viewtopic.php?f=16&t=123790

Ernie

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Sun Apr 20, 2014 12:22 am

JNeuhoff wrote:In all fairness, we get so-called bug/error reports all the time which are so insufficient, no details, no attached error messages, that I usually tend to ignore them now. Here is a recent example:
I fully agree. as beeing part of some script-scene's for some time, I know how it goes. It's just not possible to work without a usable bases on information. More, OC exists in 'many forms and variations - who could possibly know how all that Stuff, offered by uncounted individuals - partly rewritten by Newbie's (like me) really functions!? I wonder, that, so far, I have only found one HIDDEN thing, possibly enabling OC to eventually transmit any 'classified' information to third party patricipants without me beeing aware of it. There are actually no strict or even enforcable rules, VQMODDING enables everything down to total System-Collapse.

The System is NOT the Problem, the Problem are the Users. Or, at least, those, creating a part of their income by offering paid Services to individuals, looking for a safe Shop. Why should One of them spread knowledge about whatever to others, realizing, that they would just profit out of this knowledge, without doing the same in Reply.

This is 'default' human Behaviour, nor even bad thinking. The only thing to do is to Call onto all participants of this Scene here to 'rethink' the Open Source IDEA, without it, most Internet-Players would not be able to use something like OpenCart today.

Ernie

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by rph » Sun Apr 20, 2014 2:22 am

JNeuhoff wrote:
dfumagalli wrote: But the surprise was not really about the bug per se (I program since 33 years, I have seen a TON!) but seeing random people posting again and again about how order emails would not work and yet not be believed and some times belittled (by other posters, not the OpenCart team).
In all fairness, we get so-called bug/error reports all the time which are so insufficient, no details, no attached error messages, that I usually tend to ignore them now.
Email issues are also very difficult to diagnose. The user may have entered the wrong settings, the server could be misconfigured, or emails could be getting filtered as spam. And you never get anything useful for diagnosing the issue like a dovecot or server log. It's just "email doesn't work".

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by dfumagalli » Wed Apr 23, 2014 10:51 pm

rph wrote:
JNeuhoff wrote:
dfumagalli wrote: But the surprise was not really about the bug per se (I program since 33 years, I have seen a TON!) but seeing random people posting again and again about how order emails would not work and yet not be believed and some times belittled (by other posters, not the OpenCart team).
In all fairness, we get so-called bug/error reports all the time which are so insufficient, no details, no attached error messages, that I usually tend to ignore them now.
Email issues are also very difficult to diagnose. The user may have entered the wrong settings, the server could be misconfigured, or emails could be getting filtered as spam. And you never get anything useful for diagnosing the issue like a dovecot or server log. It's just "email doesn't work".
A whole generation of OC 1.5.6 users could never post a dovecot or server log, because the release OC code had two leftover lines of code (see my report above) that would cause a PHP error and would never lead to a mail being generated to begin with. Therefore, no logs to speak of :P

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by rph » Wed Apr 23, 2014 11:03 pm

Wrong. If there's a PHP error there's a log, one in OpenCart and one for the server.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by dfumagalli » Thu Apr 24, 2014 4:11 pm

rph wrote:Wrong. If there's a PHP error there's a log, one in OpenCart and one for the server.
You mean, like this?

Code: Select all

2013-06-19 5:00:37 - PHP Notice:  Cannot find controller class file for route 'mp3-players' in /var/www/removed.com/public_html/system/engine/factory.php on line 152
2013-06-19 8:21:47 - PHP Notice:  Cannot find controller class file for route 'apparel/hoodies/the-get-up-kids-band-camp-pullover-hoodie.html' in /var/www/removed.com/public_html/system/engine/factory.php on line 168
2013-06-19 9:39:36 - PHP Warning:  session_start(): The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,' in /var/www/removed.com/public_html/system/library/session.php on line 11
2013-06-19 9:39:36 - PHP Notice:  A session had already been started - ignoring session_start() in /var/www/removed.com/public_html/system/vendor/facebook-sdk/facebook.php on line 37
...
2014-04-15 18:15:35 - PHP Notice:  Cannot find controller class file for route 'product/add' in /var/www/projects/removed/public_html/system/engine/factory.php on line 168
2014-04-15 18:17:03 - PHP Notice:  Cannot find controller class file for route 'product/add' in /var/www/projects/removed/public_html/system/engine/factory.php on line 168
...
2014-04-17 8:55:14 - PHP Notice:  Undefined variable: request in xdebug://debug-eval on line 1
2014-04-17 8:55:16 - PHP Notice:  Undefined variable: request in xdebug://debug-eval on line 1
2014-04-17 8:55:19 - PHP Notice:  Undefined variable: request in xdebug://debug-eval on line 1
2014-04-18 10:48:18 - PHP Warning:  mysqli::query(): (21000/1242): Subquery returns more than 1 row in /var/www/projects/removed/public_html/system/database/mysqliz.php on line 19
2014-04-18 10:48:18 - PHP Notice:  Error: Subquery returns more than 1 row<br />Error No: 1242<br />SELECT DISTINCT *, (SELECT keyword FROM oc_url_alias WHERE query = 'information_id=4') AS keyword FROM oc_information WHERE information_id = '4' in /var/www/projects/removed/public_html/system/database/mysqliz.php on line 53
I have 3/4 of a year worth of logs and guess what, not a single time I had a mail related notice, warning or error.

If what you say was true, all you'd ever need to fix OC users issues would be to ask them to post that log.
Sadly it isn't.

I implemented a whole PHP unit testing army to cover the bugs that never show on the log nor on the web pages. Maybe it's because I am using Nginx + PHP-fpm, maybe because my OC customizations are deep enough I sometimes need to use XDebug (in example, when I changed OC's engine to implement my configurable, memcached based, language + currency + module instance aware, sub-page caching).

Also, regardless of your considerations and regardless of logs, the fact that OC 1.5.6 release had a "fatal error" (not showing on the logs!) in the foundation of an e-commerce product - the order delivery - means that nobody tested whether such foundation part of the software worked or not.

This is as serious as it can be, and shows that when a project grows large enough, additional care has to be put into the existing quality control. Since it's unreasonable to force such gruesome and easily automated task onto a developer, it becomes quite appropriate to think about adding OC an unit tests suite to run before any official release delivery. Sure, unit tests only cover the portions of code they have been created for (expecially when not developing starting from unit tests) but over time they can become really extensive and deliver a very good, repeatable quality control experience.
It'd be awesome if OC 2.0 introduced unit tests as one of it's "major release number" motivating factors.

And yes, in the previous posts I have said I'd be available to help getting the OC unit tests suite started.

Heavy OpenCart Customizations. Current project in progress: fleurworld.com


Active Member

Posts

Joined
Tue Aug 20, 2013 3:34 am

Post by villagedefrance » Thu Apr 24, 2014 5:00 pm

dfumagalli wrote:This is as serious as it can be, and shows that when a project grows large enough, additional care has to be put into the existing quality control. Since it's unreasonable to force such gruesome and easily automated task onto a developer, it becomes quite appropriate to think about adding OC an unit tests suite to run before any official release delivery. Sure, unit tests only cover the portions of code they have been created for (expecially when not developing starting from unit tests) but over time they can become really extensive and deliver a very good, repeatable quality control experience.
Yes, I agree that a "unit test" would be a very good idea since the opencart project is now written by more than one person. Parts of it are also maintained by third parties (like Openbay Pro) and not always in line in term of coding rules with the rest of the code. Also every .tpl file should be validated with the W3C html checker (even though html5 is not official by W3C standards).

OpenCart custom solutions @ https://villagedefrance.net


User avatar
Active Member

Posts

Joined
Wed Oct 13, 2010 10:35 pm
Location - UK

Post by rph » Sat Apr 26, 2014 1:37 pm

dfumagalli wrote:I have 3/4 of a year worth of logs and guess what, not a single time I had a mail related notice, warning or error.

If what you say was true, all you'd ever need to fix OC users issues would be to ask them to post that log.
Sadly it isn't.
I think there's a mix up on terminology. A bug will not always evoke the PHP error handler. A script can be perfectly valid PHP yet horribly bugged.

Nevertheless the mail class does have numerous trigger_error() calls. If there's someplace you think one should be I'd definitely encourage you to make a pull request.
I implemented a whole PHP unit testing army to cover the bugs that never show on the log nor on the web pages.
That would be seriously impressive if you managed to get wide unit testing coverage for OpenCart. It would be a huge amount of work. You might want to see if the OpenCart Testing Suite is still active and would accept pull requests. I'm sure they'd appreciate it.

Personally I lean toward the opinion that OpenCart's methods are too large and complex to be properly unit tested as they exist. It's common for a controller to be a several hundred line index method and a small validation method. I'm not saying it isn't worth it (I'm playing around with a major rewrite myself) but the amount of required changes would essentially make it OpenCart 3.0.
Also, regardless of your considerations and regardless of logs, the fact that OC 1.5.6 release had a "fatal error" (not showing on the logs!) in the foundation of an e-commerce product - the order delivery - means that nobody tested whether such foundation part of the software worked or not.
Well a fatal error is one that stops the script from running and I'm not aware of any of those. I do agree there needs to be more testing, whether that's automated or longer and more public release candidates. Ecommerce platforms require a conservative release cycle versus something like a blog or wiki. Hopefully it'll happen some day. It's been brought up several times now without much progress.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by rawmeattt » Mon Apr 28, 2014 5:34 am

Hello, I am also getting an error when trying to up date product information and save the updates.
I also get this error trying to save product info and not making any changes. I am using 1.5.6.4 .thank you for you help


Notice: Undefined index: profile_id in /home/content/02/10525702/html/premiumcartridge/admin/model/catalog/product.php on line 268Warning: Cannot modify header information - headers already sent by (output started at /home/content/02/10525702/html/premiumcartridge/admin/index.php:81) in /home/content/02/10525702/html/premiumcartridge/system/engine/controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/content/02/10525702/html/premiumcartridge/admin/index.php:81) in /home/content/02/10525702/html/premiumcartridge/system/engine/controller.php on line 29

Newbie

Posts

Joined
Mon Apr 28, 2014 5:21 am

Post by i2Paq » Tue Apr 29, 2014 3:43 pm

Issues related to a 1.5.6.4 CLEAN install can be posted here: http://forum.opencart.com/viewtopic.php?f=161&t=124313

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by rawmeattt » Wed Apr 30, 2014 11:27 am

Not sure but since I am new, how much more effort would it be to try to offer an answer and then tell me where to place myself.
Is that something possible

Newbie

Posts

Joined
Mon Apr 28, 2014 5:21 am

Post by OSWorX » Wed Apr 30, 2014 2:55 pm

rawmeattt wrote:Not sure but since I am new, how much more effort would it be to try to offer an answer and then tell me where to place myself.
Is that something possible
http://forum.opencart.com/viewtopic.php?f=161&t=124313

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member
Online

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by farhanulhaq » Thu May 01, 2014 4:52 am

I am receiving error when i edit & click on save products...
Opencart Version 1.5.6
Vqmod version 2.4.0
than why this error appear?
"Notice: Undefined index: profile_id in /home/inam/public_html/admin/model/catalog/product.php on line 268Warning: Cannot modify header information - headers already sent by (output started at /home/inam/public_html/admin/index.php:85) in /home/inam/public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /home/inam/public_html/admin/index.php:85) in /home/inam/public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 29"

Newbie

Posts

Joined
Thu May 01, 2014 4:10 am

Post by IP_CAM » Mon May 26, 2014 6:33 am

ecommercesussexltd wrote:Made into a VQ so updates don't override it.
I use OC v.1.5.6.1/2/3, according to Posting from Daniel, the >>> 'hasAction' <<< routine-handler would not longer be implemented in OC Versions. I did not find anything in my login.tpl file you mentioned either. Therefore, your VQMod would not function.

Therefore, I assume that it is made for an older OC Version. Am I right?

Ernie

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
1'400+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by xs2qunal » Wed Jun 11, 2014 6:21 pm

Hi I am Kunal, I am facing this fatal error problem.

Fatal error: Class 'User' not found in /home/xxxx/public_html/index.php on line 146
Call Stack
# Time Memory Function Location
1 0.0013 626824 {main}( ) ../index.php:0

please help me with this error




<?php
// Version
define('VERSION', '1.5.6.1');

// Configuration
if (file_exists('config.php')) {
require_once('config.php');
}

// Install
if (!defined('DIR_APPLICATION')) {
header('Location: ../install/index.php');
exit;
}

// vQmod
require_once('./vqmod/vqmod.php');


// VQMODDED Startup
require_once(VQMod::modCheck(DIR_SYSTEM . 'startup.php'));

// Application Classes
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/customer.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/currency.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/tax.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/weight.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/length.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/cart.php'));
require_once(VQMod::modCheck(DIR_SYSTEM . 'library/affiliate.php'));

// Registry
$registry = new Registry();

// Loader
$loader = new Loader($registry);
$registry->set('load', $loader);

// Config
$config = new Config();
$registry->set('config', $config);

// Database
$db = new DB(DB_DRIVER, DB_HOSTNAME, DB_USERNAME, DB_PASSWORD, DB_DATABASE);
$registry->set('db', $db);

// Settings
$query = $db->query("SELECT * FROM " . DB_PREFIX . "setting WHERE store_id = '0'");

foreach ($query->rows as $setting) {
if (!$setting['serialized']) {
$config->set($setting['key'], $setting['value']);
} else {
$config->set($setting['key'], unserialize($setting['value']));
}
}

// Url
$url = new Url(HTTP_SERVER, $config->get('config_secure') ? HTTPS_SERVER : HTTP_SERVER);
$registry->set('url', $url);

// Log
$log = new Log($config->get('config_error_filename'));
$registry->set('log', $log);

function error_handler($errno, $errstr, $errfile, $errline) {
global $log, $config;

switch ($errno) {
case E_NOTICE:
case E_USER_NOTICE:
$error = 'Notice';
break;
case E_WARNING:
case E_USER_WARNING:
$error = 'Warning';
break;
case E_ERROR:
case E_USER_ERROR:
$error = 'Fatal Error';
break;
default:
$error = 'Unknown';
break;
}

if ($config->get('config_error_display')) {
echo '<b>' . $error . '</b>: ' . $errstr . ' in <b>' . $errfile . '</b> on line <b>' . $errline . '</b>';
}

if ($config->get('config_error_log')) {
$log->write('PHP ' . $error . ': ' . $errstr . ' in ' . $errfile . ' on line ' . $errline);
}

return true;
}

// Error Handler
set_error_handler('error_handler');

// Request
$request = new Request();
$registry->set('request', $request);

// Response
$response = new Response();
$response->addHeader('Content-Type: text/html; charset=utf-8');
$registry->set('response', $response);

// Cache
$cache = new Cache();
$registry->set('cache', $cache);

// Session
$session = new Session();
$registry->set('session', $session);

// Language
$languages = array();

$query = $db->query("SELECT * FROM `" . DB_PREFIX . "language`");

foreach ($query->rows as $result) {
$languages[$result['code']] = $result;}

$config->set('config_language_id', $languages[$config->get('config_admin_language')]['language_id']);

// Language
$language = new Language($languages[$config->get('config_admin_language')]['directory']);
$language->load($languages[$config->get('config_admin_language')]['filename']);
$registry->set('language', $language);

// Document
$registry->set('document', new Document());

// Currency
$registry->set('currency', new Currency($registry));

// Weight
$registry->set('weight', new Weight($registry));

// Length
$registry->set('length', new Length($registry));

// User
$registry->set('user', new User($registry));

//OpenBay Pro
$registry->set('openbay', new Openbay($registry));

// Front Controller
$controller = new Front($registry);

// Login
$controller->addPreAction(new Action('common/home/login'));

// Permission
$controller->addPreAction(new Action('common/home/permission'));

// Router
if (isset($request->get['route'])) {
$action = new Action($request->get['route']);
} else {
$action = new Action('common/home');
}

// Dispatch
$controller->dispatch($action, new Action('error/not_found'));

// Output
$response->output();
?>

Newbie

Posts

Joined
Wed Jun 11, 2014 6:13 pm

Post by JNeuhoff » Thu Jun 12, 2014 11:07 pm

Hi I am Kunal, I am facing this fatal error problem.

Fatal error: Class 'User' not found in /home/xxxx/public_html/index.php on line 146
Not a bug. Your index.php file is corrupted, the original index.php doesn't use class 'User'!

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by psycmos » Tue Jul 01, 2014 7:54 pm

Browser saving Post code field during registration?? how can i fix it?

New member

Posts

Joined
Mon Nov 26, 2012 7:31 pm
Who is online

Users browsing this forum: Bing [Bot] and 2 guests