Post by craft37 » Sun May 05, 2013 9:04 pm

Hello, folks!
Please help me with mail contact form ( http://gmbox.by/contact ), script even don't show success page.
1) hoster says that php mail () work correctly
2) mail mode in settings, e-mail set properly
3) i modifyed only contact.tpl only with map, system/mail.php is original from ver. 1.5.5.1

i just don't know what to do, i googled for few weeks and not fix problem.
what it can be, please help me!
Last edited by craft37 on Tue May 14, 2013 5:58 pm, edited 1 time in total.

New member

Posts

Joined
Sun Dec 09, 2012 12:30 pm

Post by butte » Mon May 06, 2013 1:47 am

What happens if you undo your 3)? Did it work before that? There are several concurrent recent threads on contact mailing.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by nestones » Wed May 08, 2013 10:00 pm

I have the same issue. Isn't working contact form! I tried several things and all not working! Just don't know what to do now.

Anyone could assist? Would be appreciated.

Newbie

Posts

Joined
Wed May 08, 2013 9:53 pm

Post by straightlight » Wed May 08, 2013 10:19 pm

Switch to default template and see if you can reproduce the problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by craft37 » Tue May 14, 2013 5:45 pm

What happens if you undo your 3)? Did it work before that? There are several concurrent recent threads on contact mailing.
tryed to restore original contact.tpl, seems the problem not in it

i found, that contact form don't work with this lines in index.php after

Code: Select all

// SEO URL's 
//$controller->addPreAction(new Action('common/seo_url'));

if (!$seo_type = $config->get('config_seo_url_type')) { 
$seo_type = 'seo_url'; 
} 
$controller->addPreAction(new Action('common/' . $seo_type));
Without this storke mail work with smtp, but it ruins seo url on my custom pages (contacts, latest, etc)
Any ideas?

New member

Posts

Joined
Sun Dec 09, 2012 12:30 pm

Post by straightlight » Tue May 14, 2013 11:44 pm

What does it report on your web error logs when you do have the SEO Url class loaded ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by craft37 » Wed May 15, 2013 4:28 pm

straightlight wrote:What does it report on your web error logs when you do have the SEO Url class loaded ?
system/logs show no error, with or without this SEO URL's strokes (seo pro plugin)

New member

Posts

Joined
Sun Dec 09, 2012 12:30 pm

Post by straightlight » Wed May 15, 2013 10:18 pm

From your cPanel error log, what does it display for that event particularly ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by craft37 » Thu May 16, 2013 5:31 am

straightlight wrote:From your cPanel error log, what does it display for that event particularly ?
my hosting use ISP manager (ispmgr) and this log empty too

New member

Posts

Joined
Sun Dec 09, 2012 12:30 pm

Post by craft37 » Mon Jul 15, 2013 10:49 pm

The problem was connected with seo_pro russian mafia extension
It's not works properly with the latest OC 1.5.5.1
At least, at this moment

New member

Posts

Joined
Sun Dec 09, 2012 12:30 pm

Post by butte » Fri Jul 19, 2013 4:26 am

The safest way, overall, to test seo extensions and modules for pproblems, solutions, and workarounds is to set up a browsable mirror OC (identical but separate, in an adjoining directory, in its own subdomain, or whatever) and tinker with that.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am
Who is online

Users browsing this forum: Bing [Bot] and 56 guests