Post by Melon » Fri Jan 13, 2012 8:57 am

This will fix the annoying <p> tag on the ckeditor

It will only do category, information and product page in admin, if you have custom mod you will need manually or add in.

New member

Posts

Joined
Thu Feb 03, 2011 8:02 pm

Post by webpie it. » Mon Jan 16, 2012 5:07 am

Do you mean it will fix the extra <p> tags added when you save something written into ckeditor?

Regards

Chris


Active Member

Posts

Joined
Mon Jan 31, 2011 7:28 pm

Post by Melon » Mon Jan 16, 2012 5:14 am

Correct..

New member

Posts

Joined
Thu Feb 03, 2011 8:02 pm

Post by webpie it. » Mon Jan 16, 2012 3:04 pm

Excellent! Great find and fix!!! :)

This is something that has bugged the crap out of me since i started using ck editor!

Regards

Chris


Active Member

Posts

Joined
Mon Jan 31, 2011 7:28 pm

Post by 3antz » Mon Jan 16, 2012 8:52 pm

thank you for the mod, it works very well.

Active Member

Posts

Joined
Sun Oct 02, 2011 6:52 pm

Post by iplayitofflegit » Fri Feb 17, 2012 2:05 pm

Where do you place this xml? In vqmod/xml/ ?


Posts

Joined
Tue Dec 20, 2011 12:22 pm

Post by Melon » Sat Feb 18, 2012 8:23 am

yes

New member

Posts

Joined
Thu Feb 03, 2011 8:02 pm

Post by Windsurfer » Wed Apr 25, 2012 10:59 am

Hi
I use Zencart V1.5 and have the ckeditor installed but i don't see a folder or file called vqmod/xml/
where would i put this file to make it work ?
Thank you

Newbie

Posts

Joined
Mon May 18, 2009 9:53 pm

Post by Klimskady » Fri Apr 27, 2012 8:46 am

Windsurfer wrote:Hi
I use Zencart V1.5 and have the ckeditor installed but i don't see a folder or file called vqmod/xml/
where would i put this file to make it work ?
Thank you
If not using Opencart and the vQmod system made for it then you will not have the folders vqmod/xml, you would need to install the vQmod not made for OC and try to install it for Zencart, I have no idea if it will work though... Maybe ask on a Zencart forum?

Active Member

Posts

Joined
Tue Jun 07, 2011 7:57 am

Post by Windsurfer » Fri Apr 27, 2012 9:09 am

Thank you

Newbie

Posts

Joined
Mon May 18, 2009 9:53 pm

Post by JPC60 » Thu May 31, 2012 3:02 am

Hi,

This works great, thank you!!!

I've just installed the CR2 HTML Module: http://www.opencart.com/index.php?route ... on_id=2318

I'm seeing the extra <p> tags when using this module... any thoughts on how to make your ckeditor fix work with the CR2 HTML Module?

Thanks again!

John

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by Melon » Thu May 31, 2012 11:54 pm

Simply add the bit of code to the xml file.. obviously check which file the cr2 html module is on first

New member

Posts

Joined
Thu Feb 03, 2011 8:02 pm

Post by JPC60 » Fri Jun 01, 2012 3:31 am

Hi,

Thanks, I've asked the cr2 author about the exact code to use, hopefully I can get this to work with cr2.

John

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by JPC60 » Mon Jun 04, 2012 2:58 am

Just an update... couldn't get this to work with cr2, I spoke to the cr2 author and he said he couldn't test it as he doesn't use vqmods. A real shame too as these two items would be really useful together.

John

New member

Posts

Joined
Thu Nov 17, 2011 5:42 am

Post by labeshops » Mon Jun 04, 2012 11:21 pm

I get this problem in the welcome module - is it possible to fix there?

Running Opencart v2.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by jigesh345 » Wed Oct 31, 2012 5:07 pm

Hello, i am using this module and i am fetching category description on product add page file name : product_form.tpl and also in cache file name vq2-admin_view_template_catalog_product_form.tpl both are same although , but i am seeing <p> </p> tag before and after finishing description.

i have applied your solution by placing fix_ckeditor_p.xml file in vqmod/xml/ folder but NO LUCK.

please help me soon, i have wasted a day behind this.

thank you.

Newbie

Posts

Joined
Wed Oct 31, 2012 5:01 pm
Who is online

Users browsing this forum: No registered users and 30 guests