Post by MrZimm » Thu May 17, 2012 12:34 pm

I'm using Version 1.5.1.3, https://adultdiaperscanada.ca

Modual stopped working and I can't figure out for the life of me whats up. Re installed a few times and nothing. No changes to the site during the time the reporting stopped.

Created a ticket for support on opencart sadly haven't heard anything back.

Anyone else experience this? The Google code just isn't showing up... but it's enabled.

New member

Posts

Joined
Mon Feb 27, 2012 11:20 pm

Post by spikeachu » Thu May 31, 2012 6:45 pm

MrZimm wrote:I'm using Version 1.5.1.3, https://adultdiaperscanada.ca

Modual stopped working and I can't figure out for the life of me whats up. Re installed a few times and nothing. No changes to the site during the time the reporting stopped.

Created a ticket for support on opencart sadly haven't heard anything back.

Anyone else experience this? The Google code just isn't showing up... but it's enabled.
Are you using vQmod with caching set to true?

I'm finding that when I set caching to true, this module doesn't show. When I return the setting to false, this mod works correctly.

Any ideas on how to resolve?

Wedding Invitations and Stationery by Love2print

Commercial Mods
Product Colours on Category Page
Cardsave Direct Gateway
Clear Cache
Promotional Watermarks on Images
Multiple Category / Product Templates ** Popular **
Log Failed Login Attempts
Display Eligible Coupons with Products
Twitter Feeds

Have I helped you out or saved you some time? Please donate


Active Member

Posts

Joined
Fri Mar 12, 2010 6:31 am

Post by spikeachu » Mon Jun 04, 2012 5:12 pm

I've figured it out.

The mod writes information to the .tpl file in a different way. Which means the page is cached before the Analytics code is written to the page.

I reverted to the traditional method and the issue is resolved.

Wedding Invitations and Stationery by Love2print

Commercial Mods
Product Colours on Category Page
Cardsave Direct Gateway
Clear Cache
Promotional Watermarks on Images
Multiple Category / Product Templates ** Popular **
Log Failed Login Attempts
Display Eligible Coupons with Products
Twitter Feeds

Have I helped you out or saved you some time? Please donate


Active Member

Posts

Joined
Fri Mar 12, 2010 6:31 am

Post by tophat » Sat Jun 30, 2012 7:47 pm

MrZimm wrote:I'm using Version 1.5.1.3, https://adultdiaperscanada.ca

Modual stopped working and I can't figure out for the life of me whats up. Re installed a few times and nothing. No changes to the site during the time the reporting stopped.

Created a ticket for support on opencart sadly haven't heard anything back.

Anyone else experience this? The Google code just isn't showing up... but it's enabled.
Yep, Same.

BE WARNED, this user/developer doesn't offer any support and simply ignored nearly every ticket I raised with him. It also doesn't Work. So I've paid for this extension with nothing to show for it which is a shame. Any help by some kind folk would be much appreciated as I really want and require this feature.

Many Thanks.

Webmaster for: http://www.getlaidbeds.co.uk + www.mattressmoose.co.uk + www.pixellounge.co.uk


User avatar
Active Member

Posts

Joined
Fri Nov 25, 2011 8:31 am


Post by imaginetech » Sat Jun 30, 2012 8:38 pm

Actually, the module does work. Fine, straight out of the box.

It has problems when people highly customize their does using third party templates that break all kinds of core OpenCart functionality to look pretty.

I remember your support request and if it hasn't been resolved to your satisfaction reply to the ticket and I'll sort it out.

Understand though that its not my responsibility to make site my modules work with other modules that modify OpenCart.

I've always made my modules with no file editing required, especially since we moved to the vQmod system.

Thank you

Image
www.opencartstore.com
Get OpenCart Templates and OpenCart Modules.


User avatar
Active Member

Posts

Joined
Fri Sep 04, 2009 12:25 pm
Location - Darwin, Australia

Post by tophat » Sat Jun 30, 2012 9:13 pm

imaginetech wrote:Actually, the module does work. Fine, straight out of the box.

It has problems when people highly customize their does using third party templates that break all kinds of core OpenCart functionality to look pretty.

I remember your support request and if it hasn't been resolved to your satisfaction reply to the ticket and I'll sort it out.

Understand though that its not my responsibility to make site my modules work with other modules that modify OpenCart.

I've always made my modules with no file editing required, especially since we moved to the vQmod system.

Thank you
I have made 4 or 5 ticket requests (several months apart now) and sent several emails with NO replies whatsoever. So, please check accordingly and kindly let me know why it is not working and never has worked. It appears it takes one to voice concern on this forum to get a response! Had given up to be honest as this was going back many months now!

I've never been made aware that it was a compatability issue with other files. Sounds like nonesense as I haven't got it working without any other extensions. The base theme perhaps may cause something, but its not just me that is experiencing this issue and beside, a module should at least be designed to work with themes given that almost everyone uses one!

I'll glady revoke any negativity expressed here if you can get the module working or a refund is made.

Thanks.

Webmaster for: http://www.getlaidbeds.co.uk + www.mattressmoose.co.uk + www.pixellounge.co.uk


User avatar
Active Member

Posts

Joined
Fri Nov 25, 2011 8:31 am


Post by spikeachu » Sun Jul 01, 2012 1:55 am

imaginetech wrote:Actually, the module does work. Fine, straight out of the box.

It has problems when people highly customize their does using third party templates that break all kinds of core OpenCart functionality to look pretty.

I remember your support request and if it hasn't been resolved to your satisfaction reply to the ticket and I'll sort it out.

Understand though that its not my responsibility to make site my modules work with other modules that modify OpenCart.

I've always made my modules with no file editing required, especially since we moved to the vQmod system.

Thank you
Hi Imaginetech,

The Google Adsense Pro module fails when you enable the caching feature of vQmod. It's a relatively simple fix,

I had to change the _write_tracking_code as below, the only downside being that _display_exception function is now redundant.

Regards, Mike.

Code: Select all

private function _write_tracking_code()
	{
		$this->data['tracking_code'] = $this->_submit_click_code . $this->_tracking_code;
					
		if (file_exists(DIR_TEMPLATE . $this->config->get('config_template') . '/template/module/googleanalytics.tpl')) {
			$this->template = $this->config->get('config_template') . '/template/module/googleanalytics.tpl';
		} else {
			$this->template = 'default/template/module/googleanalytics.tpl';
		}

		$this->render();
		
	}

Wedding Invitations and Stationery by Love2print

Commercial Mods
Product Colours on Category Page
Cardsave Direct Gateway
Clear Cache
Promotional Watermarks on Images
Multiple Category / Product Templates ** Popular **
Log Failed Login Attempts
Display Eligible Coupons with Products
Twitter Feeds

Have I helped you out or saved you some time? Please donate


Active Member

Posts

Joined
Fri Mar 12, 2010 6:31 am

Post by tophat » Thu Jul 05, 2012 1:24 am

So... 4 days later, no reply.
Last edited by tophat on Thu Jul 05, 2012 5:12 pm, edited 1 time in total.

Webmaster for: http://www.getlaidbeds.co.uk + www.mattressmoose.co.uk + www.pixellounge.co.uk


User avatar
Active Member

Posts

Joined
Fri Nov 25, 2011 8:31 am


Post by imaginetech » Thu Jul 05, 2012 5:02 am

tophat wrote:So... 4 days later, no reply. Perhaps I'm asking too much?! (It's only been 4 or 5 months in total)
Not doing support via forum thread.

As I said open/reopen a support ticket:-

https://opencartstorecom.zendesk.com/home

Thank you

Image
www.opencartstore.com
Get OpenCart Templates and OpenCart Modules.


User avatar
Active Member

Posts

Joined
Fri Sep 04, 2009 12:25 pm
Location - Darwin, Australia
Who is online

Users browsing this forum: No registered users and 5 guests