Post by Demon5 » Mon May 14, 2012 11:35 am

From the last thing he says I'd say he has the config files messed up since he says the entire site now in ssl. Here's an example of what should be in the root config.php.


config.php

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.lordofthe.net/');
define('HTTP_IMAGE', 'http://www.lordofthe.net/image/');
define('HTTP_ADMIN', 'http://www.lordofthe.net/admin/');

// HTTPS
define('HTTPS_SERVER', 'https://www.lordofthe.net/');
define('HTTPS_IMAGE', 'https://www.lordofthe.net/image/');

admin/config.php

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.lordofthe.net/admin/');
define('HTTP_CATALOG', 'http://www.lordofthe.net/');
define('HTTP_IMAGE', 'http://www.lordofthe.net/image/');

// HTTPS
define('HTTPS_SERVER', 'https://www.lordofthe.net/admin/');
define('HTTPS_IMAGE', 'https://www.lordofthe.net/image/');
define('HTTPS_CATALOG', 'https://www.lordofthe.net/');

https://www.lotnllc.com is your one stop shop for all your computer needs!


User avatar
Active Member

Posts

Joined
Sat Jun 19, 2010 4:12 am
Location - Sacramento, CA

Post by dlo80 » Sun Jun 17, 2012 2:37 am

Hi, did you already fixed the issue with SSL? I have the same issue with EV Comodo on my shop as well. Hope to hear from you....:)
sumankhan wrote:
cwswebdesign wrote:
sumankhan wrote:i have still this same problem as i am using not shared ssl all is working only the checkout page is not working.

What steps did you take to turn on SSL? There's only 3 places that need to be modified (the two config files and the enable SSL in the admin section). So many people seem to change more than what is needed.

HI THANKS FOR REPLY I HAVE CHANGE 2 CONFIG FILE STORE AND ADMIN AND ON SSL ON ADMIN PANEL AND ALL WORKING GOOD ONLY WHEN GOING TO CHECKOUT PAGE THEN CHECKOUT OPTIONS ARE HANG NOT OPENING.

I HAVE ALSO CHECK IN COMODO PAGE THE SETUP AND SETUP IS OK.

SORRY I FORGOT ALSO THE ADMIN PANEL IMAGE MANAGER NOT WORKING IF SSL IS ENABLED.

Newbie

Posts

Joined
Thu Mar 01, 2012 5:04 am

Post by Knight57 » Tue Jul 03, 2012 8:58 am

Yes, Justhost installed a new Comodo SSL certificate on my site www.knightshipper.com and I cant view my about us, delivery information, privacy policy etc. The links immediately bring back to home page.. please advise

Newbie

Posts

Joined
Tue Jul 03, 2012 8:52 am

Post by cwswebdesign » Thu Jul 05, 2012 2:03 am

Knight57 wrote:Yes, Justhost installed a new Comodo SSL certificate on my site http://www.knightshipper.com and I cant view my about us, delivery information, privacy policy etc. The links immediately bring back to home page.. please advise
I can view all of the pages without a problem. Which Browser and version are you using? Do you have a screenshot of what's going on?

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by Knight57 » Thu Jul 05, 2012 9:51 am

Problem fixed. BUT the https://www.knightshipper.com/index.php ... ount/login page is distorted. The catalog is in more than one section of the page (as seen). How can I fix this? I am using the latest opencart version 1.5.3

Newbie

Posts

Joined
Tue Jul 03, 2012 8:52 am

Post by Knight57 » Thu Jul 05, 2012 9:48 pm

The link within the website for account is directing to the same location
https://www.knightshipper.com/index.php ... ount/login but with different results..........If you click the link above everything is fine with the account/login page. So, now attempt it from MY ACCOUNT within the site and see the problems. DOES ANYONE have a suggestion??? :(

Newbie

Posts

Joined
Tue Jul 03, 2012 8:52 am

Post by BasheeraDesigns » Thu Sep 06, 2012 7:06 am

My admin login page is also distorted. Did you figure out how to fix this?


Posts

Joined
Thu Aug 23, 2012 1:58 pm

Post by bobwhite » Sat Sep 08, 2012 9:42 pm

Hello,
I need some advice here.
I installed SSL. It is private SSL provided by Comodo, installed by Hostgator. Everything was done according to this topic: http://forum.opencart.com/viewtopic.php?f=138&t=64685 , I even went to this website: http://whynopadlock.com and checked for errors. I got all green checkmarks. Unfortunately there is a situation when I am (customer) getting warning messages:
My store supports multiple languages and multiple currencies and while customer is on secure page, “My account” (registration) or “Checkout” and decided to change language or change currency, customer will get this message: “Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party. Are you sure you want to continue sending this information?” in FireFox; “The identity of this website has not been verified. Your connection to mysite.com is not encrypted.” in Google. Is this normal behaviour or something has to be done to changed? Please let me know.

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by cwswebdesign » Sun Sep 09, 2012 7:01 am

bobwhite wrote:Hello,
I need some advice here.
I installed SSL. It is private SSL provided by Comodo, installed by Hostgator. Everything was done according to this topic: http://forum.opencart.com/viewtopic.php?f=138&t=64685 , I even went to this website: http://whynopadlock.com and checked for errors. I got all green checkmarks. Unfortunately there is a situation when I am (customer) getting warning messages:
My store supports multiple languages and multiple currencies and while customer is on secure page, “My account” (registration) or “Checkout” and decided to change language or change currency, customer will get this message: “Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party. Are you sure you want to continue sending this information?” in FireFox; “The identity of this website has not been verified. Your connection to mysite.com is not encrypted.” in Google. Is this normal behaviour or something has to be done to changed? Please let me know.

Need the link to your website.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by bobwhite » Sun Sep 09, 2012 10:48 am

Ups, totally forgot, sorry.
http://springofhealth.ca/index.php?route=common/home
Thanks.

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by cwswebdesign » Mon Sep 10, 2012 12:52 am

Your certificate is properly installed. I was able to get to the checkout page and https comes up with no errors. If I stay on the checkout page and change currency or language while I'm on that page, I get the issue about items not being encrypted. If I click ok, it loads non https. If I reload that same page, https is engaged again.

Is this what you're referring to? For some reason, it's only happening if you change the language or currency after you've gone to an https page, such as checkout. Did you do a search in the forums?

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by bobwhite » Mon Sep 10, 2012 12:20 pm

cwswebdesign wrote:Your certificate is properly installed. I was able to get to the checkout page and https comes up with no errors. If I stay on the checkout page and change currency or language while I'm on that page, I get the issue about items not being encrypted. If I click ok, it loads non https. If I reload that same page, https is engaged again.

Is this what you're referring to? For some reason, it's only happening if you change the language or currency after you've gone to an https page, such as checkout. Did you do a search in the forums?

DL
DL, thank you for checking.
This is exactly what I was referring too in my original post. Yes, I did search forum, but no luck yet.
Bob

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by comparecheapssl » Tue Jan 14, 2020 1:43 am

You need to check your SSL Certificate installation- You can use following url-
https://comparecheapssl.com/ssl-tools/ssl-checker/


Posts

Joined
Sat Aug 31, 2019 2:04 am

Post by EvolveWebHosting » Thu Jan 23, 2020 9:57 pm

comparecheapssl wrote:
Tue Jan 14, 2020 1:43 am
You need to check your SSL Certificate installation- You can use following url-
https://comparecheapssl.com/ssl-tools/ssl-checker/
This post is over 8 years old. Are you just trying to get your name out there which is affiliated with NameCheap? BTW, Comodo doesn't issue SSL Certs any longer.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: No registered users and 8 guests