Post by SonKeller » Mon Jun 18, 2012 10:31 pm

Dear All,
I'm trying to upgrade from 1.5.2.1. to 1.5.3.1. but no success (upgraded by SimpleScript)

2 errors:
1.
Notice: Undefined index: bottom in /home5/ronindog/public_html/catalog/controller/common/footer.php on line 26
but still posted on 'bugs' and waiting help there.

2. error:
when I'm trying to edit store settings (system>settings>mystore) following message:
Notice: Error: Table 'ronindog_pnc1.oc_customer_group_description' doesn't exist
Error No: 1146
SELECT * FROM oc_customer_group cg LEFT JOIN oc_customer_group_description cgd ON (cg.customer_group_id = cgd.customer_group_id) WHERE cgd.language_id = '1' ORDER BY cgd.name ASC in /home5/ronindog/public_html/system/database/mysql.php on line 49

Reading the 2nd error, I understand that this is a problem with tables. SimpleScript add a prefix to tables (oc_).
I don't know sq and php.
Someone knows what should I do ?
Thank you all for you attention (and sorry for my english... hope you understand the issue).

Sonia
OpenCart: Version 1.5.3.1.


Newbie

Posts

Joined
Wed Mar 21, 2012 11:52 pm

Post by fshehri » Sat Jun 23, 2012 8:29 pm

I'm having the same problem as #1 ???

Newbie

Posts

Joined
Mon Apr 30, 2012 1:35 pm

Post by straightlight » Sat Jun 23, 2012 9:35 pm

1.
Notice: Undefined index: bottom in /home5/ronindog/public_html/catalog/controller/common/footer.php on line 26
but still posted on 'bugs' and waiting help there.
Does this error message occurs when using a custom template or straight from the default template ? If from a custom template, switch back to the default template and see if you can reproduce the error.
2. error:
when I'm trying to edit store settings (system>settings>mystore) following message:
Notice: Error: Table 'ronindog_pnc1.oc_customer_group_description' doesn't exist
Error No: 1146
SELECT * FROM oc_customer_group cg LEFT JOIN oc_customer_group_description cgd ON (cg.customer_group_id = cgd.customer_group_id) WHERE cgd.language_id = '1' ORDER BY cgd.name ASC in /home5/ronindog/public_html/system/database/mysql.php on line 49
It looks like the upgrade procedure in your case haven't seem to have gone pretty well. I would suggest to restore backup of your OpenCart site and its database then to launch the upgrade again with caution.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sat Jun 23, 2012 9:36 pm

fshehri wrote:I'm having the same problem as #1 ???
Follow my instruction for number 1 above and see if you can reproduce the problem.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by SonKeller » Sun Jun 24, 2012 8:15 pm

Notice: Undefined index: bottom in /home5/ronindog/public_html/catalog/controller/common/footer.php on line 26
but still posted on 'bugs' and waiting help there.
Does this error message occurs when using a custom template or straight from the default template ? If from a custom template, switch back to the default template and see if you can reproduce the error.
Both. default and custom template.
2. error:
when I'm trying to edit store settings (system>settings>mystore) following message:
Notice: Error: Table 'ronindog_pnc1.oc_customer_group_description' doesn't exist
Error No: 1146
SELECT * FROM oc_customer_group cg LEFT JOIN oc_customer_group_description cgd ON (cg.customer_group_id = cgd.customer_group_id) WHERE cgd.language_id = '1' ORDER BY cgd.name ASC in /home5/ronindog/public_html/system/database/mysql.php on line 49
It looks like the upgrade procedure in your case haven't seem to have gone pretty well. I would suggest to restore backup of your OpenCart site and its database then to launch the upgrade again with caution.
I have restored backup and have launched upgrade 2 times. I do not have 'access' to the upgrade. I do the upgrade through SimpleScript on my hoster. I have no opportunity to 'speak' about upgrading.
Anyway. I preferred to do a fresh installation (v. 1.5.3.1) so I have not experienced any problems.
Thanks for the help.
Regards.
Sonia

Sonia
OpenCart: Version 1.5.3.1.


Newbie

Posts

Joined
Wed Mar 21, 2012 11:52 pm
Who is online

Users browsing this forum: No registered users and 8 guests