Post by SuperJuice » Sun Apr 29, 2012 8:53 pm

PGS wrote:As the coding isn't line by line, but all jumbled together, I have no idea where this line should go.
Sounds like you are using an editor that doesn't recognise unix carriage returns (Notepad?) I would suggest using something better if you have it available (Wordpad will show unix carriage returns correctly).

If turning the option off solves your issue, it's all good! :D

Active Member

Posts

Joined
Thu Aug 13, 2009 12:06 pm

Post by ateloh » Sun May 20, 2012 9:06 pm

Hey, I am using the latest version of OpenCart Version 1.5.2.1.

Just wondering if measurements of products (small boxes) need to be in mm or cm?

For some reason, it seems that the Module is not splitting the order up over multiple parcels.


For example, I have a box that weighs 609g (in grams on open cart) dimensions 115x110x150mm (in mm on open cart too)

And I have, Australia Post Standard enabled and it gives me

$8.65 for one item @ 0.61kg

I then order 20 of the same item, which equates 12.18kg, ask for shipping quote and it gives me $8.65.

Does this sound right to you?

Id like to put my store on-line asap, however I do not want to miss quote my customers.

eek

=)

Newbie

Posts

Joined
Sun May 20, 2012 8:32 pm

Post by Ozfarmer » Mon May 21, 2012 1:06 pm

SuperJuice wrote:
Ozfarmer wrote:Is anyone else getting these errors?

012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 75
2012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 195
2012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 221

Its not affecting the mod its excellent and yes my iso 2 is AU.
This is strange, but I can honestly say I have never seen it before, thanks for posting it though.

It may be a race condition of some variety.. do you get any similar warning for other modules? or is Auspost just lucky? :D

I will step through the code next time I have it open and see if I can come up with any ideas!.
Hi SJ, sorry missed this reply, I think it may be caused by this line:
2012-05-21 13:53:07 - PHP Notice: Undefined index: shipping_address_id in /home/public_html/vqmod/vqcache/vq2-catalog_controller_checkout_shipping.php on line 11

$shipping_address = $this->model_account_address->getAddress($this->session->data['shipping_address_id']);

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by SuperJuice » Mon May 21, 2012 8:17 pm

Ozfarmer wrote:
SuperJuice wrote:
Ozfarmer wrote:Is anyone else getting these errors?

012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 75
2012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 195
2012-04-04 13:05:55 - PHP Notice: Undefined index: iso_code_2 in /home/public_html/catalog/model/shipping/auspost.php on line 221

Its not affecting the mod its excellent and yes my iso 2 is AU.
This is strange, but I can honestly say I have never seen it before, thanks for posting it though.

It may be a race condition of some variety.. do you get any similar warning for other modules? or is Auspost just lucky? :D

I will step through the code next time I have it open and see if I can come up with any ideas!.
Hi SJ, sorry missed this reply, I think it may be caused by this line:
2012-05-21 13:53:07 - PHP Notice: Undefined index: shipping_address_id in /home/public_html/vqmod/vqcache/vq2-catalog_controller_checkout_shipping.php on line 11

$shipping_address = $this->model_account_address->getAddress($this->session->data['shipping_address_id']);
So it would appear the session hasn't yet set a shipping address.. but I would assume anyone at that step would have that set, I will need to look into again. This isn't happening when you attempt to get a shipping estimate from the product page is it?

If you have managed tocome up with a way to recreate the error through steps in the checkout (or product page) let me know. If I can recreate it, it shouldn't be too hard for me to weed out the issue. Thanks for following up the post.

Active Member

Posts

Joined
Thu Aug 13, 2009 12:06 pm

Post by SuperJuice » Mon May 21, 2012 8:20 pm

ateloh wrote:Hey, I am using the latest version of OpenCart Version 1.5.2.1.

Just wondering if measurements of products (small boxes) need to be in mm or cm?

For some reason, it seems that the Module is not splitting the order up over multiple parcels.


For example, I have a box that weighs 609g (in grams on open cart) dimensions 115x110x150mm (in mm on open cart too)

And I have, Australia Post Standard enabled and it gives me

$8.65 for one item @ 0.61kg

I then order 20 of the same item, which equates 12.18kg, ask for shipping quote and it gives me $8.65.

Does this sound right to you?

Id like to put my store on-line asap, however I do not want to miss quote my customers.

eek

=)
It won't split into multiple parcels until the parcel weight exceeds 20kg, which is the Australia Post parcel limit.

It does seem strange that the price isn't increasing with that amount of increase in weight. If you enable express postage as well (not satchels) do you get the same quote result (ie. when you increase the parcel weight, the price doesn't increase)?

If I can't re-create the issue here I may need to get you to add some lines to the module to debug it. Do you have access to the PHP error log on the server you are configuring this on?

-edit-

I had trouble replicating your issue. I configured the details of the iPhone to exactly match your information in my test environment (length/weight etc) and then calculated postage from an NSW postcode (random) to a QLD postcode (random).

These were the results, first price is for x1, second price is for x20:
Australia Post Standard (est. 3 days delivery) $12.25
Australia Post Standard (est. 3 days delivery) $27.85
Is your origin postcode the same as your destination when testing?, wondering if something like that may be fudging the price.

Active Member

Posts

Joined
Thu Aug 13, 2009 12:06 pm

Post by Ozfarmer » Tue May 22, 2012 12:34 pm

So it would appear the session hasn't yet set a shipping address.. but I would assume anyone at that step would have that set, I will need to look into again. This isn't happening when you attempt to get a shipping estimate from the product page is it?

If you have managed tocome up with a way to recreate the error through steps in the checkout (or product page) let me know. If I can recreate it, it shouldn't be too hard for me to weed out the issue. Thanks for following up the post.
Yes It is odd, it doesnt appear straight away so its hard to work out whats causing it and doesnt affect the operation of the mod

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by mustkillmike » Wed Jun 06, 2012 3:48 pm

Im having a couple dramas with international shipping with my open cart site and the Australia post shipping module.

Im pretty sure i have all the settings correct to ship internationally, but whenever i choose a country other than Australia i got the following

"Warning: No Shipping options are available. Please contact us for assistance!"

Im using version 1.5.3.1 of open cart and version 1511u4 of the module.

the website is http://stil-hora.com if anyone wants to have a look and see if there is something obvious?

thanks,

Mike

Newbie

Posts

Joined
Wed Jun 06, 2012 3:42 pm

Post by crqdesigns » Wed Jun 13, 2012 11:11 am

I am wondering the thing as (mustkillmike)

I have 1.5.3.1 and want to install the Aust post extension.

Newbie

Posts

Joined
Fri Mar 16, 2012 9:22 am

Post by crqdesigns » Wed Jun 20, 2012 1:32 pm

ok manage to make it work on 1.5.3.1
see the attributes settings for the Australia post on the attachment

Attachments

screen.png

screen.png (43.61 KiB) Viewed 5530 times


Newbie

Posts

Joined
Fri Mar 16, 2012 9:22 am

Post by PetSue » Tue Jul 17, 2012 12:01 pm

EDIT: problem sorted all working thank you.

New member

Posts

Joined
Wed Jun 20, 2012 7:38 pm

Post by SuperJuice » Tue Jul 24, 2012 8:10 pm

I can't see a reason why it wouldn't work on 1.5.3.1 as I don't believe there have been major changes to the shipping code. For those who have tested it / got it working, were there any errors you had to work around?

Once I have confirmation from a few people I will update the Extensions page to show compatibility with the new version (I unfortunately am a little time poor at the moment so can't carry out a full test myself).

Speaking of the Extensions page, for some reason my Australia Post module fails to turn up in a search on the Extensions page (the first hit returned isn't my module, it is written by wwwshop a different author).

In the meantime, to get my module you will need to go to the direct link
http://www.opencart.com/index.php?route ... on_id=1011

I have raised this with Daniel so hope it will be fixed soon.

I didn't remove the module, it is still there!

Active Member

Posts

Joined
Thu Aug 13, 2009 12:06 pm

Post by boonga » Wed Aug 01, 2012 6:19 am

SuperJuice wrote:
ateloh wrote:Hey, I am using the latest version of OpenCart Version 1.5.2.1.

Just wondering if measurements of products (small boxes) need to be in mm or cm?

For some reason, it seems that the Module is not splitting the order up over multiple parcels.


For example, I have a box that weighs 609g (in grams on open cart) dimensions 115x110x150mm (in mm on open cart too)

And I have, Australia Post Standard enabled and it gives me

$8.65 for one item @ 0.61kg

I then order 20 of the same item, which equates 12.18kg, ask for shipping quote and it gives me $8.65.

Does this sound right to you?

Id like to put my store on-line asap, however I do not want to miss quote my customers.

eek

=)
It won't split into multiple parcels until the parcel weight exceeds 20kg, which is the Australia Post parcel limit.

It does seem strange that the price isn't increasing with that amount of increase in weight. If you enable express postage as well (not satchels) do you get the same quote result (ie. when you increase the parcel weight, the price doesn't increase)?

If I can't re-create the issue here I may need to get you to add some lines to the module to debug it. Do you have access to the PHP error log on the server you are configuring this on?

-edit-

I had trouble replicating your issue. I configured the details of the iPhone to exactly match your information in my test environment (length/weight etc) and then calculated postage from an NSW postcode (random) to a QLD postcode (random).

These were the results, first price is for x1, second price is for x20:
Australia Post Standard (est. 3 days delivery) $12.25
Australia Post Standard (est. 3 days delivery) $27.85
Is your origin postcode the same as your destination when testing?, wondering if something like that may be fudging the price.
FYI: Australia post have fixed pricing for parcels lodged at an office within 50km of the delivery office. So any two postcodes that are close to one another will attract this fixed pricing no matter the parcel weight (up to 20kg). This could well be ateloh's problem.

By the way, thanks for the shipping module. I haven't used it yet, but plan to soon.

Newbie

Posts

Joined
Wed Aug 01, 2012 5:34 am

Post by tora0515 » Wed Aug 01, 2012 10:13 am

Having problems with dimensions.

I have some large products that are often bought in multiples. When more than 2 products are added to the cart, the dimensions exceed auspost's values. My customers receive the error: The dimensions exceed the maximum girth of 140cm.

Is there a way to split this into 2 shipments? Maybe using length and cubic volume?

Thanks

Active Member

Posts

Joined
Fri Jun 15, 2012 3:05 pm

Post by Ozfarmer » Fri Aug 03, 2012 5:04 pm

Easy Question? where do I change this text? "There is a single item in your cart that is too heavy to ship with Australia Post (20kg)"

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by stephanmuller » Sun Aug 05, 2012 9:06 pm

SuperJuice, you are most certainly a legend, do you have a paypal donation box setup or anything?

Also, for a future improvement, is it possible to make a rounding feature, say to the nearest (or next) 50 cents? or is this just a piece of code that can be modified easily (well easy for you haha)?

many thanks
Stephan

Newbie

Posts

Joined
Sun Aug 05, 2012 9:01 pm

Post by philbydevil » Mon Aug 06, 2012 6:15 am

Ozfarmer wrote:Easy Question? where do I change this text? "There is a single item in your cart that is too heavy to ship with Australia Post (20kg)"
There's some text in the catalog/model file. I think that's there.

I heart cmd-f, cmd-c, cmd-v, cmd-z + vQmod.
My favourite page...
v1.5.4.1


User avatar
Active Member

Posts

Joined
Fri Dec 03, 2010 5:20 am

Post by Anon_ » Mon Aug 06, 2012 7:56 pm

Why does it only allow Air Mail and Sea Mail international shipping options with no express or other options?

Newbie

Posts

Joined
Mon Aug 06, 2012 7:55 pm

Post by PetSue » Sun Aug 12, 2012 8:06 am

I'm now getting an error - "Error interfacing with Australia Post (connection)"

It was working fine, but now this error.

Any suggestions please?

New member

Posts

Joined
Wed Jun 20, 2012 7:38 pm

Post by downunderjane » Sun Aug 12, 2012 7:01 pm

For some reason I cannot access the download links. Is there a problem?

I tried downloading the latest version opencart1511u4.auspost.zip but all I get is the error Error: Could not find file opencart1511u4.auspost.zip!

Is someone able to point me to another source for this file?

Thanks

Newbie

Posts

Joined
Sun Aug 12, 2012 6:59 pm

Post by Daniel » Sun Aug 12, 2012 10:20 pm

yes i'm downloading a backup now to reupload all the downloads.

will take a few hours. sorry.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 5 guests