Post by aurevilly » Mon Mar 05, 2012 7:57 am

solojuve1897 wrote:*Reposted* - Is there no fix for this? [...]
I can also confirm I have the same bug on my store even tho it's not a *clean install*.

User avatar
New member

Posts

Joined
Thu Sep 29, 2011 4:32 am
Location - Sherbrooke, Canada

Post by Calcite » Mon Mar 05, 2012 6:24 pm

Thanks for posting the bug fix.

I am puzzled by bug fixes though. Does the main download file get updated when a fix is written?

Just asking because rather than trawl all the bug fix thread it would be good to know what fixes were incorporated into the main OC download file by date?

Active Member

Posts

Joined
Fri Dec 30, 2011 3:21 am

Post by osyshine » Wed Mar 07, 2012 9:13 am

Hi, i have open cart 1.5.1.3 . could someone tell me where i can find import /export tools. i could not find anywhere
thanks
osyshine

Newbie

Posts

Joined
Wed Mar 07, 2012 9:09 am

Post by Pittman » Fri Mar 09, 2012 12:45 am

Okay, so I am running Opencart 1.5.1.3 on my server, and setup has been tough, but going fine so far.

However, upon testing the checkout process (using testcard information), even though I get a successful transaction, I end up being redirected to an error page that says:

Notice: Error: Could not load language checkout/success! in /home3/johncpit/public_html/johnpittman/opencart/system/library/language.php on line 26

So what gives....why am I getting this error and what does it mean? I haven't changed the file being referenced in the error, so it should be fine since it would be the file that was uploaded upon installation.

Help? Advice? Info? Please!!! LOL

Newbie

Posts

Joined
Fri Mar 09, 2012 12:43 am

Post by Qphoria » Fri Mar 09, 2012 2:08 am

Pittman wrote: Notice: Error: Could not load language checkout/success! in /home3/johncpit/public_html/johnpittman/opencart/system/library/language.php on line 26
It means it could not load this file:
catalog/language/english/checkout/success.php
because it doesn't exist

Or if you are using another language.. it doesn't exist in that language.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by solojuve1897 » Fri Mar 09, 2012 2:31 am

Qphoria, can you please help out with the bug I reported?

Regards,

Newbie

Posts

Joined
Fri Jun 03, 2011 1:00 am

Post by Qphoria » Fri Mar 09, 2012 2:54 am

solojuve1897 wrote:*Reposted* - Is there no fix for this?

Do the following:

First: Have a clean install of OpenCart 1.5.1.3

1. Put something in the cart.

2. Go to checkout

3. Choose Register account

4. Input all your details and uncheck "My delivery and billing addresses are the same."

5. Choose "I want to use a new address" and input your details

6. Complete the order.

7. Go to the admin and check the new order.

8. Choose "Payment Details"

The bug: The payment details are empty!

It's really strange that this hasnt been reported before? Or maybe it has? It's kind of a big bug. What to do to fix this issue?

Image

cannot reproduce

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by solojuve1897 » Fri Mar 09, 2012 3:11 am

That was really strange. Have tested it locally (with XAMP) and on my host. Did you try with a fresh install of 1.5.1.3?

I don't get it.

Newbie

Posts

Joined
Fri Jun 03, 2011 1:00 am

Post by speedingorange » Fri Mar 09, 2012 6:19 am

I have searched and cannot find an answer to this one;

Have it occurring on two sites so am pretty sure it is a bug? common factors are that they both run paypal standard?

(may just be that I am not searching in the right places but I spent a good hour googling & searching the forums)

I am getting the error:

Code: Select all

PHP Notice:  Undefined variable: payment_address in /home/bla/public_html/catalog/controller/checkout/payment.php on line 88
I believe this is different to the "payment_address_id" and "shipping_address_id" errors as I have already applied the fix for these,

Anyone any ideas on how to fix this as It has cost me several sales in the past few days.

Cheers
James

Active Member

Posts

Joined
Tue Feb 23, 2010 7:33 pm

Post by 12OZmouse » Fri Mar 09, 2012 9:48 am

Hi, I have done a fresh install of 1.5.1.3

Admin panel is working, however when I navigate to the front-end this error message pops:

Fatal error: Call to a member function isLogged() on a non-object in /home/xxx/public_html/xxxx/catalog/model/catalog/product.php on line 8

I have re-uploaded the catalog directory twice and it doesn't seem to have an effect. Can anyone please assist? Thanks in advance.

Newbie

Posts

Joined
Thu Sep 16, 2010 8:45 am

Post by dstart » Fri Mar 09, 2012 9:08 pm

speedingorange wrote:I have searched and cannot find an answer to this one;

Have it occurring on two sites so am pretty sure it is a bug? common factors are that they both run paypal standard?

(may just be that I am not searching in the right places but I spent a good hour googling & searching the forums)

I am getting the error:

Code: Select all

PHP Notice:  Undefined variable: payment_address in /home/bla/public_html/catalog/controller/checkout/payment.php on line 88
I believe this is different to the "payment_address_id" and "shipping_address_id" errors as I have already applied the fix for these,

Anyone any ideas on how to fix this as It has cost me several sales in the past few days.

Cheers
James
I am seeing this too,

Apart from it seems to always be followed by checkout/confirm page errors ( i know some of these can be reproduced by directly accessing the checkout/confirm page. However this does not replicate the line 88 error.

Code: Select all

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/payment.php on line 88

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/payment.php on line 88

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 120

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 121

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 122

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 123

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 124

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 125
2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 126

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 127

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 128

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 129

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 130

2012-03-03 8:40:40 - PHP Notice:  Undefined variable: payment_address in /home/xxx/public_html/catalog/controller/checkout/confirm.php on line 131
We have had a few phonecalls from customers who cannot check out because of this error.

Newbie

Posts

Joined
Wed Jul 14, 2010 10:44 pm

Post by yiyinlah » Wed Mar 14, 2012 5:18 am

matts118 wrote:Hi. I found a bug, and also fixed it. The USPS module gives incorrect values for foreign currencies as it multiplies the US$ value twice. It isn't so noticeable with Euros etc as they are already close to the US$, but if you have Yen or Hungarian Forints, you get shipping equivalents of thousands of dollars.

The fix is:

go to catalog/model/shipping/usps.php

find this line (it occurs several times)
'text' => $this->currency->format($this->tax->calculate($this->currency->convert($cost, 'USD', $this->currency->getCode()), $this->config->get('usps_tax_class_id'), $this->config->get('config_tax')))

replace with
'text' => $this->currency->format($this->tax->calculate($cost, $this->config->get('usps_tax_class_id'), $this->config->get('config_tax')))

find
'cost' => $this->currency->convert($cost, 'USD', $this->config->get('config_currency')),

replace with
'cost' => $cost,

The problem is this $this->currency->convert() converts the currency from US$, and then the format() function does it again, so the initial US$ number is multiplied twice by the new currency. So need to remove the $this->currency->convert().

Hi, I'm experiencing the same problem, but I have only weight based shipping & free shipping available.
Also for payment, only Paypal Standard & bank transfer.
So I don't know what's the problem? Can someone help please?

I'm using Opencart 1.5.4.1 & vQmod 2.3.2.


User avatar
Active Member

Posts

Joined
Thu Sep 23, 2010 1:19 pm
Location - Singapore

Post by zfed » Fri Mar 16, 2012 5:07 am

hi.

I don't know if it was already reported, but if I copy/clone product that has additional images them in copy of original I must add additional img. again. Sorry if it is already discussed. version 1.5.1.3

Newbie

Posts

Joined
Sat Dec 24, 2011 1:16 am

Post by davidkimm » Sat Mar 17, 2012 3:42 am

Database bug in 1.5.1.3 ... for country usa 223 ... zone code AL (Alabama) shows up as AK (Alaska) in customer order. How can this be corrected to AL in admin order page... Thank you

New member

Posts

Joined
Wed Mar 23, 2011 3:12 pm

Post by storm-cloud » Wed Apr 04, 2012 10:47 am

storm-cloud wrote:Not 100% sure if this is a bug but thought this would be a good place to start.

I have found that the search box at the top of the store only references one word. For example, if I enter "Word A" and "Word B", the results appear. Then if I change "Word B" even if the word is gibberish, the results stay the same.

Now I have products that "Word A" is the same but "Word B" is different, but if I search with the two words, the results are the nearly same (the order changes slightly but the two word match is not being prioritised in any way). It seems that the search is not paying attention to "Word B" at all.

Surely if I search for a two word string that matches a product with both words, then the products matching with both words should show up at the top of the results list, and those products only matching with one word should be filtered out or placed at the end of the list?
Please excuse me quoting this again but is this not of concern to the developers? If I type a three word string into the search box, it seems to present all products with either of the three words. To clarify if a product contains only one of the three words, it is still presented in search results.

For example, the three word search that I just performed should reveal 3 products. However, I was presented with 89 products!

This makes the search function near useless as we have many products that share perhaps one word but the other words identify it as a completely different product.
Last edited by storm-cloud on Mon Apr 09, 2012 2:09 pm, edited 1 time in total.

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by shopper » Thu Apr 05, 2012 1:05 am

I'm using a category list in column_left.
When selecting a category, the url of the active category list item normally gets a <a class="active">

However when enabling SEO url's and adding a seo keyword for the active category the category link isn't appointed 'class="active" '.

The code in catalog/view/theme/template-name/template/modulestates:

Code: Select all

<?php if ($category['category_id'] == $category_id) { ?>
<a href="<?php echo $category['href']; ?>" class="active"><?php echo $category['name']; ?></a>
<?php } else { ?>
This was also the case with the default opencart template.

Newbie

Posts

Joined
Fri Jan 21, 2011 7:05 pm

Post by storm-cloud » Mon Apr 09, 2012 1:41 pm

I have just discovered that when a discount coupon is applied and the customer selects PayPal (we use the PayPal Standard module included with OpenCart) that the discount is not applied when reaching the PayPal gateway.

I would assume that this is a bug. Could anyone advise if this has been mentioned previously and if there is a fix for it?

Edit: Never mind, found a fix for it. For some reason, the theme we are using has included a broken PayPal template file. This code was missing:

Code: Select all

<?php if ($discount_amount_cart) { ?>
<input type="hidden" name="discount_amount_cart" value="<?php echo $discount_amount_cart; ?>" />
<?php } ?>

Active Member

Posts

Joined
Wed Feb 22, 2012 8:07 am

Post by catalinpl » Fri Apr 20, 2012 9:14 pm

- you are a new customer/visitor
- add products to cart
- go to checkout\
- choose `register account`
- fill all the details
- keep billing and shipping address the same
- complete order

in admin (order details) the shipping details tab is missing.
i have checked in the database and the shipping_firstname, etc are empty and also, in `order_total` table, the shipping line for the current order is missing and the `total` line has no shipping included

so, if i have more than one shipping methods, i basically have no idea which one the customer chose.

Newbie

Posts

Joined
Fri Apr 20, 2012 9:01 pm

Post by apenimon » Mon Apr 23, 2012 7:25 pm

Hi,

I am having a problem with uploading photos, this is only started recently I couldn't figure out what causing this error. I have tried it from different browsers and each of the throws slightly different error logs, but can't upload image through any of the browsers. The error log I get as below:

I would really appreciate it if anyone can help me out to find a solution to this error. Apologise if I posted this wrong forum category!

SyntaxError: JSON.parse

OK

[{"filename":"$(KGrHqEOKj8E5c3cl590BOelu!DmF!~~60_3.jpg","file":"$(KGrHqEOKj8E5c3cl590BOelu!DmF!~~60_3.jpg","size":"60.9KB"},{"filename":"$(KGrHqEOKkME1qKbRUyKBNre31Yl-Q~~0_3.jpg","file":"$(KGrHqEOKkME1qKbRUyKBNre31Yl-Q~~0_3.jpg","size":"60.32KB"},{"filename":"$(KGrHqF,!lEE6pcNO6gqBO)trjh(3!~~60_3.jpg","file":"$(KGrHqF,!lEE6pcNO6gqBO)trjh(3!~~60_3.jpg","size":"59.23KB"},{"filename":"$(KGrHqF,!p8E63ZwgZ(3BO29yDhLYw~~60_3.jpg","file":"$(KGrHqF,!p8E63ZwgZ(3BO29yDhLYw~~60_3.jpg","size":"62.1KB"},{"filename":"$(KGrHqFHJBsE60e3tjkeBO1Ve6UtO!~~60_3.jpg","file":"$(KGrHqFHJBsE60e3tjkeBO1Ve6UtO!~~60_3.jpg","size":"80KB"},{"filename":"$(KGrHqFHJC0E7BcvfcB9BO1Ve9(9Bg~~60_3.jpg","file":"$(KGrHqFHJC0E7BcvfcB9BO1Ve9(9Bg~~60_3.jpg","size":"79.2KB"},{"filename":"$(KGrHqFHJDcE63Z(jjCLBO2-)UPQjQ~~60_3.jpg","file":"$(KGrHqFHJDcE63Z(jjCLBO2-)UPQjQ~~60_3.jpg","size":"72.35KB"},{"filename":"$(KGrHqJ,!iwE68Ozrg5YBO29yDz!dQ~~60_3.jpg","file":"$(KGrHqJ,!iwE68Ozrg5YBO29yDz!dQ~~60_3.jpg","size":"67.17KB"},{"filename":"$(KGrHqMOKpIE5W!19tj-BOelt)NbLQ~~60_3.jpg","file":"$(KGrHqMOKpIE5W!19tj-BOelt)NbLQ~~60_3.jpg","size":"82.89KB"},{"filename":"$(KGrHqMOKpQE1qmfnzf)BNre4holYg~~0_3.jpg","file":"$(KGrHqMOKpQE1qmfnzf)BNre4holYg~~0_3.jpg","size":"57.29KB"},{"filename":"$(KGrHqN,!oUE8VkRp!7iBPNvg2Jh9!~~60_3.jpg","file":"$(KGrHqN,!oUE8VkRp!7iBPNvg2Jh9!~~60_3.jpg","size":"53.82KB"},{"filename":"$(KGrHqNHJ!0E63RuBb3yBO1Ve4KRNg~~60_3.jpg","file":"$(KGrHqNHJ!0E63RuBb3yBO1Ve4KRNg~~60_3.jpg","size":"61.04KB"},{"filename":"$(KGrHqQOKpEE5ZME29CDBOg4!HfHQ!~~60_3.jpg","file":"$(KGrHqQOKpEE5ZME29CDBOg4!HfHQ!~~60_3.jpg","size":"70.15KB"},{"filename":"$(KGrHqR,!oME63(Z)iV8BO0(U4NMH!~~60_3.jpg","file":"$(KGrHqR,!oME63(Z)iV8BO0(U4NMH!~~60_3.jpg","size":"140.88KB"},{"filename":"$(KGrHqRHJCkE63YKh+SjBO0(U+z!5Q~~60_3.jpg","file":"$(KGrHqRHJCkE63YKh+SjBO0(U+z!5Q~~60_3.jpg","size":"136.81KB"},{"filename":"$(KGrHqUOKjUE5RbbyUGlBOelt26y-g~~60_3.jpg","file":"$(KGrHqUOKjUE5RbbyUGlBOelt26y-g~~60_3.jpg","size":"162.69KB"},{"filename":"$(KGrHqV,!hUE6cefp35+BO)tr7PWi!~~60_3.jpg","file":"$(KGrHqV,!hUE6cefp35+BO)tr7PWi!~~60_3.jpg","size":"63.52KB"},{"filename":"$(KGrHqVHJ!0E63RuCk3FBO2-)FSTpQ~~60_3.jpg","file":"$(KGrHqVHJ!0E63RuCk3FBO2-)FSTpQ~~60_3.jpg","size":"71.77KB"},{"filename":"$(KGrHqVHJ!sE63KspWjwBO1Vez1WL!~~60_3.jpg","file":"$(KGrHqVHJ!sE63KspWjwBO1Vez1WL!~~60_3.jpg","size":"69.43KB"},{"filename":"$(KGrHqYOKnUE53V-VJVpBOelt4wzFg~~60_3.jpg","file":"$(KGrHqYOKnUE53V-VJVpBOelt4wzFg~~60_3.jpg","size":"76.73KB"},{"filename":"$(KGrHqYOKpEE5ZHm1DS,BOg4!!hr)!~~60_3.jpg","file":"$(KGrHqYOKpEE5ZHm1DS,BOg4!!hr)!~~60_3.jpg","size":"72.06KB"},{"filename":"$(KGrHqZ,!loE64s,sRPtBO)trhq2W!~~60_3.jpg","file":"$(KGrHqZ,!loE64s,sRPtBO)trhq2W!~~60_3.jpg","size":"143.92KB"},{"filename":"$(KGrHqZ,!lwE65jmZmO(BO29yKn47g~~60_3.jpg","file":"$(KGrHqZ,!lwE65jmZmO(BO29yKn47g~~60_3.jpg","size":"68.78KB"},{"filename":"$(KGrHqZ,!m!E5e)7o38HBOelt1dOUQ~~60_12.jpg","file":"$(KGrHqZ,!m!E5e)7o38HBOelt1dOUQ~~60_12.jpg","size":"75.05KB"},{"filename":"$(KGrHqZ,!nME63S99g!QBO29y(RrsQ~~60_3.jpg","file":"$(KGrHqZ,!nME63S99g!QBO29y(RrsQ~~60_3.jpg","size":"90.28KB"},{"filename":"$(KGrHqZHJBQE8e36C5sfBPNvQvPQLQ~~60_3.jpg","file":"$(KGrHqZHJBQE8e36C5sfBPNvQvPQLQ~~60_3.jpg","size":"56.32KB"},{"filename":"$(KGrHqZHJCIE8mU5sorBBPNbTOsrS!~~60_3.jpg","file":"$(KGrHqZHJCIE8mU5sorBBPNbTOsrS!~~60_3.jpg","size":"62.22KB"},{"filename":"1 (1).jpg","file":"1 (1).jpg","size":"75.55KB"},{"filename":"1 (12).jpg","file":"1 (12).jpg","size":"65.32KB"},{"filename":"1 (16).jpg","file":"1 (16).jpg","size":"80.12KB"},{"filename":"BLACK (2).jpg","file":"BLACK (2).jpg","size":"278.78KB"},{"filename":"BLACK (5).jpg","file":"BLACK (5).jpg","size":"245.41KB"},{"filename":"BROWN (2).jpg","file":"BROWN (2).jpg","size":"241.7KB"},{"filename":"BROWN (4).jpg","file":"BROWN (4).jpg","size":"263.51KB"},{"filename":"CAMEL (2).jpg","file":"CAMEL (2).jpg","size":"268.07KB"},{"filename":"CAMEL (4).jpg","file":"CAMEL (4).jpg","size":"274.2KB"},{"filename":"CANTA.jpg","file":"CANTA.jpg","size":"80.54KB"},{"filename":"DARK BROWN (1).jpg","file":"DARK BROWN (1).jpg","size":"248.43KB"},{"filename":"IMG_5631.jpg","file":"IMG_5631.jpg","size":"89.04KB"},{"filename":"IMG_5643.jpg","file":"IMG_5643.jpg","size":"89.84KB"},{"filename":"Untitled-1.jpg","file":"Untitled-1.jpg","size":"53.82KB"},{"filename":"banner 4.jpg","file":"banner 4.jpg","size":"212.56KB"},{"filename":"cart.png","file":"cart.png","size":"421B"},{"filename":"def.jpg","file":"def.jpg","size":"102.44KB"},{"filename":"flat.jpg","file":"flat.jpg","size":"61.82KB"},{"filename":"gift-voucher-birthday.jpg","file":"gift-voucher-birthday.jpg","size":"19.82KB"},{"filename":"hp_3.jpg","file":"hp_3.jpg","size":"17.86KB"},{"filename":"hp_banner.jpg","file":"hp_banner.jpg","size":"29.85KB"},{"filename":"hp_logo.jpg","file":"hp_logo.jpg","size":"18.99KB"},{"filename":"htc_logo.jpg","file":"htc_logo.jpg","size":"59.17KB"},{"filename":"htc_touch_hd_1.jpg","file":"htc_touch_hd_1.jpg","size":"14.26KB"},{"filename":"htc_touch_hd_2.jpg","file":"htc_touch_hd_2.jpg","size":"3.68KB"},{"filename":"htc_touch_hd_3.jpg","file":"htc_touch_hd_3.jpg","size":"25KB"},{"filename":"il_570xN.151165595.jpg","file":"il_570xN.151165595.jpg","size":"71.21KB"},{"filename":"il_570xN.151171911.jpg","file":"il_570xN.151171911.jpg","size":"67.62KB"},

Newbie

Posts

Joined
Wed Apr 11, 2012 1:05 am

Post by Daniel » Mon Apr 23, 2012 9:29 pm

ranem your files just using normal characters.

$(KGrHqF,!lEE6pcNO6gqBO)trjh(3!~~60_3.jpg is ridiculousness.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 15 guests