Post by tobychin » Fri Jan 20, 2012 11:06 pm

Okay. So, I finally have SSL enabled AND working on my site. Now, however, the images that are being served from Opencart aren't displayed. The links are good, though. I can view the page source and click on the link and voila! Image. HTTPS and all. But, it doesn't show on pages like: https://accents.jbsfurniture.com/account/login. Any ideas??

Let me just say, I love this forum. This group of users/coders/developers is awesome! Always someone willing to help!
Last edited by tobychin on Tue Jan 24, 2012 12:01 am, edited 1 time in total.

- Toby
"The only way to get to the top is to get off your bottom." - Fortune Cookie


New member

Posts

Joined
Tue Jul 12, 2011 12:03 am
Location - Warsaw, Indiana

Post by florinsith » Fri Jan 20, 2012 11:31 pm

In the config.php try setting the define('HTTPS_IMAGE', 'https:// with http at the adress instead of https.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by tobychin » Fri Jan 20, 2012 11:44 pm

Already done... Images aren't displaying in the admin section either... Here's my root config file:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://accents.jbsfurniture.com/');
define('HTTP_IMAGE', 'http://accents.jbsfurniture.com/image/');
define('HTTP_ADMIN', 'http://accents.jbsfurniture.com/admin/');

// HTTPS
define('HTTPS_SERVER', 'https://accents.jbsfurniture.com/');
define('HTTPS_IMAGE', 'https://accents.jbsfurniture.com/image/');
And my config.php file in my admin:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://accents.jbsfurniture.com/admin/');
define('HTTP_CATALOG', 'http://accents.jbsfurniture.com/');
define('HTTP_IMAGE', 'http://accents.jbsfurniture.com/image/');

// HTTPS
define('HTTPS_SERVER', 'https://accents.jbsfurniture.com/admin/');
define('HTTPS_IMAGE', 'https://accents.jbsfurniture.com/image/');

- Toby
"The only way to get to the top is to get off your bottom." - Fortune Cookie


New member

Posts

Joined
Tue Jul 12, 2011 12:03 am
Location - Warsaw, Indiana

Post by tobychin » Sat Jan 21, 2012 12:17 am

florinsith wrote:In the config.php try setting the define('HTTPS_IMAGE', 'https:// with http at the adress instead of https.
Sorry, just reread your post. Wouldn't that break the SSL certificate and make the page not secure?

- Toby
"The only way to get to the top is to get off your bottom." - Fortune Cookie


New member

Posts

Joined
Tue Jul 12, 2011 12:03 am
Location - Warsaw, Indiana

Post by florinsith » Sat Jan 21, 2012 1:35 am

Yes , you are right. Its weird , sometimes the images work and sometimes they dont. Try contacting godaddy, maybe its because of them.

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by victorj » Sat Jan 21, 2012 5:42 am

opencart does apply ssl only to the sensitive parts op the website witch is making a account and checking out.
If you want your shop completely under Ssl it is a total other game.
Not impossible but takes some hard work

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by tobychin » Tue Jan 24, 2012 12:01 am

Turns out it was a hotlink issue on my host. They're resolved it and it's all good now. Their response to my issue:
I've corrected your hotlink protection rules and now see the images displayed on the secure pages of your site, as you were previously missing the https URL's in the hotlink protection exclude list.

- Toby
"The only way to get to the top is to get off your bottom." - Fortune Cookie


New member

Posts

Joined
Tue Jul 12, 2011 12:03 am
Location - Warsaw, Indiana
Who is online

Users browsing this forum: No registered users and 76 guests