Post by gertjan91 » Wed Sep 28, 2011 4:13 pm

Hi,

Does anyone know how to solve the following problem?
I think this error is also the reason my Image manager does not work.
The full error code is as followed and can be found in my settings panel;

Warning: imagepng() [function.imagepng]: SAFE MODE Restriction in effect. The script whose uid is 661 is not allowed to access /home/mbtools/domains/accuboorhamer.nl/public_html/image/cache/data owned by uid 101 in /home/mbtools/domains/accuboorhamer.nl/public_html/system/library/image.php on line 46Warning: imagepng() [function.imagepng]: Invalid filename in /home/mbtools/domains/accuboorhamer.nl/public_html/system/library/image.php on line 46Warning: imagepng() [function.imagepng]: SAFE MODE Restriction in effect. The script whose uid is 661 is not allowed to access /home/mbtools/domains/accuboorhamer.nl/public_html/image/cache/data owned by uid 101 in /home/mbtools/domains/accuboorhamer.nl/public_html/system/library/image.php on line 46Warning: imagepng() [function.imagepng]: Invalid filename in /home/mbtools/domains/accuboorhamer.nl/public_html/system/library/image.php on line 46

Regards,

Gertjan

Newbie

Posts

Joined
Tue Sep 13, 2011 8:12 pm

Post by florinsith » Wed Sep 28, 2011 4:19 pm

Try disabling safemode in php.ini

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by gertjan91 » Wed Sep 28, 2011 6:29 pm

Thanx, but nope does not change anything!

Newbie

Posts

Joined
Tue Sep 13, 2011 8:12 pm

Post by i2Paq » Wed Sep 28, 2011 6:47 pm

gertjan91 wrote:Thanx, but nope does not change anything!
Contact you hoster, if they will not disable it then move to another hoster.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Xsecrets » Wed Sep 28, 2011 8:15 pm

did you develop this on a local server then move it to your host? if so you need to delete everything from your cache folders.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by TAC » Thu Jan 05, 2012 12:35 am

I have had similar problems today, even though my site has been running successfully since last September. I read as many forum posts as I could and followed all the hints. I even checked in Plesk and safe mode was definitely off.

As each post seemed to end with "contact your host" I did and they did something and now it all works again.

So mystery not solved (in my mind) but problem solved so I am happy ;D

User avatar
TAC
Active Member

Posts

Joined
Sun Sep 26, 2010 1:33 am
Location - England

Post by itq9 » Mon May 28, 2012 8:45 pm

I had the same problem on my server and already had the Safe Mode set to off in my PHP.INI file but continued to receive the error.

My fix was to delete the image/cache/data folder and re-create and then re-set the permissions to 777. On my server it was not initially possible to set the permission on the folder but by deleting and re-creating I set the permissions and all is now running correctly! I hope this may help others.

Newbie

Posts

Joined
Mon May 28, 2012 8:42 pm

Post by GaryG » Fri Jan 25, 2013 4:07 am

I notice for some servers you will have to reset file owner for some directories through the server file manager. You will not be allowed to change file permissions and this error or similar php errors will occur. I had to reset all these files and the error removed.

Newbie

Posts

Joined
Sat Dec 03, 2011 9:37 am
Who is online

Users browsing this forum: No registered users and 11 guests