Post by dry_flood » Sat Feb 12, 2011 2:24 am

This will add both a Facebook share button and a Tweet button to the product page.

Image

New member

Posts

Joined
Tue Dec 14, 2010 4:33 am

Post by Phil » Fri Mar 04, 2011 7:32 pm

Love this mod, I put it on straight away. Only problem I'm having is that when I click on the tweet button on any of the product pages I get a new window with twitter page in it saying:

URL required

'url' parameter does not contain a valid URL.
Retry Close

Is anyone else getting this? ???

New member

Posts

Joined
Fri Feb 18, 2011 6:10 pm


Post by philbydevil » Sat Mar 05, 2011 6:43 pm

No, it's working fine for me on 1.4.9.3.

For me, the only "problem" I have is that the Facebook "Share" doesn't show a number 0 (zero) when a product hasn't been shared. This may be normal behavior but I'm not too sure. Tweet shows 0, so that's why I'm wondering...

Thanks to dry_flood for this vQmod.

I Image cmd-f, cmd-c, cmd-v, cmd-z + vQmod.
My favourite page...
v1.5.4.1


User avatar
Active Member

Posts

Joined
Fri Dec 03, 2010 5:20 am
Location - Sunshine Coast, Australia

Post by philbydevil » Sat Mar 05, 2011 6:49 pm

I would like to know who is Sharing and Tweeting my products (and which ones too). Is there some way to "track" the Shares and Tweets? I know I can just view the product to see the number of Shares/Tweets, but some more in depth tracking would be interesting.

I Image cmd-f, cmd-c, cmd-v, cmd-z + vQmod.
My favourite page...
v1.5.4.1


User avatar
Active Member

Posts

Joined
Fri Dec 03, 2010 5:20 am
Location - Sunshine Coast, Australia

Post by qahar » Sat Mar 05, 2011 7:18 pm

philbydevil wrote:I would like to know who is Sharing and Tweeting my products (and which ones too). Is there some way to "track" the Shares and Tweets? I know I can just view the product to see the number of Shares/Tweets, but some more in depth tracking would be interesting.
Try to use addThis

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by philbydevil » Sun Mar 06, 2011 7:17 am

qahar wrote:Try to use addThis
Looks good qahar. I signed up for an account, but during the sign up process it did mention that Facebook "Like" and Twitter weren't trackable...

Anyway, I've added it to my site (and my Google Analytics account - which tracking things easier) and will see how it goes.

Thanks.

I Image cmd-f, cmd-c, cmd-v, cmd-z + vQmod.
My favourite page...
v1.5.4.1


User avatar
Active Member

Posts

Joined
Fri Dec 03, 2010 5:20 am
Location - Sunshine Coast, Australia

Post by 1uk3 » Wed Mar 30, 2011 6:29 pm

philbydevil wrote:
qahar wrote:Try to use addThis
Looks good qahar. I signed up for an account, but during the sign up process it did mention that Facebook "Like" and Twitter weren't trackable...

Anyway, I've added it to my site (and my Google Analytics account - which tracking things easier) and will see how it goes.

Thanks.
You can track Tweets by adding a hash tag and/or Twitter username to the Tweet. It's not a perfect solution but it gives you an idea....

If you change the Twitter code in Facebook_Tweeter.xml to something like this, it'll work:

Code: Select all

<a href="http://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="YourTwitterUsername #ADescriptiveHashTag">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>

OpenCart 1.4.9.4


Newbie

Posts

Joined
Wed Mar 30, 2011 3:14 pm

Post by starsunflower » Mon Apr 11, 2011 9:06 am

All plugins and sharer codes I've used so far in opencart version 1.4.9.1 do not reliably track the sharing counts. Any digs on this? I really don't want to enable the SEO urls as it seems a bit messy atm. Tried it and some products bring up 404 errors. I've never encountered this issue with sharing buttons before. Even tried addthis as a default fallback if nothing works and it's not showing the counts either. Any suggestions?

User avatar
New member

Posts

Joined
Fri May 22, 2009 1:58 am


Post by starsunflower » Mon Apr 11, 2011 9:14 am

Ok looks as though the facebook like button is working to show the counts and the orange share button from addthis. So I guess it's all good now. I couldn't get the twitter part to display the share counts so I just deleted that line of code from the flat horizontal share buttons.

User avatar
New member

Posts

Joined
Fri May 22, 2009 1:58 am


Post by farrow » Fri May 27, 2011 3:19 pm

OC 1.4.9.4
Works Great! Thanks!

New member

Posts

Joined
Sat Apr 16, 2011 5:02 pm
Location - Oklahoma

Post by ripper » Thu Jul 21, 2011 8:18 pm

Hi,
I made some changes and now it's working for OC 1.5.1 and vQmod 1.2.3. Hope dry_flood wouldn't be angry. :drunk:

New member

Posts

Joined
Wed Jul 06, 2011 4:37 am

Post by eric1998 » Sat Jul 30, 2011 9:49 am

Thanks ripper !

http://wm-distribution.com ---- OC 1.5.1.3


User avatar
New member

Posts

Joined
Sat Apr 02, 2011 10:39 pm

Post by hbg » Fri Aug 12, 2011 4:01 pm

Hi, I just loaded this but no images show up. I have had a few issues trying to install other facebook likes on 1.5.0.5.
http://opencart.homebrewinn.com.au/shop ... super-pack

Opencart Version 1.5.1.3
https://www.opencart.homebrewinn.com.au/shop/


User avatar
hbg
Active Member

Posts

Joined
Wed Apr 13, 2011 8:52 am
Location - Newcastle NSW Australia

Post by BoardShades » Mon Sep 05, 2011 9:25 am

ripper wrote:Hi,
I made some changes and now it's working for OC 1.5.1 and vQmod 1.2.3. Hope dry_flood wouldn't be angry. :drunk:
What folder do I upload the xml file to?

Newbie

Posts

Joined
Fri Aug 26, 2011 2:37 pm

Post by hbg » Mon Sep 05, 2011 9:46 am

BoardShades wrote:
ripper wrote:Hi,
I made some changes and now it's working for OC 1.5.1 and vQmod 1.2.3. Hope dry_flood wouldn't be angry. :drunk:
What folder do I upload the xml file to?
VQMOD\XML

Use Filezilla, if you are not already. :)

Opencart Version 1.5.1.3
https://www.opencart.homebrewinn.com.au/shop/


User avatar
hbg
Active Member

Posts

Joined
Wed Apr 13, 2011 8:52 am
Location - Newcastle NSW Australia

Post by BoardShades » Mon Sep 05, 2011 10:11 am

hbg wrote:
BoardShades wrote:
ripper wrote:Hi,
I made some changes and now it's working for OC 1.5.1 and vQmod 1.2.3. Hope dry_flood wouldn't be angry. :drunk:
What folder do I upload the xml file to?
VQMOD\XML

Use Filezilla, if you are not already. :)
Where is the VQMOD\XML file located? I can't find it? I'm using the default theme of Opencart.

Newbie

Posts

Joined
Fri Aug 26, 2011 2:37 pm

Post by Maansy » Mon Sep 05, 2011 2:15 pm

Great post and mod

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by highvibes » Wed Sep 07, 2011 4:23 am

Great mod that works well, except that when sharing on facebook it links to the product but underneath lists all my footer text instead of anything from the product description :/ I think this may be something to do with the professional theme that I bought having a custom footer as i believe facebook scrapes the page for text.

If anyone thinks otherwise I'd love to know if there's a workaround.

Cheers!

New member

Posts

Joined
Sun Aug 07, 2011 10:38 pm

Post by cyrupmail » Tue Jan 31, 2012 2:25 am

Great mods

is it working on 1.5.1.3??


Cheers

Newbie

Posts

Joined
Mon Jan 23, 2012 2:49 am

Post by SVN » Sat Feb 11, 2012 3:59 am

Can someone tell me how I can put and ENTER between this facebook en Tweet buttons and the buttons QTY etc... under them ?
Where do I need to put a <br> in the XML ?

thx

User avatar
SVN
Active Member

Posts

Joined
Mon Jan 03, 2011 11:59 pm
Who is online

Users browsing this forum: No registered users and 5 guests