Post by tifosi » Fri Mar 27, 2009 10:49 pm

I've just upgraded from 1.1.8 to 1.25 - or attempted to.

The default install works fine, but importing the dbbackup breaks the shopfront with an error similar to http://forum.opencart.com/viewtopic.php?f=31&t=3431

The problem is that the backup.sql the admin creates includes 'drop table' commands which is nonsensical! - Essentially reverting the database to the earlier version.

The upgrade path is intrusive and needs to be totally rethought. If the project increases in size you will have users on multiple platforms with potentially multiple table structures. To have them essentially wipe their db and reinstall is simply too invasive. The current method is seriously flawed.

Once installed there should be seperate install & upgrade paths where the most an upgrade sql does is to alter tables, and potentially drop tables only when deprecated and after new changes processed.

The best example I've seen is vbulletin where the version control does sequentiual upgrades via a wizard depending on start & finish versions.

S

New member

Posts

Joined
Tue Feb 17, 2009 8:14 am

Post by mal-schauen » Sat Mar 28, 2009 3:01 am

Use search for your problem

Alles für die Anwendung im deutschen Sprachraum
Hier gehts zum deutschen Forumbereich


User avatar
Moderator

Posts

Joined
Sun Feb 08, 2009 11:16 pm
Location - Germany

Post by tifosi » Sat Mar 28, 2009 3:49 am

mal-schauen wrote:Use search for your problem
Instead of useless replies like that try adding a link if you've found one!

I was just following the admins 5 point upgrade, which should work for all upgrades.

S

New member

Posts

Joined
Tue Feb 17, 2009 8:14 am
Who is online

Users browsing this forum: No registered users and 11 guests