Post by QNAP » Tue Jul 05, 2011 3:12 pm

I'm voting to stop adding new features to 1.5.0.x for the time being and lets get 1.5.0.5 without bugs first, release 1.5.0.6 as "stable" and then start adding new feature.
+1

Daniel, when can we expect a stable 1.5.0.6 version ? Latest version came out as late as June 14, 2011

Active Member

Posts

Joined
Wed Jan 19, 2011 3:46 am

Post by DirkZz » Tue Jul 05, 2011 3:51 pm

Daniel, when is there a working site at the SVN?

I would like to show my boss the process of setting up a cart with our own data in it, and one step of that process is fetching the latest version of OC 1.5.X.

Was about to show it until i noticed that there's unfinished stuff on the SVN. Its probably how you work.. but adding unfinished stuff to the SVN is not really the normal way to go.

New member

Posts

Joined
Thu Jun 16, 2011 3:34 pm

Post by Daniel » Tue Jul 05, 2011 5:29 pm

i need to rework the manufacturers box maybe rename it to carousal. but thats the only major thing and finishing the reports at the moment where you might see something not working.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by ritey » Tue Jul 05, 2011 8:58 pm

Would appear that the coupon / Paypal issue needs addressing in general, I've had 2 checkouts of 1 coupon that should only be allowed to be used once per customer but the same customer account could use it twice.

Dave
www.coderstudios.com


User avatar
Active Member

Posts

Joined
Fri Jan 22, 2010 4:28 am
Location - Richmond

Post by Daniel » Tue Jul 05, 2011 10:12 pm

ritey wrote:Would appear that the coupon / Paypal issue needs addressing in general, I've had 2 checkouts of 1 coupon that should only be allowed to be used once per customer but the same customer account could use it twice.

already fixed. check the svn.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by ritey » Tue Jul 05, 2011 10:28 pm

Ok, will diff and merge some of the files to make my own 1.5.0.6 if the SVN has incomplete parts...

Dave
www.coderstudios.com


User avatar
Active Member

Posts

Joined
Fri Jan 22, 2010 4:28 am
Location - Richmond

Post by QNAP » Wed Jul 06, 2011 6:56 pm

Daniel
there was one new field created in the last version under settings.
Which new field are you referring to ? What makes it for use ?

Regarding the Update issue:
Can we just upload the install folder and run through the installer again?
Or will that mess up the database? Are you planning on making an upgrade script from 1.5.0.5 to whatever the next version is you're planning on releasing?
It would be nice if you could clarify the position on that one, there is probably some users who have begun to enter a lot of products in the current OC release 1.5.0.5 and given that 1.5.0.6 is around the corner so you have to wonder how to upgrade and if it is safe. Hope you understand. Thanx.

Active Member

Posts

Joined
Wed Jan 19, 2011 3:46 am

Post by PetracheNicolae » Thu Jul 07, 2011 2:36 am

file visitor.php from admin/language/english/report has no content. this is how it should be or is something missing? thanks

New member

Posts

Joined
Tue May 24, 2011 5:40 am

Post by Xsecrets » Thu Jul 07, 2011 3:08 am

PetracheNicolae wrote:file visitor.php from admin/language/english/report has no content. this is how it should be or is something missing? thanks
there are several reports that are not completed yet. The should all be turned off by default.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by i2Paq » Thu Jul 07, 2011 3:36 am

SVN 457, clean install, no changes made yet.

See Here

Code: Select all

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by uksitebuilder » Thu Jul 07, 2011 3:48 am

Searching on advanced search by pressing the Enter key does not work - also evident in open cart demo

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by celestial » Thu Jul 07, 2011 6:25 am

i2Paq wrote:SVN 457, clean install, no changes made yet.

See Here

Code: Select all

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49
You most change all your custom modules, in admin/controller/modules, in admin/view/modules/. Compare the modules of OC with your custom modules, is hard but is OK.

Celestial - Martín Abel Rosales
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by Phil » Thu Jul 07, 2011 6:55 am

Hi All,

Apologies if this topic has already been covered but I have searched this thread and cannot find anything similar.
I seem to have a problem with the returns system on my site, when a customer enters all of the details in the returns form on the site they then go through to a page that states that the return has been sent through to the relevant department and that they will be contacted soon, however I don't get an email saying that a new return request has been submitted and have to manually check the returns section in the admin area every day to make sure that nothing has come through.... Does anyone else have this problem or is it just me?

Thanks for your time and your continued hard work.
Phil

New member

Posts

Joined
Fri Feb 18, 2011 6:10 pm


Post by allenshea » Thu Jul 07, 2011 11:02 am

In previous version of OC, lets say, 1.4, we can search part of the Product Name or Model to get the items you need.

Product Name: GY6 150cc Piston Assy (57.4mm)
Model: MIGY150-3005

but in the new version 1.5, if you search piston, I got below
products.jpg

products.jpg (33.46 KiB) Viewed 2689 times

Showing 1 to 20 of 31 (2 Pages)? where is the item to edit?

if I search model no of 3005, I got nothing, in 1.4, I can get all item model listed with 3005.

By the way, if you search the 1st letter, yes, it works fine, GY6 or MIGY150, you can get the items you need.

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by 'tis-grand » Thu Jul 07, 2011 1:22 pm

I'm not sure if this is a bug or if I'm missing something but here goes. When I try to disable the categories of the sample data in a new installation of 1.5.0.5 I am able to delete all of the top level categories except 'Laptops & Notebooks' and 'MP3 Players'. When I go into the admin area and choose Catalog > Categories > Laptops & Notebooks > Edit > Data and then choose Status > Disabled from the drop-down menu and then Save, instead of being taken to the Categories listing again with a message saying "Success: You have modified categories!" I am instead taken to the home page of the front of the store. Nothing I do changes this from occurring so I'm thinking it's a bug.

I wanted to use 1.5.0.5 as a production version for a shop for my client but after reading over this thread it seems it may not yet be ready for production and I should stick to 1.4.9.5. Any clarification of these 2 points would be appreciated thanks.

Newbie

Posts

Joined
Fri Aug 20, 2010 11:25 am

Post by i2Paq » Thu Jul 07, 2011 1:37 pm

celestial wrote:
i2Paq wrote:SVN 457, clean install, no changes made yet.

See Here

Code: Select all

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49Warning: Invalid argument supplied for foreach() in /var/www/vhosts/oc-directory.info/subdomains/150/httpdocs/catalog/controller/common/content_bottom.php on line 49
You most change all your custom modules, in admin/controller/modules, in admin/view/modules/. Compare the modules of OC with your custom modules, is hard but is OK.
i2Paq wrote:SVN 457, clean install, no changes made yet.
;)

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Daniel » Thu Jul 07, 2011 1:38 pm

uksitebuilder wrote:Searching on advanced search by pressing the Enter key does not work - also evident in open cart demo

already fixed in svn.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Thu Jul 07, 2011 1:41 pm

'tis-grand wrote:I'm not sure if this is a bug or if I'm missing something but here goes. When I try to disable the categories of the sample data in a new installation of 1.5.0.5 I am able to delete all of the top level categories except 'Laptops & Notebooks' and 'MP3 Players'. When I go into the admin area and choose Catalog > Categories > Laptops & Notebooks > Edit > Data and then choose Status > Disabled from the drop-down menu and then Save, instead of being taken to the Categories listing again with a message saying "Success: You have modified categories!" I am instead taken to the home page of the front of the store. Nothing I do changes this from occurring so I'm thinking it's a bug.

I wanted to use 1.5.0.5 as a production version for a shop for my client but after reading over this thread it seems it may not yet be ready for production and I should stick to 1.4.9.5. Any clarification of these 2 points would be appreciated thanks.
i'm pretty sure this is something you have done. it does not happen with a default install of opencart.

there is nothing that stops opencart 1.5.0.5 working and making sales. i suppose you know what would be production or not.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by rph » Thu Jul 07, 2011 2:26 pm

allenshea wrote:In previous version of OC, lets say, 1.4, we can search part of the Product Name or Model to get the items you need.

Product Name: GY6 150cc Piston Assy (57.4mm)
Model: MIGY150-3005

but in the new version 1.5, if you search piston, I got below
products.jpg
Showing 1 to 20 of 31 (2 Pages)? where is the item to edit?

if I search model no of 3005, I got nothing, in 1.4, I can get all item model listed with 3005.

By the way, if you search the 1st letter, yes, it works fine, GY6 or MIGY150, you can get the items you need.
It was reported earlier in the thread and Daniel wasn't interested in fixing it.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by 'tis-grand » Thu Jul 07, 2011 3:08 pm

Thanks for the speedy reply. I installed opencart 1.5.0.5 on another server using softaculous and indeed the error did not repeat. So I went back to my first server and deleted the original installation of opencart and deleted the database associated with it and started again, including downloading a new copy of opencart onto another computer before uploading it.

I also unzipped this new version on my desktop first using 7zip to check it. It gave me a number of diagnostic messages including:
CRC failed in 'Opencart v.1.5.0.5\upload\admin\view\javascript\jquery\ui\external\simulate\jquery.simulate.js.' File is broken.

It gave me a lot of other messages saying 'Unsupported compression method for Opencart v.1.5.0.5\upload\admin\view\javascript\jquery\ui\i18n\jquery.ui.datepick' - somthing like 62 of these messages which I can't paste here because I am unable to copy and paste.

Undeterred I uploaded the opencart_v1.5.0.5.zip that I had just downloaded via File manage in cPanel and then used the extract facility to decompress it. I received the following errors:

Code: Select all

inflating: OpenCart v1.5.0.5/upload/admin/view/javascript/jquery/ui/external/qunit.js  
   creating: OpenCart v1.5.0.5/upload/admin/view/javascript/jquery/ui/external/simulate/
  inflating: OpenCart v1.5.0.5/upload/admin/view/javascript/jquery/ui/external/simulate/jquery.simulate.js  
  error:  invalid compressed data to inflate
 bad CRC 00000000  (should be 7639f86a)
file #1235:  bad zipfile offset (local header sig):  2156334
file #1236:  bad zipfile offset (local header sig):  2156426
file #1237:  bad zipfile offset (local header sig):  2169843
file #1238:  bad zipfile offset (local header sig):  2170441
file #1239:  bad zipfile offset (local header sig):  2171149
file #1240:  bad zipfile offset (local header sig):  2171900
file #1241:  bad zipfile offset (local header sig):  2172536
file #1242:  bad zipfile offset (local header sig):  2173251
file #1243:  bad zipfile offset (local header sig):  2173828
file #1244:  bad zipfile offset (local header sig):  2174424
file #1245:  bad zipfile offset (local header sig):  2175059
file #1246:  bad zipfile offset (local header sig):  2175674
file #1247:  bad zipfile offset (local header sig):  2176267
file #1248:  bad zipfile offset (local header sig):  2177011
file #1249:  bad zipfile offset (local header sig):  2177595
file #1250:  bad zipfile offset (local header sig):  2178182
file #1251:  bad zipfile offset (local header sig):  2178769
file #1252:  bad zipfile offset (local header sig):  2179369
file #1253:  bad zipfile offset (local header sig):  2179973
file #1254:  bad zipfile offset (local header sig):  2180599
file #1255:  bad zipfile offset (local header sig):  2181188
file #1256:  bad zipfile offset (local header sig):  2181906
file #1257:  bad zipfile offset (local header sig):  2182522
file #1258:  bad zipfile offset (local header sig):  2183142
file #1259:  bad zipfile offset (local header sig):  2183751
file #1260:  bad zipfile offset (local header sig):  2184408
file #1261:  bad zipfile offset (local header sig):  2185011
file #1262:  bad zipfile offset (local header sig):  2185655
file #1263:  bad zipfile offset (local header sig):  2186253
file #1264:  bad zipfile offset (local header sig):  2186894
file #1265:  bad zipfile offset (local header sig):  2187586
file #1266:  bad zipfile offset (local header sig):  2188176
file #1267:  bad zipfile offset (local header sig):  2188821
file #1268:  bad zipfile offset (local header sig):  2189427
file #1269:  bad zipfile offset (local header sig):  2190015
file #1270:  bad zipfile offset (local header sig):  2190619
file #1271:  bad zipfile offset (local header sig):  2191349
file #1272:  bad zipfile offset (local header sig):  2191998
file #1273:  bad zipfile offset (local header sig):  2192625
file #1274:  bad zipfile offset (local header sig):  2193389
file #1275:  bad zipfile offset (local header sig):  2193983
file #1276:  bad zipfile offset (local header sig):  2194579
file #1277:  bad zipfile offset (local header sig):  2195184
file #1278:  bad zipfile offset (local header sig):  2195809
file #1279:  bad zipfile offset (local header sig):  2196423
file #1280:  bad zipfile offset (local header sig):  2196985
file #1281:  bad zipfile offset (local header sig):  2197583
file #1282:  bad zipfile offset (local header sig):  2198257
file #1283:  bad zipfile offset (local header sig):  2198994
file #1284:  bad zipfile offset (local header sig):  2199611
file #1285:  bad zipfile offset (local header sig):  2200247
file #1286:  bad zipfile offset (local header sig):  2200846
file #1287:  bad zipfile offset (local header sig):  2201421
file #1288:  bad zipfile offset (local header sig):  2202073
file #1289:  bad zipfile offset (local header sig):  2202692
file #1290:  bad zipfile offset (local header sig):  2203419
file #1291:  bad zipfile offset (local header sig):  2204156
file #1292:  bad zipfile offset (local header sig):  2204764
file #1293:  bad zipfile offset (local header sig):  2205496
file #1294:  bad zipfile offset (local header sig):  2206153
file #1295:  bad zipfile offset (local header sig):  2206773
file #1296:  bad zipfile offset (local header sig):  2207396
file #1297:  bad zipfile offset (local header sig):  2208019
  inflating: OpenCart v1.5.0.5/upload/admin/view/javascript/jquery/ui/i18n/ui.datepicker-bg.js  
  inflating: OpenCart v1.5.0.5/upload/admin/view/javascript/jquery/ui/i18n/ui.datepicker-ca.js
Nevertheless the frontend seemed alright and gave me green marks all the way so I went through the frontend install process and then logged in and started to disable the top level categories as before. Again I got the same problem - all the top level categories would disable except for 'Laptops & Notebooks' and 'MP3 Players'. When I try to disable those I get sent to the homepage of the frontend rather than back to the Categories listing in the backend.

I have a lot of stuff on my server and no issues with any other installation. I'm wondering if the download version of opencart_v1.5.0.5.zip does indeed contain a broken file that is doing this or where the issue lies - my server, the opencart files, where?

I can delete these remaining categories no problem but I'm wondering if this whole issue indicates some other problems that are going to come back and cause problems somewhere down the line.

Newbie

Posts

Joined
Fri Aug 20, 2010 11:25 am
Who is online

Users browsing this forum: No registered users and 4 guests