Post by nmarat » Mon Jun 20, 2011 3:53 am

Need SKU checking when adding new product to avoid doubles
mb after pressing save button or ajax

Newbie

Posts

Joined
Fri Jul 30, 2010 5:25 pm

Post by Hildebrando » Mon Jun 20, 2011 7:07 pm

I see this in demo.opencart.com and in my installation, the 8th product goes to the second line. What's the problem?
not to me. Look at http://www.coompras.com/tiendas/demoopen/

In catalog/view/theme/default/stylesheet/stylesheet.css

replace

Code: Select all

.box-product > div {
	width: 116px;
	display: inline-block;
	vertical-align: top;
	margin-right: 20px;
	margin-bottom: 15px;	
}
with

Code: Select all

.box-product > div {
	//width: 116px;
	width: 106px;
	display: inline-block;
	vertical-align: top;
	//margin-right: 20px;
	margin-right: 0px;
	margin-bottom: 15px;	
}

Commercial Contributions:Bulk Specials| Bulk Update Prices|Search Tyre Pro
Free Contributions: Youtube video (oc 1.5.x) | Search History Report (oc 1.5.x) | Product Filter by Category (oc 1.5.x)|Youtube Popup
More Free & commercial mods: www.fpress.com


User avatar
Active Member

Posts

Joined
Fri Mar 06, 2009 8:22 pm
Location - Spain

Post by audiomarket » Mon Jun 20, 2011 7:08 pm

Ambottera wrote:I see this in demo.opencart.com and in my installation, the 8th product goes to the second line. What's the problem?
I have resolved with css upgrade!
In the stylesheet file, search class .box-product > div and replace it with:

Code: Select all

.box-product > div {
	width: 20%;
	float: left;
	text-align: center;
	margin-bottom: 20px;
}
Yes, tou hahve only 5 products but a nice aligned!!
Olso in other page the alignement is great!!

Bye

New member

Posts

Joined
Mon Mar 15, 2010 1:55 am

Post by audiomarket » Mon Jun 20, 2011 7:17 pm

Hildebrando wrote:
I see this in demo.opencart.com and in my installation, the 8th product goes to the second line. What's the problem?
not to me. Look at http://www.coompras.com/tiendas/demoopen/

In catalog/view/theme/default/stylesheet/stylesheet.css

replace

Code: Select all

.box-product > div {
	width: 116px;
	display: inline-block;
	vertical-align: top;
	margin-right: 20px;
	margin-bottom: 15px;	
}
with

Code: Select all

.box-product > div {
	//width: 116px;
	width: 106px;
	display: inline-block;
	vertical-align: top;
	//margin-right: 20px;
	margin-right: 0px;
	margin-bottom: 15px;	
}
Yes, in home page this is can work but in other product page (correlated product) the aligned don't correct!!
My solution work great in all product page!!
Bye

New member

Posts

Joined
Mon Mar 15, 2010 1:55 am

Post by wkkapr » Mon Jun 20, 2011 8:12 pm

The Welcome module from the home page also shows up on Site Map and Special Offers page

The Banner does the same thing.

Not sure why this is happening.

Attachments

oc_special2.JPG

oc_special2.JPG (13.62 KiB) Viewed 5784 times

oc_sitemap2.JPG

oc_sitemap2.JPG (14.57 KiB) Viewed 5784 times


Newbie

Posts

Joined
Sat Apr 30, 2011 10:24 am

Post by uksitebuilder » Mon Jun 20, 2011 10:55 pm

That doesn't happen for me, nor does it happen on the demo.

With regards to the featured products on the home page dropping the last one down to the next row, here is my CSS.

Code: Select all

.box-product > div{
    width:116px;
    display:inline-block;
    vertical-align:top;
    margin:0 9px 15px 9px;
    text-align:center;
}

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by jcsmithy » Tue Jun 21, 2011 6:43 am

Product_tag table in the DB needs to be indexed, as described in this post.

Xsecrets solved the problem, reduced search query down from 13mins (yes, minutes) to 0.5 seconds after this.

Active Member

Posts

Joined
Fri Oct 01, 2010 9:54 pm

Post by jcsmithy » Tue Jun 21, 2011 4:25 pm

Me once again lol....

in the following function

Code: Select all

public function getProducts($data = array()) {
All tag queries need to be changed to lowercase - the tag it'self is passed as lowercase from PHP, but the tag column isn't converted to lower...

Existing query being run

Code: Select all

p.product_id IN (SELECT pt.product_id FROM product_tag pt WHERE pt.language_id = '1' AND pt.tag LIKE '%co20101%')
Should be

Code: Select all

p.product_id IN (SELECT pt.product_id FROM product_tag pt WHERE pt.language_id = '1' AND LCASE(pt.tag) LIKE '%co20101%')

Only looked in this one function

Active Member

Posts

Joined
Fri Oct 01, 2010 9:54 pm

Post by jcsmithy » Tue Jun 21, 2011 4:55 pm

an update to the above... also this function

Code: Select all

public function getTotalProducts($data = array()) {



And.... another bug... this one I'm unsure if it's already been mentioned

When using the UPS shipping method, "Calculate Shipping Quote" does not work as it expects the City and correct Zone code, which are not passed through to it.

Only the
country_id
postcode
zone_id

Variables are passed - No City... and the Zone code isnt worked out from the Zone_id

Active Member

Posts

Joined
Fri Oct 01, 2010 9:54 pm

Post by Daniel » Tue Jun 21, 2011 9:51 pm

jcsmithy wrote:an update to the above... also this function

Code: Select all

public function getTotalProducts($data = array()) {



And.... another bug... this one I'm unsure if it's already been mentioned

When using the UPS shipping method, "Calculate Shipping Quote" does not work as it expects the City and correct Zone code, which are not passed through to it.

Only the
country_id
postcode
zone_id

Variables are passed - No City... and the Zone code isnt worked out from the Zone_id
are u using 1.5.0.5?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by uksitebuilder » Tue Jun 21, 2011 11:00 pm

Product Options vanish when editing a product.

When viewing/editing an already created product that has options, some of the options values do not re-appear and when going to save errors are displayed.

Image

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by bluelayer » Tue Jun 21, 2011 11:04 pm

searching for UF8 words in product description still do not work

v1.5.5.1


New member

Posts

Joined
Sun Oct 17, 2010 8:11 pm

Post by Daniel » Wed Jun 22, 2011 12:24 am

uksitebuilder wrote:Product Options vanish when editing a product.

When viewing/editing an already created product that has options, some of the options values do not re-appear and when going to save errors are displayed.

Image

probably trying to save the page without waiting before its finished loading.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by pbhd » Wed Jun 22, 2011 2:56 am

This is from the 1.5.0.5 sources.
Shouldn't in this code be used the correct length of the constant string, 15 resp. 19?
if (substr($route, 0, 16) == 'product/product' && isset($this->request->get['product_id'])) {
...
if (substr($route, 0, 16) == 'product/information' && isset($this->request->get['information_id'])) {

If it should, then this is also the case in the other files in that folder.

Gruss PB

User avatar
Newbie

Posts

Joined
Mon Jun 13, 2011 2:11 am
Location - Heidelberg, Germany

Post by Daniel » Wed Jun 22, 2011 3:28 am

pbhd wrote:This is from the 1.5.0.5 sources.
Shouldn't in this code be used the correct length of the constant string, 15 resp. 19?
if (substr($route, 0, 16) == 'product/product' && isset($this->request->get['product_id'])) {
...
if (substr($route, 0, 16) == 'product/information' && isset($this->request->get['information_id'])) {

If it should, then this is also the case in the other files in that folder.

Gruss PB
i think your right.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by jcsmithy » Wed Jun 22, 2011 3:39 am

Daniel wrote:
jcsmithy wrote:an update to the above... also this function

Code: Select all

public function getTotalProducts($data = array()) {



And.... another bug... this one I'm unsure if it's already been mentioned

When using the UPS shipping method, "Calculate Shipping Quote" does not work as it expects the City and correct Zone code, which are not passed through to it.

Only the
country_id
postcode
zone_id

Variables are passed - No City... and the Zone code isnt worked out from the Zone_id
are u using 1.5.0.5?

Yep - 1.5.0.5

Active Member

Posts

Joined
Fri Oct 01, 2010 9:54 pm

Post by celestial » Wed Jun 22, 2011 3:49 am

Daniel you forgot for bilingual use:

Line 1583 of admin\controller\sale\order.php (function history)

$pagination->text = $this->language->get('text_pagination');

Thanks

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by merry » Wed Jun 22, 2011 5:05 am

Customer REORDER Button not functional on index.php?route=account/order/info&order_id=2

Most answers are from my OpenCart 1.5 User Manual CURRENT TO 1.5.5.1 and includes free updates.
FREE HELP! 60-page user guide with OpenCart Admin Menu Cheatsheet, Install Guide & 30 Minute QuickStart Guide: http://showmeguides.com/


User avatar
Active Member

Posts

Joined
Thu Dec 09, 2010 12:51 am
Location - Mexico and sometimes Texas

Post by happychai » Wed Jun 22, 2011 10:52 am

anyone have idea how to upgrade from 1.5 to 1.5.05?
Does it have any database changes?

Newbie

Posts

Joined
Sun Mar 20, 2011 1:04 pm

Post by phoenixquantum » Wed Jun 22, 2011 11:21 am

Michael.Maardt.dk wrote:When translating I noticed variable in product_description was meta_keywords in 1.4.9.5 and in 1.5.0.4 it was meta_keyword (s missing)
The attachment opencart-1495-meta-keywords.jpg is no longer available
The attachment opencart-1504-meta-keywords.jpg is no longer available
Same with category_description

you're right... even some fields in different tables are misplaced
BEFORE
1.JPG

BEFORE - 1.JPG (11.44 KiB) Viewed 5667 times

AFTER
2.JPG

AFTER - 2.JPG (10.85 KiB) Viewed 5667 times



Posts

Joined
Wed Jun 22, 2011 10:28 am
Who is online

Users browsing this forum: No registered users and 4 guests