Post by Daniel » Wed May 25, 2011 11:35 pm

celestial wrote:Daniel, sorry but still bad the footer, same problem
do u have a link to your site?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Wed May 25, 2011 11:42 pm

Blnukem wrote:May be bug: Extensions -> Modules -> Category -> Category: When show in left hand, not all pages are showing "Category list" example: Contact and Site map, no category list is showing on left. :)

screenshot please.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by reynierpm » Wed May 25, 2011 11:50 pm

Daniel wrote:fixed in svn.
Hi Daniel, still the same SVN? I mean I was getting updates from RC1 repository but now what I'm need to do in order to get RC2 working? I need to reinstall all? Or just updating files is enough?
Cheers

User avatar
Active Member

Posts

Joined
Tue Jan 12, 2010 9:51 pm

Post by Daniel » Wed May 25, 2011 11:58 pm

reynierpm wrote:
Daniel wrote:fixed in svn.
Hi Daniel, still the same SVN? I mean I was getting updates from RC1 repository but now what I'm need to do in order to get RC2 working? I need to reinstall all? Or just updating files is enough?
Cheers
update files and run through the installer again to get any missed db stuff.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by celestial » Wed May 25, 2011 11:59 pm

Daniel wrote:
celestial wrote:Daniel, sorry but still bad the footer, same problem
do u have a link to your site?
I am in local ¿¿maybe this is the problem??

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by EpiphanyInc » Thu May 26, 2011 12:01 am

BUG? When going through the checkout process and registering a new account, when I click to read the Privacy Policy it opens the privacy policy page content in the existing window instead of a pop-up box or new page.

Also the checkout steps go from Step 1 to Step 2 to Step 5 to Step 6. What are steps 3 & 4 as they don't show up.

EDIT: Steps 3 & 4 were missing when checking out with just the iMac but they appeared when other products were added.

Thanks!

Newbie

Posts

Joined
Wed Jul 21, 2010 2:37 pm

Post by celestial » Thu May 26, 2011 12:35 am

Daniel, is correct the problem is a extra DIV, now is fixed (my fault i use a program for compare and this fail), THANKS

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by Blnukem » Thu May 26, 2011 1:13 am

Daniel wrote:
Blnukem wrote:May be bug: Extensions -> Modules -> Category -> Category: When show in left hand, not all pages are showing "Category list" example: Contact and Site map, no category list is showing on left. :)

screenshot please.
Selected.jpg

Selected.jpg (46.33 KiB) Viewed 3859 times

Missing.jpg

Missing.jpg (29.71 KiB) Viewed 3859 times


OK, I looked further into this and it does not work for: Contact Us, Site Map and Specials. there is no option for the specials page. All other pages seem fine.
Specials.jpg

Specials.jpg (23.36 KiB) Viewed 3811 times

Last edited by Blnukem on Thu May 26, 2011 5:15 am, edited 1 time in total.

New member

Posts

Joined
Wed Apr 28, 2010 11:17 pm

Post by i2Paq » Thu May 26, 2011 2:26 am

Not a bug but a sort of useless function.

Why does the e-mail send to the store owner when a new registration is made not contain name (and or customer number) and e-mail address of the newly registered customer?
Now I get the same e-mail as the customer gets which makes no sense as it contains a link that gets me no-where :-\

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Daniel » Thu May 26, 2011 2:59 am

i2Paq wrote:Not a bug but a sort of useless function.

Why does the e-mail send to the store owner when a new registration is made not contain name (and or customer number) and e-mail address of the newly registered customer?
Now I get the same e-mail as the customer gets which makes no sense as it contains a link that gets me no-where :-\

can be turned off in the settings but its a feature Q put in.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by opencartisalright » Thu May 26, 2011 3:41 am

JasonSGN wrote:
opencartisalright wrote:
JasonSGN wrote:I found small issue with Reward Points. Here are the steps to recreate:

1. Add an item to your shopping cart that uses Reward Points
2. Use Rewards Points towards the purchase of the item
3. Remove the item from your shopping cart (customer changes mind on purchase)
4. Add another item that does NOT use Rewards Points to your cart. The previous Reward Points you applied towards the previous item still appear in cart without offering any type of discount on the current item and no way to remove the wasted points.

Possible solution: Could you clear the Rewards Points when the cart is emptied?
Confirmed.
Maybe do the same as Gift Vouchers, or possibly offer some way for customer to maunally remove it from the cart.
Please don't forget this one, it's a big one. The rewards points should clear out of the cart if a customer clears all the items from their cart to keep the above error from happening. :)

Active Member

Posts

Joined
Mon Feb 21, 2011 4:09 am

Post by i2Paq » Thu May 26, 2011 4:12 am

Daniel wrote:
i2Paq wrote:Not a bug but a sort of useless function.

Why does the e-mail send to the store owner when a new registration is made not contain name (and or customer number) and e-mail address of the newly registered customer?
Now I get the same e-mail as the customer gets which makes no sense as it contains a link that gets me no-where :-\

can be turned off in the settings but its a feature Q put in.
Then have a look at this topic: [MOD] Send Alert Email when a new user has registered.
This small piece of code added to this function on OC 1.5.0 would make it what it should be: complete.
I have it now in my current 1.4.9.3 store and I love it.

OMG! I just added a Feature request.... :o

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by ezblue » Thu May 26, 2011 4:28 am

Admin area---> catalog----> products

Select a product with a check mark, click copy, get this error message:

Error: Duplicate entry '48-52' for key 1
Error No: 1062
INSERT INTO product_related SET product_id = '48', related_id = '52'


Just FYI

Newbie

Posts

Joined
Wed Apr 27, 2011 10:34 am

Post by Blnukem » Thu May 26, 2011 5:20 am

May be bug, If there are "NO" Manufacturers listed, the brand page shows:

Notice: Undefined variable: categories in /var/www/vhosts/doaminname.com/subdomains/shop/httpdocs/catalog/view/theme/default/template/product/manufacturer_list.tpl on line 9

Works fine if you add one Manufacturer.

New member

Posts

Joined
Wed Apr 28, 2010 11:17 pm

Post by opencartnovice » Thu May 26, 2011 5:36 am

Hi all,

Having clicked to continue in step 3 i.e. after providing userdatabase, databasename etc..., and then went to a blank page? No message or text

Don't know why, please help

Many thanks

New member

Posts

Joined
Thu Oct 07, 2010 5:12 am

Post by yrshopping » Thu May 26, 2011 9:12 am

thank you for your hard work.

for Attribute parts, can we also write html code because if for color chart & size chart which need insert color charts and Excel form format at specification, thank you.

New member

Posts

Joined
Wed Aug 12, 2009 12:42 pm

Post by screenager8 » Thu May 26, 2011 9:53 am

Excellent works Daniel!

Here are my reports:

1. When i click tags in the product detail page, it goes to wrong search result, i have to change a code to make it works:
Catalog > Controller > Product > Product.php

Line 339:

Code: Select all

foreach ($results as $result) {
	$this->data['tags'][] = array(
		'tag'  => $result['tag'],
		'href' => $this->url->link('product/search', 'filter_tag=' . $result['tag'])
	);
}
I change it to:

Code: Select all

foreach ($results as $result) {
	$this->data['tags'][] = array(
		'tag'  => $result['tag'],
		'href' => $this->url->link('product/search', 'filter_name=' . $result['tag'])
	);
}

2. When i click a product from the search results, the breadcrumb display text_search, I should add text_search in the main language file (english.php)

Image

Bukatoko.com | Cara mudah & cepat punya toko online!


User avatar
Active Member

Posts

Joined
Sat Nov 28, 2009 5:45 pm
Location - Jakarta, Indonesia

Post by screenager8 » Thu May 26, 2011 10:03 am

When u use more than one image as banner, the page will display all the images before it run the animation. You shoud make only the first image to show and hide the rest.

I'm not a programmer, so this is my "hack":

From Catalog > View > Theme > Default > Template > Module > Banner.tpl

Code: Select all

<div id="banner<?php echo $module; ?>" class="banner">
	<?php foreach ($banners as $banner) { ?>
		<?php if ($banner['link']) { ?>
			<div><a href="<?php echo $banner['link']; ?>"><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" title="<?php echo $banner['title']; ?>" /></a></div>
		<?php } else { ?>
			<div><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" title="<?php echo $banner['title']; ?>" /></div>
		<?php } ?>
	<?php } ?>
</div>
I change it to:

Code: Select all

<div id="banner<?php echo $module; ?>" class="banner">
	<?php $v = 1; ?> 
	<?php foreach ($banners as $banner) { ?>
		<?php if ($banner['link']) { ?>
			<div <?php if ( $v == 1 ) { echo 'class="first-slide"';} ?>><a href="<?php echo $banner['link']; ?>"><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" title="<?php echo $banner['title']; ?>" /></a></div>
		<?php } else { ?>
			<div <?php if ( $v == 1 ) { echo 'class="first-slide"';} ?>><img src="<?php echo $banner['image']; ?>" alt="<?php echo $banner['title']; ?>" title="<?php echo $banner['title']; ?>" /></div>
		<?php } ?>
		<?php $v++ ?>
	<?php } ?>
</div>

Then you should add styles in your CSS:

.banner img { display: block; }
.banner div { display: none; }
.banner div.first-slide { display: block; }

Image

Bukatoko.com | Cara mudah & cepat punya toko online!


User avatar
Active Member

Posts

Joined
Sat Nov 28, 2009 5:45 pm
Location - Jakarta, Indonesia

Post by Daniel » Thu May 26, 2011 11:42 am

opencartisalright wrote:
Please don't forget this one, it's a big one. The rewards points should clear out of the cart if a customer clears all the items from their cart to keep the above error from happening. :)

fixed in svn.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Thu May 26, 2011 11:43 am

Blnukem wrote:
Daniel wrote:
Blnukem wrote:May be bug: Extensions -> Modules -> Category -> Category: When show in left hand, not all pages are showing "Category list" example: Contact and Site map, no category list is showing on left. :)

screenshot please.
Selected.jpg
Missing.jpg

OK, I looked further into this and it does not work for: Contact Us, Site Map and Specials. there is no option for the specials page. All other pages seem fine.
Specials.jpg

just needs the route puit into the layout page. i have already done it will update the sql later.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: Bing [Bot] and 8 guests