Post by Dreamvention » Fri Aug 17, 2018 3:28 pm

Hi Guys

We have been getting soom feedback about users having issues with browser cache. It happens like this:
- you added a product to cart and clicked back and there is zero in your cart. only after refresh, you see the products.
- you installed a new extension, went back to see it and it is not there.
- you added a new product - not showing in list.
- you added a new category - still missing.

this issue is common because of twig and one more - the browser's cache.

Here is the solution
1. go to Dashboard, on the top right you will see a button (blue gear)
2. click the blue gear button and in the popup - turn off the cache and click orange button (refresh)
3. via FTP go to your root folder (public_html or www) and find admin folder
4. in admin folder create a new .htaccess file and edit it

add this code to .htaccess

<IfModule mod_headers.c>
<filesMatch "\.(htm|html|css|js|php|tag)$">
Header set Cache-Control "no-cache, no-store, must-revalidate"
</filesMatch>
</IfModule>

this should clear the twig cache and also remove the browser cache.

Let me know if this helped anyone?

Many OpenCart users struggle to find quality extensions. We know how frustrating the need to fix the shop is just because of one poorly coded extension. We created quality OpenCart Extensions, tested by real developers and provide professional support.

AJAX QUICK CHECKOUT - #1 one-page checkout solution
VISUAL DESIGNER - Page builder for Opencart
View more extensions here

Tested by Shopunity.net


User avatar
New member

Posts

Joined
Sun Jun 17, 2012 7:04 pm
Location - Europe
Who is online

Users browsing this forum: No registered users and 10 guests