Post by soneria » Wed Sep 19, 2012 1:48 am

Merhaba. 2 Yıldır aktif bir sitem var. Sanalpos alacağım için SSL aldım. Statik IP var. SSL kurulumu başarıyla yapılı.
Opencart'te aktif etmek istediğimde config.php lerden gerekli işlemleri yapıyorum. Admin paneli genel ayarlardan SSL yi aktif ediyorum. Private key kısmına SSL den aldığım uzun keyi yazıyorum. Buraya kadar herşey tamam
sonra siteye girdiğimde SSL gereken yeri tıklıyorum mesela hesabım sayfasınız. Burda resimler gözükmüyor. sayfadaki tüm resimleri özellikle https:// olarak linkledim. Gözükmeyen resme sağ tıklıyor özellikler diyorum yolunu kopyalıyorum browsere yapıştırıyorum sorunsuz gözüküyor.
Ne yaptıysam çözemedim. Ücretli veya ücretsiz bana ssl kurulumunda yardımcı olabilecek biri varsa çom memnun olurum.

Newbie

Posts

Joined
Sat Oct 23, 2010 2:45 am

Post by Baylas » Wed Sep 19, 2012 6:08 pm

Code: Select all

// HTTPS
define('HTTPS_SERVER', 'http://www.siteadresiniz.xxx/admin/');
define('HTTPS_IMAGE', 'http://www.siteadresiniz.xxx/image/');
Merhablar config.php dosyasında bu alanı aşağıdaki şekilde düzenledinizmi?

Code: Select all

// HTTPS
define('HTTPS_SERVER', 'https://www.siteadresiniz.xxx/admin/');
define('HTTPS_IMAGE', 'https://www.siteadresiniz.xxx/image/');

Image
Web Tasarım ve Programlama
http://www.baylas.com


User avatar
New member

Posts

Joined
Thu Jun 14, 2012 4:21 pm
Location - Turkey

Post by okansayin » Sat Apr 20, 2013 12:04 am

Bu benim içinde önemli bir sıkıntı, admin/config.php ayarları, panelden ssl aktif et, ssl key gir gibi standart ifadeleri okumaktan sıkıldım bende. Ssl sıkıntısız olarak kurulu, opencart tan iyi anlıyorum. Ama bilmediğim bir konudan dolayı bir eksiklik var. Eminim ki bu konuda bir sürü kişi hata oluyor. Özellikle ssl i hesabım ve ödeme sayfalarında kullanamıyor ve ,image sorunu yaşıyor. Yardım eden de yok bilen de ücretli destek alın demekten başka birçare bırakmıyor.

Çiçek Kapında Flower Delivery Web Page, Turkey

Thank you Opencart


User avatar
New member

Posts

Joined
Fri Feb 11, 2011 1:10 am
Location - Turkey

Post by eka7a » Sat Apr 20, 2013 6:30 am

soneria wrote:Merhaba. 2 Yıldır aktif bir sitem var. Sanalpos alacağım için SSL aldım. Statik IP var. SSL kurulumu başarıyla yapılı.
Opencart'te aktif etmek istediğimde config.php lerden gerekli işlemleri yapıyorum. Admin paneli genel ayarlardan SSL yi aktif ediyorum. Private key kısmına SSL den aldığım uzun keyi yazıyorum. Buraya kadar herşey tamam
sonra siteye girdiğimde SSL gereken yeri tıklıyorum mesela hesabım sayfasınız. Burda resimler gözükmüyor. sayfadaki tüm resimleri özellikle https:// olarak linkledim. Gözükmeyen resme sağ tıklıyor özellikler diyorum yolunu kopyalıyorum browsere yapıştırıyorum sorunsuz gözüküyor.
Ne yaptıysam çözemedim. Ücretli veya ücretsiz bana ssl kurulumunda yardımcı olabilecek biri varsa çok memnun olurum.
Demek ki bir yerlerde yanlış ya da eksik yaptığınız bir şeyler var. Yaptıklarınızı tekrar gözden geçirmekte yarar var.

Kullandığınız sürüme bağlı olarak;
catalog/controller/common/header.php
catalog/model/tool/image.php
ya da
system/library/image.php

dosyalarınızda hata olabilir. Kullandığınız sürüme göre varsayılan dosyalarla kendi dosyalarınızı karşılaştırınız.

Kendi siteniz de bulunan resimler ve bağlantılar için http:// ya da https:// kullanmayınız.
okansayin wrote:Bu benim içinde önemli bir sıkıntı, admin/config.php ayarları, panelden ssl aktif et, ssl key gir gibi standart ifadeleri okumaktan sıkıldım bende. Ssl sıkıntısız olarak kurulu, opencart tan iyi anlıyorum. Ama bilmediğim bir konudan dolayı bir eksiklik var. Eminim ki bu konuda bir sürü kişi hata oluyor. Özellikle ssl i hesabım ve ödeme sayfalarında kullanamıyor ve ,image sorunu yaşıyor. Yardım eden de yok bilen de ücretli destek alın demekten başka birçare bırakmıyor.
Aynı sorun farklı kişilerde farklı sebeplerden dolayı oluşabilmektedir. Bu yüzden de bu sorunun çözümü budur demek bir başkası için çare olmayabiliyor.


User avatar
Active Member

Posts

Joined
Sun Apr 12, 2009 12:59 am
Location - Türkiye

Post by okansayin » Sat Apr 20, 2013 7:09 am

Benim şuan sayfamda orjinal haliyle oc 1.4.9.6 kurulu. Logoyu bile değiştirmedim. Ama hata nerede bulamıyorum. Tüm ayarlarım doğru. Büyük ihtimalle image dosyalarından kaynaklı çünkü, admin paneline chrome ile girdim. Resim olmayan sayfalarda ssl kiliti sarı resimli sayfalarda mesela ürünler sayfasında kilit uyarı şeklinde geliyor. chmod ayarım 755 image klasöründe.

Çiçek Kapında Flower Delivery Web Page, Turkey

Thank you Opencart


User avatar
New member

Posts

Joined
Fri Feb 11, 2011 1:10 am
Location - Turkey

Post by okansayin » Sat Apr 20, 2013 11:29 pm

Ayrıca dikkatimi çeken bir nokta ise .png uzantılı resimlerde linkler https:// olarak aktif olurken .jpg uzantılı resimlerde http:// olarak kalıyor. Bu nedenden dolayı admin panelinde hata alıyorum ürünler sayfasında ve resim yükleme bölümünde. Sitede ise ödeme ve üyelik bölümündeki uyarıda jpg üzerinde ssl in aktif olmamasından olabilir ki benim şuanki opencart standart opencart kendi içindeki ürünleriyle duruyor. ssl sorununu çözene kadar düzenlemeyeceğim siteyi.

Çiçek Kapında Flower Delivery Web Page, Turkey

Thank you Opencart


User avatar
New member

Posts

Joined
Fri Feb 11, 2011 1:10 am
Location - Turkey

Post by sanalpos » Fri May 03, 2013 4:25 pm

resimleri image klasöründen başka bir yere kaydetmiş olabilir misiniz?

http://www.opencartpos.com


User avatar
Newbie

Posts

Joined
Fri May 03, 2013 3:57 pm
Location - istanbul
Who is online

Users browsing this forum: No registered users and 0 guests