Post by mamoocreative » Sat Dec 10, 2011 5:50 am

Hi there,

I have the 1.5.1.3 install of OpenCart. On the category page I have some products from the sub-cats and the buttons:

Add to Cart
Wishlist
Compare

At first they appear inactive but when I examine them in my Firebug they are giving the following error when clicked:

Notice: Error: Could not load library json! in /home/gadgetdr/public_html/system/engine/loader.php on line 23

From memory this was a fresh install of 1.5.1.3 so there should be no upgrade bugs.

Any help would be great. I am running Shoppica theme but I don't think it is related to the theme (could be wrong)

many thanks

Newbie

Posts

Joined
Sat Dec 10, 2011 5:36 am

Post by Daniel » Sat Dec 10, 2011 11:47 pm

reupload you might be missing a few files.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Qphoria » Sun Dec 11, 2011 5:07 am

The problem is likely due to a 3rd party mod trying to call the old 1.5.1 method for loading json as library.
In 1.5.1.3 it was moved to the helpers area and no longer gets loaded as a library. That 3rd party addon will need to be updated

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by mamoocreative » Mon Dec 12, 2011 6:17 pm

Thanks guys, thats awesome, will investigate those points. Qphoria that sounds like it's prob the case, as when i run the store on the default theme it works fine. Cheers again, Matt

Newbie

Posts

Joined
Sat Dec 10, 2011 5:36 am

Post by open-electronics.org » Thu Dec 29, 2011 1:47 am

Hi,
I'm newbie opencart user and I have a problem with mr json...
In log I find this error:
2011-12-28 17:18:10 - PHP Notice: Error: Could not load library json! in /store/vqmod/vqcache/vq2-system_engine_loader.php on line 24
And the reviews don't work... :'(
I tried to disable all VQMod script, but nothing happens.
I tried to reinstall the theme (http://www.12leaves.com/store/crista-op ... plate.html)
but nothing happens...
Can you help me to find the problem?


Posts

Joined
Wed Dec 28, 2011 7:00 pm

Post by Qphoria » Thu Dec 29, 2011 3:50 am

The error isn't with vQmod.. its with another addon is not 1.5.1.3 compatible.
In 1.5.1.3, the json model was changed to a helper... so really the fix is to remove any reference to trying to load json as a model... and alter the function.

So find out which custom mod is causing it as it is not likely a vQmod script but an extension.. possibly payment. And check with the author for an update.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by open-electronics.org » Thu Dec 29, 2011 6:19 am

Thank you, but is there a method to find the wrong extension?
Excuse me for the question but I'm not an expert. :(
I thought that was vQmod that caused problem because the file indicted was vq2-system_engine_loader.php
Have I to look a particular call in files?


Posts

Joined
Wed Dec 28, 2011 7:00 pm

Post by jty » Thu Dec 29, 2011 9:20 am

open-electronics.org wrote:Thank you, but is there a method to find the wrong extension?
Uninstall your mods one by one (including the theme), take your install back to standard open cart, until it works. That'll tell you what the offending mod is.

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by mamoocreative » Thu Dec 29, 2011 6:55 pm

Just to update you on the original post. Qphoria's post about the 3rd party mod trying to call the old 1.5.1 method for loading json as library. I updated the 3rd party mod and it jumped into life. Thanks for the help.

Newbie

Posts

Joined
Sat Dec 10, 2011 5:36 am

Post by ikinciadam » Mon Nov 26, 2012 7:18 pm

Hi everyone,

i installed 1.5.4.1 and a 3rd party modul for payment. everything is ok. but someone come to check out, begins the problem. My modul also call the old method for loading json as library. So how can i fix it? how can i change the call method or folder name etc?

Sorry for bad eng. and i'm not soo good at opencart

Newbie

Posts

Joined
Mon Nov 26, 2012 7:14 pm
Who is online

Users browsing this forum: No registered users and 7 guests