Post by d33p » Thu Jun 25, 2009 6:18 pm

I just installed the latest Import/Export Module with OC 1.29 and everything seems to work fine, both the export and the import. Now, when I import an xls-file with special characters (german: ä ö ü and ß), these characters are not written correctly to the database, instead the entry breaks at the first special character.

Besides that, there are no problems with special characters. Manually editing a product and displaying the pages works correctly. Exporting the xls works fine too.

The collation of my database and all the tables is utf8_unicode_ci.
I use Open Office Calc to edit the xls file.

Any Ideas how to solve that problem?

Thanks in advance,
Claus

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by d33p » Thu Jun 25, 2009 9:26 pm

I use Open Office Calc to edit the xls file.
Ok, I just tried on a friends computer with MS Excel 2007. Doesn't make any difference.

Any Ideas?

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by d33p » Mon Jun 29, 2009 6:31 am

Anybody?

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by phpuk » Mon Jun 29, 2009 7:00 am

This really needs to be directed towards J.Neuhoff as he was the developer of this addon / contribution.

Global Moderator

Posts

Joined
Wed Mar 25, 2009 10:57 am

Post by d33p » Mon Jun 29, 2009 7:27 am

thanks phpuk.
im gonna pm him about this topic

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by phpuk » Mon Jun 29, 2009 8:53 am

Your welcome.

Global Moderator

Posts

Joined
Wed Mar 25, 2009 10:57 am

Post by JNeuhoff » Mon Jun 29, 2009 4:38 pm

To be honest, I haven't tested Export/Import yet on Opencart 1.2.9 as I was extremely busy over the past ten days. I'll take a look at it as soon as possible and get it fixed.

I am also planning on doing some other changes to this modules, such as adding support for discounts and related products.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Mon Jun 29, 2009 8:58 pm

This is a tough bug.

The Export/Import module assumes UTF-8 encoding for the spreadsheet file, it is capable of generating the spreadsheet file using Unicode (2 bytes for every character), and also importing it. However, as soon as I edit the spreadsheet, either in OpenOffice 3.x or MS Excel 2003, and save it again, it converts the spreadhsheet file into ISO-8859-1 (1 byte per character). It seems neither OpenOffice nor MS Excel 2003 are capable of supporting proper UTF-8 encoding.

I'll have to further look into this.

For the time being, when editing in the spreadsheet file, use the HTML-escapes for the German Umlaut characters.

BTW.: I have now uploaded an updated version of the Export/Import module specifically for Opencart 1.2.9. While it doesn't yet fix this issue, it will work otherwise. Don't use previous versions for Opencart 1.2.9!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by d33p » Mon Jun 29, 2009 9:07 pm

Thank you so very much for your fast reply, at least I am glad it's a bug and not my fault :)
For the moment I gonna use html escapes.

Have a nice day,
Claus

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by JNeuhoff » Mon Jun 29, 2009 10:04 pm

I am now using mb_detect_encoding( $str, 'UTF-8,ISO-8859-15,ISO-8859-1,cp1251,KOI8-R' ) calls for the meta, name, and description fields when reading from the spreadsheet during an Import. I hope this fixes it, but I'd like some Russian/Spanish/German or other language users/people to test it, and if there are still issues with it, to let me know.

You can download the latest Export/Import module from the contributions section.

Please don't use previous versions for Opencart 1.2.9, as this will mess up the Backup/Restore and the menus!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by d33p » Tue Jun 30, 2009 12:52 am

Ok, I just tested it with German special characters in the title and product description. It works like a charm.

Thanks again,
Claus

Newbie

Posts

Joined
Tue May 26, 2009 12:11 am

Post by Tobievr » Thu Nov 04, 2010 2:34 am

Hi

I see that you have encountered this problem before, but I am based in South Africa and I am sitting with exactly the same problem. I have installed the latest version of this module and no matter what I havetried and I have tried every single possible option, I cant seem to import the xls file that I have exported. This is a matter of serious urgency and I am willing to pay for services rendered as I am about to lose the deal purely on this point, as my client has to upload more than 3000 photos on each session.

Please could you help me.

Thanks

Tobie

Newbie

Posts

Joined
Wed Oct 27, 2010 4:40 am

Post by julicek » Tue Jan 03, 2012 7:45 pm

Hello,

I have this problem:
http://www.zlatebobule.cz/palava-2008-ps-krist

CTRL+U

in description, title,...

there are á......

I am using import made in google docs

How to solve this? thanks

Newbie

Posts

Joined
Wed Aug 24, 2011 4:50 am
Who is online

Users browsing this forum: No registered users and 1 guest