Post by silver0 » Wed Aug 17, 2011 2:45 am

Hi to all,

I have OC 1.5.1 installed and running. Have set SEO URL's enabled and have .htaccess file in my public_html folded where the OC files are located.
As I try to open specific category or info page I get the following error:
"Not Found

The requested URL /about_us was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."


Can anybody tell me where the problem is? I have read forums all afternoon but I can nowhere find the answer.... :-\
Thank you in advance!

P.S. http://imania.bg/ is the store URL..
Last edited by silver0 on Wed Aug 17, 2011 7:18 am, edited 1 time in total.

Newbie

Posts

Joined
Wed Aug 17, 2011 2:31 am

Post by uksitebuilder » Wed Aug 17, 2011 5:06 am

Are you using a Windows Server or Apache server ?

If Apache, please post contents of your .htaccess here

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by silver0 » Wed Aug 17, 2011 6:07 am

It is Apache server and the file is empty - what should I put in it?

Newbie

Posts

Joined
Wed Aug 17, 2011 2:31 am

Post by uksitebuilder » Wed Aug 17, 2011 6:20 am

When you downloaded OC there was a .htaccess.txt file in the download

Rename that file to just .htaccess and upload to your public_html folder

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by silver0 » Wed Aug 17, 2011 6:50 am

@uksitebuilder: In the package I downloaded there is no such file - am I missing something?
Any idea guys?

Newbie

Posts

Joined
Wed Aug 17, 2011 2:31 am

Post by Xsecrets » Wed Aug 17, 2011 6:52 am

silver0 wrote:@uksitebuilder: In the package I downloaded there is no such file - am I missing something?
Any idea guys?
If you downloaded it from opencart then yes it's there. You may have to turn on view hidden files on some operating systems because the file begins with a .

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by silver0 » Wed Aug 17, 2011 7:17 am

Guys you are great!!!!!!!!!!!!!
The file was really hidden (I'm using Mac OS). I found it renamed it uploaded it to the public_html folder and now the pages are opening correctly!
Thank you very much

Newbie

Posts

Joined
Wed Aug 17, 2011 2:31 am

Post by bobwhite » Tue Apr 03, 2012 12:09 pm

Thank you to all contributors to this topic!
It was exacly my problem.
My .htaccess file was renamed during migration. Renamed it back and problem fixed.
Bob :laugh:

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by Basikboy » Tue Apr 03, 2012 9:03 pm

I am having the same problem but when I look Into the folder to change the htcaccess I don't see htcaccess.txt only the following:
.htaccess
.htaccess.bak
.htaccess.bak1

I don't see any others?

New member

Posts

Joined
Sun Mar 18, 2012 12:21 am

Post by bobwhite » Wed Apr 04, 2012 12:39 am

Hi Basikboy,
You can try to renayme .htaccess.bak or download fresh opencart and use only htaccess.txt from there. I my case I renamed htaccess.bak or whatever extention they put during migarion.
Cheers,
Bob

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by Calcite » Wed Apr 04, 2012 12:49 am

bobwhite wrote:Thank you to all contributors to this topic!
It was exacly my problem.
My .htaccess file was renamed during migration. Renamed it back and problem fixed.
Bob :laugh:
Suggest you download the following widget for Mac

http://www.apple.com/downloads/dashboar ... files.html

Been using it for a few weeks since I started working on OC and it's a great way to toggle the hidden files on and off.

Be aware too that Mac Os X overwrites everything in a folder when you replace it with an upgrade!

I struggled with a custom theme installation only to find out that all files in a folder are deleted before the folder is replaced when uploading from a Mac ;)

Active Member

Posts

Joined
Fri Dec 30, 2011 3:21 am

Post by Basikboy » Wed Apr 04, 2012 12:11 pm

I tried changing .htaccess.bak to .htaccess but it didn't allow me as it said this file already exists. How would i go about downloading a fresh Opencart and not wipe out what I have already done? Thank you for all your help.

New member

Posts

Joined
Sun Mar 18, 2012 12:21 am

Post by bobwhite » Thu Apr 05, 2012 4:36 am

Basikboy wrote:I tried changing .htaccess.bak to .htaccess but it didn't allow me as it said this file already exists. How would i go about downloading a fresh Opencart and not wipe out what I have already done? Thank you for all your help.
Just delete, .htaccess and rename .htaccess.bak to .htaccess
If does not work, then download opencart to your personal computer, take htaccess.txt from there, rename it to .htaccess and upload it to the host server.

User avatar
New member

Posts

Joined
Thu Jan 26, 2012 8:20 am

Post by Basikboy » Thu Apr 05, 2012 7:28 am

This didn't work either: Just delete, .htaccess and rename .htaccess.bak to .htaccess
I am really unsure on how to upload this htaccess.txt file

New member

Posts

Joined
Sun Mar 18, 2012 12:21 am

Post by Basikboy » Thu Apr 05, 2012 7:44 pm

Ok, so I downloaded Opencart to my computer to retrieve the htaccess.txt file and the new download doesn't have this file only a .htaccess file. Am i looking in the wrong place?

By the way, I am running Version 1.5.2.1

New member

Posts

Joined
Sun Mar 18, 2012 12:21 am

Post by Basikboy » Thu Apr 05, 2012 8:32 pm

Ok, was helped out by our friends over at MarketInSG and they sent over the file I needed and I uploaded and all is working fine. I highly recommend these guys if you need any help with your Opencart store. Super helpful and priced very fair. Thanks again everyone.

New member

Posts

Joined
Sun Mar 18, 2012 12:21 am

Post by Needhelptoo » Sat Apr 14, 2012 12:29 am

Ok I'm having this issue where does the file need to be uploaded to. I'm running 1.5.2.1 also.

Thank you, GOD Bless

New member

Posts

Joined
Thu Mar 22, 2012 1:11 am

Post by pgt_gaming » Tue Jan 29, 2013 3:41 am

I am having this same problem and I have tried to do all the suggestions above but I cannot find the file. I know it is on there but I don't know how to get to it. I don't have a place that says to show hidden files but I searched my directory & it says that .htaccess.txt is there. Couldn't find it. I also looked for .htaccess and it is there too but I could not find it. I tried downloading .htaccess.txt and uploading it to file manager & then renaming it to .htaccess but it said that the file already exists. Does anyone know what I should do??

Newbie

Posts

Joined
Tue Jan 29, 2013 3:38 am

Post by uksitebuilder » Wed Jan 30, 2013 6:42 am

Thete will be an option in your fie manager to show hidden files

As there are many different hosting environments and setups, you should contact your host and ask them how to view .htaccess in file manager

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by gbisqit » Wed Mar 11, 2015 11:25 am

Also I found out if this does not work then this should solve it once input into the htaccess file:

RewriteEngine On

RewriteBase /
RewriteRule sitemap.xml /index.php?route=feed/google_sitemap
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Newbie

Posts

Joined
Thu Aug 18, 2011 3:41 pm
Location - Encino, CA
Who is online

Users browsing this forum: No registered users and 58 guests