Post by LEINAD » Mon Jun 17, 2024 10:05 pm

Hello community,

I try to add a new group of filters, but it doesn't save anymore. Can you help me with a solution?
I am using OpenCart 4.0.2.3

Thank you very much for your support

Regards,
leinad
Last edited by LEINAD on Tue Jun 18, 2024 10:20 pm, edited 2 times in total.

Newbie

Posts

Joined
Fri May 17, 2024 6:51 pm

Post by paulfeakins » Mon Jun 17, 2024 10:13 pm

Please read the Forum Rules.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by LEINAD » Tue Jun 18, 2024 3:49 pm

Hello monica345,

Thank you very much for your support.
I followed your advice exactly, but it still doesn't work. The error that is generated is the following:

2024-06-18 07:40:47 - 0: Error: Duplicate entry '157-1' for key 'oc27_filter_group_description.PRIMARY'<br/>Error No: 1062<br/>INSERT INTO `oc27_filter_group_description` SET `filter_group_id` = '157', `language_id` = '1', `name` = 'Packaging'
File: /home/leinadsh/public_html/leinadtex.ro/system/library/db/mysqli.php
Lines: 76

Newbie

Posts

Joined
Fri May 17, 2024 6:51 pm

Post by ADD Creative » Tue Jun 18, 2024 4:11 pm

Looks like your oc_filter_group_description and oc_filter_group tables in your database are out of sync with the filter_group_id. Look at the tables in your database.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by LEINAD » Tue Jun 18, 2024 10:19 pm

Thank you all for your help. Thanks to your support, we have solved the problem. I don't know for what reason, a large number of filter_group_ids disappeared from the database and I had to recreate them to be able to synchronize with oc_filter_group_description.

Thank you all once again!

best regards,
Dan

Newbie

Posts

Joined
Fri May 17, 2024 6:51 pm
Who is online

Users browsing this forum: No registered users and 9 guests