Post by stanmx » Sun May 12, 2024 1:51 am

Hi everyone,

I was working with OC 4.0.2.3 to create a new theme but now I need to upload the final store online and integrated PayPal. In my last interactions in the forum several people recommend not use OC 4 yet for an online store. Which of the newest versions of OpenCart do you recommend installing for an online store?

Thank you!
Last edited by stanmx on Tue May 14, 2024 3:46 am, edited 1 time in total.

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by IP_CAM » Sun May 12, 2024 1:56 am

Most likely this one:
https://github.com/opencart/opencart-3/tree/main
define('VERSION', '3.2.0.0');

My Github OC Site: https://github.com/IP-CAM
5'200 + FREE OC Extensions, on the World's largest private Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Sun May 12, 2024 3:50 am

The Code has just been updated a little, just to have it mentioned:
Updated root reference in vendor
https://github.com/opencart/opencart-3

My Github OC Site: https://github.com/IP-CAM
5'200 + FREE OC Extensions, on the World's largest private Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by stanmx » Sun May 12, 2024 11:34 am

IP_CAM wrote:
Sun May 12, 2024 3:50 am
The Code has just been updated a little, just to have it mentioned:
Updated root reference in vendor
https://github.com/opencart/opencart-3
Thank you man, I will install it and check if my preview changes in the template of OC 4 work here too.

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by stanmx » Mon May 13, 2024 3:17 am

IP_CAM wrote:
Sun May 12, 2024 3:50 am
The Code has just been updated a little, just to have it mentioned:
Updated root reference in vendor
https://github.com/opencart/opencart-3
I try to install this version, but required PHP 8.3+, I upgraded my web server to PHP 8.3 (ea-php83) but still requested the PHP 8.3+. Do you have a OpenCart version with a lower PHP version?

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by stanmx » Mon May 13, 2024 3:31 am

... and why OpenCart is promote OC v4.0 if is not ready for a online store? or Why you don't recommend OC v4 to this endeavor? Thank You!

Attachments

Screen Shot 2024-05-12 at 12.29.54 PM.png

Screen Shot 2024-05-12 at 12.29.54 PM.png (230.09 KiB) Viewed 815 times


User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by straightlight » Mon May 13, 2024 3:39 am

stanmx wrote:
Mon May 13, 2024 3:17 am
IP_CAM wrote:
Sun May 12, 2024 3:50 am
The Code has just been updated a little, just to have it mentioned:
Updated root reference in vendor
https://github.com/opencart/opencart-3
I try to install this version, but required PHP 8.3+, I upgraded my web server to PHP 8.3 (ea-php83) but still requested the PHP 8.3+. Do you have a OpenCart version with a lower PHP version?
If you are experiencing issues detecting the PHP version on your server, you should probably contact your web hosting provider. As for the OC v4.x releases, they're not yet ready for production, it is still in development mode until an official release gets published on Github Opencart repository and on the website.

As for the code updates, the commit logs can be followed on this link - realtime: https://www.github.com/opencart/opencart-3/commits

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stanmx » Mon May 13, 2024 4:48 am

straightlight wrote:
Mon May 13, 2024 3:39 am
stanmx wrote:
Mon May 13, 2024 3:17 am
IP_CAM wrote:
Sun May 12, 2024 3:50 am
The Code has just been updated a little, just to have it mentioned:
Updated root reference in vendor
https://github.com/opencart/opencart-3
I try to install this version, but required PHP 8.3+, I upgraded my web server to PHP 8.3 (ea-php83) but still requested the PHP 8.3+. Do you have a OpenCart version with a lower PHP version?
If you are experiencing issues detecting the PHP version on your server, you should probably contact your web hosting provider. As for the OC v4.x releases, they're not yet ready for production, it is still in development mode until an official release gets published on Github Opencart repository and on the website.

As for the code updates, the commit logs can be followed on this link - realtime: https://www.github.com/opencart/opencart-3/commits

Hi Straightlight, I check my web server support and they updated to PHP 8.3.6, but the this change add the next lines in the bottom of the .htaccess and the install URL stops work:

<IfModule mime_module>
AddHandler application/x-httpd-ea-php83___lsphp .php .php8 .phtml
</IfModule>

What can I do?

Attachments

Screen Shot 2024-05-12 at 1.48.26 PM.png

Screen Shot 2024-05-12 at 1.48.26 PM.png (39.29 KiB) Viewed 800 times


User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by straightlight » Mon May 13, 2024 6:36 am

stanmx wrote:
Mon May 13, 2024 4:48 am
straightlight wrote:
Mon May 13, 2024 3:39 am
stanmx wrote:
Mon May 13, 2024 3:17 am


I try to install this version, but required PHP 8.3+, I upgraded my web server to PHP 8.3 (ea-php83) but still requested the PHP 8.3+. Do you have a OpenCart version with a lower PHP version?
If you are experiencing issues detecting the PHP version on your server, you should probably contact your web hosting provider. As for the OC v4.x releases, they're not yet ready for production, it is still in development mode until an official release gets published on Github Opencart repository and on the website.

As for the code updates, the commit logs can be followed on this link - realtime: https://www.github.com/opencart/opencart-3/commits

Hi Straightlight, I check my web server support and they updated to PHP 8.3.6, but the this change add the next lines in the bottom of the .htaccess and the install URL stops work:

<IfModule mime_module>
AddHandler application/x-httpd-ea-php83___lsphp .php .php8 .phtml
</IfModule>

What can I do?
More information is needed. What error message does it provide? The .htaccess should not require any modifications to use Opencart with PHP 8.3x.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stanmx » Mon May 13, 2024 6:48 am

straightlight wrote:
Mon May 13, 2024 6:36 am
stanmx wrote:
Mon May 13, 2024 4:48 am
straightlight wrote:
Mon May 13, 2024 3:39 am


If you are experiencing issues detecting the PHP version on your server, you should probably contact your web hosting provider. As for the OC v4.x releases, they're not yet ready for production, it is still in development mode until an official release gets published on Github Opencart repository and on the website.

As for the code updates, the commit logs can be followed on this link - realtime: https://www.github.com/opencart/opencart-3/commits

Hi Straightlight, I check my web server support and they updated to PHP 8.3.6, but the this change add the next lines in the bottom of the .htaccess and the install URL stops work:

<IfModule mime_module>
AddHandler application/x-httpd-ea-php83___lsphp .php .php8 .phtml
</IfModule>

What can I do?
More information is needed. What error message does it provide? The .htaccess should not require any modifications to use Opencart with PHP 8.3x.
Error 500

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by straightlight » Mon May 13, 2024 7:01 am

stanmx wrote:
Mon May 13, 2024 6:48 am
straightlight wrote:
Mon May 13, 2024 6:36 am
stanmx wrote:
Mon May 13, 2024 4:48 am



Hi Straightlight, I check my web server support and they updated to PHP 8.3.6, but the this change add the next lines in the bottom of the .htaccess and the install URL stops work:

<IfModule mime_module>
AddHandler application/x-httpd-ea-php83___lsphp .php .php8 .phtml
</IfModule>

What can I do?
More information is needed. What error message does it provide? The .htaccess should not require any modifications to use Opencart with PHP 8.3x.
Error 500
Check your server error logs for more information about this error.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by stanmx » Mon May 13, 2024 11:41 am

The error_log show this:

Code: Select all

[12-May-2024 18:45:24 UTC] PHP Fatal error:  Uncaught Error: Typed property Language::$default must not be accessed before initialization in /home2/stanmx/<mysubdomain>/system/library/language.php:82
Stack trace:
#0 /home2/stanmx/<mysubdomain>/system/engine/loader.php(233): Language->load('engb', '')
#1 /home2/stanmx/<mysubdomain>/system/framework.php(166): Loader->language('engb')
#2 /home2/stanmx/<mysubdomain>/system/startup.php(109): require_once('/home2/stanmx/b...')
#3 /home2/stanmx/<mysubdomain>/install/index.php(37): start('install')
#4 {main}
  thrown in /home2/stanmx/<mysubdomain>/system/library/language.php on line 82

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by ADD Creative » Mon May 13, 2024 4:42 pm

stanmx wrote:
Mon May 13, 2024 3:31 am
... and why OpenCart is promote OC v4.0 if is not ready for a online store? or Why you don't recommend OC v4 to this endeavor? Thank You!
OpenCart is developed by one main developer and they would probably consider their work as stable. It's the opinion of users and developers on the forums that it's not. The most stable version is probably currently https://github.com/opencart/opencart/tree/3.0.x.x which is 3.0.3.9 with additional bug and security fixes and will hopefully be released as 3.0.4.0 soon.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by straightlight » Mon May 13, 2024 6:13 pm

stanmx wrote:
Mon May 13, 2024 11:41 am
The error_log show this:

Code: Select all

[12-May-2024 18:45:24 UTC] PHP Fatal error:  Uncaught Error: Typed property Language::$default must not be accessed before initialization in /home2/stanmx/<mysubdomain>/system/library/language.php:82
Stack trace:
#0 /home2/stanmx/<mysubdomain>/system/engine/loader.php(233): Language->load('engb', '')
#1 /home2/stanmx/<mysubdomain>/system/framework.php(166): Loader->language('engb')
#2 /home2/stanmx/<mysubdomain>/system/startup.php(109): require_once('/home2/stanmx/b...')
#3 /home2/stanmx/<mysubdomain>/install/index.php(37): start('install')
#4 {main}
  thrown in /home2/stanmx/<mysubdomain>/system/library/language.php on line 82
Thanks for reporting this. Should be fixed, now. If you notice additional bugs from OC v3.2x release, please submit them here: https://www.github.com/opencart/opencart-3 's issues tab.

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by paulfeakins » Mon May 13, 2024 6:57 pm

straightlight wrote:
Mon May 13, 2024 6:13 pm
Thanks for reporting this. Should be fixed, now.
If your issue is now solved, please add [SOLVED] to the start of this topic title.

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by stanmx » Mon May 13, 2024 11:47 pm

straightlight wrote:
Mon May 13, 2024 6:13 pm
stanmx wrote:
Mon May 13, 2024 11:41 am
The error_log show this:

Code: Select all

[12-May-2024 18:45:24 UTC] PHP Fatal error:  Uncaught Error: Typed property Language::$default must not be accessed before initialization in /home2/stanmx/<mysubdomain>/system/library/language.php:82
Stack trace:
#0 /home2/stanmx/<mysubdomain>/system/engine/loader.php(233): Language->load('engb', '')
#1 /home2/stanmx/<mysubdomain>/system/framework.php(166): Loader->language('engb')
#2 /home2/stanmx/<mysubdomain>/system/startup.php(109): require_once('/home2/stanmx/b...')
#3 /home2/stanmx/<mysubdomain>/install/index.php(37): start('install')
#4 {main}
  thrown in /home2/stanmx/<mysubdomain>/system/library/language.php on line 82
Thanks for reporting this. Should be fixed, now. If you notice additional bugs from OC v3.2x release, please submit them here: https://www.github.com/opencart/opencart-3 's issues tab.
Hi, I downloaded again OC, upload files and start the installation. After the screen of upgrade and press continue button, they load a white page. I check the error_log and show this:

Code: Select all

[13-May-2024 15:34:55 UTC] PHP Fatal error:  Uncaught TypeError: DB::__construct(): Argument #7 ($ssl_key) must be of type string, null given, called in /home2/stanmx/<mysubdomain>/system/framework.php on line 108 and defined in /home2/stanmx/<mysubdomain>/system/library/db.php:34
Stack trace:
#0 /home2/stanmx/<mysubdomain>/system/framework.php(108): DB->__construct('mysqli', 'localhost', '<mydbuser>', '<mydbpass>', '<mydbname>', '3306', NULL, NULL, NULL)
#1 /home2/stanmx/<mysubdomain>/system/startup.php(109): require_once('/home2/stanmx/b...')
#2 /home2/stanmx/<mysubdomain>/index.php(19): start('catalog')
#3 {main}
  thrown in /home2/stanmx/<mysubdomain>/system/library/db.php on line 34
What can I do?

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by stanmx » Tue May 14, 2024 12:04 am

ADD Creative wrote:
Mon May 13, 2024 4:42 pm
stanmx wrote:
Mon May 13, 2024 3:31 am
... and why OpenCart is promote OC v4.0 if is not ready for a online store? or Why you don't recommend OC v4 to this endeavor? Thank You!
OpenCart is developed by one main developer and they would probably consider their work as stable. It's the opinion of users and developers on the forums that it's not. The most stable version is probably currently https://github.com/opencart/opencart/tree/3.0.x.x which is 3.0.3.9 with additional bug and security fixes and will hopefully be released as 3.0.4.0 soon.
Hi ADD Creative, I will try this version in a new subdomain. I install the OC v4 and don't have any problem. I just I received several comments in different posts about this version is a development version and is not ready for production. But when I downloaded, was in the official site. I hope my other comment find solution, to continue with the v3.2 installation too. Thank you!

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by JNeuhoff » Tue May 14, 2024 12:42 am

The upcoming OC 3.0.4.0 (based on 3.0.3.9, with further bugfixes and security patches) still supports the majority of existing OC 3.0.3.8 extensions, unlike OC 3.2.0.0 which has undergone significant formatting and syntactic changes, hence many of the OCmod-based 3.0.3.8 extensions may first have to be updated before running them on 3.2.0.0.

Export/Import Tool * SpamBot Buster * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Tag Manager * Survey Plus * OpenTwig


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by stanmx » Tue May 14, 2024 3:45 am

Thank you all for your patient and help. I will continue using OC v4, and if a new version arrive, I will update it.

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by straightlight » Tue May 14, 2024 8:49 am

stanmx wrote:
Tue May 14, 2024 3:45 am
Thank you all for your patient and help. I will continue using OC v4, and if a new version arrive, I will update it.
Thanks for the update. OC v4.x releases is, indeed, the future that holds ahead of us. :)

Dedication and passion goes to those who are able to push and merge a project.

Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 1 guest