Post by Sampletekk » Sat Feb 03, 2024 3:27 pm

OC Ver 4.0.2.3
Can't download/install anything from marketplace, getting the "Signature hash does not match!" error. I have added the API, several times, but still have the problem. Any ideas?

Per
Sampletekk


New member

Posts

Joined
Mon Aug 19, 2013 4:25 am

Post by paulfeakins » Mon Feb 05, 2024 11:46 pm

Are you trying to do that from your OpenCart website's admin area?
Maybe try just going direct to the marketplace: https://www.opencart.com/index.php?rout ... /extension

UK OpenCart Hosting | OpenCart Audits | OpenCart Support - please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - London Gatwick, United Kingdom

Post by stars777 » Fri Apr 19, 2024 6:03 pm

I have the exact same issue.
Last edited by stars777 on Fri Apr 19, 2024 6:05 pm, edited 1 time in total.

Newbie

Posts

Joined
Mon Apr 08, 2024 5:03 am

Post by stanmx » Tue May 14, 2024 3:32 am

Hi, I have the same issue, when I trying to download the Paypal Checkout Integration from the Extensions > Payments section. Where this signature needs to be add?

Attachments

Screen Shot 2024-05-13 at 12.31.27 PM.png

Screen Shot 2024-05-13 at 12.31.27 PM.png (59.2 KiB) Viewed 741 times


User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by stanmx » Tue May 14, 2024 4:16 am

I SOLVED. Just follow the Mihail Savov's article.

1. I just log in to the opencart.com account,
2. Then in YOUR STORES, I registered my store,
3. After that, I click the View icon, and send me to "Your Store API Information" where is the Marketplace API Information.
4. Finally I back to my store admin and in EXTENSIONS > MARKETPLACE I add the info in the modal view of Marketplace API.

Thank you!

User avatar
New member

Posts

Joined
Wed Apr 10, 2024 9:48 am
Location - Tijuana, MX

Post by zpeters » Thu Jun 06, 2024 11:11 pm

So... I've done that and I am still getting the message. Any other ideas?

Newbie

Posts

Joined
Thu Jun 06, 2024 9:49 pm

Post by OSWorX » Fri Jun 07, 2024 1:53 pm

zpeters wrote:
Thu Jun 06, 2024 11:11 pm
So... I've done that and I am still getting the message. Any other ideas?
Yes.
Simply do what Paul suggested: viewtopic.php?p=870674#p866596

If it does not work from the administration, why trying again and again instead of getting it from the Marketplace and install it the usual way.

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: redactuk and 4 guests