Post by v-v » Sat Nov 04, 2023 4:06 am

Hi, my provider, due some misunderstanding, changed version of php server to 8.2. So my site begins now with lots of " Unknown: Creation of dynamic property Proxy::$getEvents is deprecated in /home/www ..." etc.

One way, how to fix, is go back to previus one (providers tells it is impossible).
2nd, find a server (provider) that runs on 6.4 or last supported version for OC 2.2.
3rd, fix these error ?

Any help is realy apreciated :-)

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm

Post by IP_CAM » Sat Nov 04, 2023 4:18 am

Well, it would be quite complicated to find a Provider, still using older PHP Versions over an extended period of time. But you could consider to move up to OC Version 2.3.0.x, because for this one, PHP v.8.x Versions exist, like this one linked below, and it should not be very hard, to upgrade your existing OC Version. Just an Idea, I assume, that condor2 could sure be of assistance on such for a reasonable fee.
Good Luck! ;)
https://github.com/condor2/Opencart_23xx

My Github OC Site: https://github.com/IP-CAM
5'200 + FREE OC Extensions, on the World's largest private Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by SohBH » Sat Nov 04, 2023 4:13 pm

Cost-effective solution is to migrate to a hosting provider that supports PHP 7.4
More expensive alternative would be start over with the latest version of OpenCart.

Business Web Development | Content Creation | Analytics and Reporting | SEO


User avatar
Active Member

Posts

Joined
Mon Nov 02, 2020 12:01 am
Location - Malaysia

Post by v-v » Sat Nov 04, 2023 6:55 pm

Thank you to all of you - fortunatelly, my hosting provider was able to downgrade back to 7.4 ... so the easiest way.

Have a nice weekend!

v-v
Active Member

Posts

Joined
Wed Jun 16, 2010 10:09 pm
Who is online

Users browsing this forum: ravikumar22 and 5 guests