Page 1 of 1

[SOLVED] Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 7:34 am
by ozstar
HI,

We are now unable to log into 1.5.6.1. admin. Was okay a month ago when we last tried.

https://bettaautorubbers.co.nz/admin/

The page and all the data is there but the actual Login button does not show, just the text Login.

The front end seems to still work fine.

What could the problem be please?

Thank you

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 9:39 am
by straightlight
ozstar wrote:
Thu Oct 19, 2023 7:34 am
HI,

We are now unable to log into 1.5.6.1. admin. Was okay a month ago when we last tried.

https://bettaautorubbers.co.nz/admin/

The page and all the data is there but the actual Login button does not show, just the text Login.

The front end seems to still work fine.

What could the problem be please?

Thank you
Pretty old OC version. Server error logs.

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 11:08 am
by ozstar
Thank you for the reply. Yes old but he doesn't want to update yet :-(
2023-10-18 19:41:53 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 19:45:02 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 19:45:02 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 19:53:46 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 19:58:03 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 20:14:18 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 20:14:41 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 20:16:53 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8
2023-10-18 20:18:51 - PHP Unknown: Function mcrypt_create_iv() is deprecated in /home/bettaaut/public_html/system/library/encryption.php on line 8

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 11:32 am
by khnaz35
on your first error regarding admin.
can you confirm if your both catalog & admin config.php loaded over https?

Code: Select all

// HTTP

define('HTTP_SERVER', 'https://yourwebsite.com/');

// HTTPS

define('HTTPS_SERVER', 'https://yourwebsite.com/');
Because your site say different

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 4:53 pm
by WaxedPerfection
Enable SSL in the OpenCart Directory config.php File

-- Open control panel and log into it, then go to File Manager.
-- Navigate to OpenCart installation directory.
-- Open the configuration file (config.php) and look for the below lines appeared as HTTPS:

Code: Select all

define('HTTPS_SERVER', 'http://www.yourdomain.com/');
Edit the HTTPS settings in the file for SSL URL path. Just add- “S” to HTTP:// to turn it HTTPS:// and click on Save changes.

Code: Select all

define('HTTPS_SERVER', 'https://www.yourssldomain.com/');
Enable SSL in the OpenCart Admin Folder config.php File

-- Browse Admin folder and open the configuration file.
-- Look for the below lines appeared as HTTPS:

Code: Select all

define('HTTPS_SERVER', 'http://www.yourdomain.com/admin/');
define('HTTPS_CATALOG', 'http://www.yourdomain.com/');
Last, again edit the HTTPS settings in the file for SSL URL path. Just add- “S” to HTTP:// to turn it HTTPS://.

Code: Select all

define('HTTPS_SERVER', 'http://www.yourssldomain.com/admin/');
define('HTTPS_CATALOG', 'http://www.yourssldomain.com/');
[/quote]

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 5:50 pm
by ozstar
Many thanks for the help. It is appreciated.

Yes it was in the admin/config file.

http:// to https:// and now fixed. :-)

Re: Now unable to log into admin for 1.5.6.1.

Posted: Thu Oct 19, 2023 6:06 pm
by WaxedPerfection
thank you for the update, please mark the topic as SOLVED