Post by Cue4cheap » Sat Dec 14, 2019 8:36 am

Hello,
I was using the method by "Mike T" to run a cron job on the admin side.
https://stackoverflow.com/questions/221 ... s/22181225

It was working very well until my webhost made quite a bit changes.
They changed servers and eliminated any version of php less than 7.0.
What additional changes they made I do not know but when I run the cron job nothing happens.
When I attempt to run it by logging into the web server it shows me
What looks like it is trying to run this as a webpage versus a php script:
<!DOCTYPE html>
<html dir="ltr" lang="en">
<head>
<meta charset="UTF-8" />
<title>Page Not Found!</title>
<base href="http://www.mydomain.com/store/admin/" />
<link rel="stylesheet" type="text/css" href="view/stylesheet/stylesheet.css" />
<script type="text/javascript" src="view/javascript/jquery/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>
<link type="text/css" href="view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css" rel="stylesheet" />
<script type="text/javascript" src="view/javascript/jquery/tabs.js"></script>
<script type="text/javascript" src="view/javascript/jquery/superfish/js/superfish.js"></script>
<script type="text/javascript" src="view/javascript/common.js"></script>
<script type="text/javascript">
...

Basically showing me the text of my admin homepage.

ANYONE here used this method of running a admin cron job, and saw the same issue? And if so what was the fix?

Thank you in advance,
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by Cue4cheap » Wed Dec 18, 2019 12:19 pm

DAMN IT!
I walked through the script and found my screw up. I hard coded a path! So my webhost changed it from /home/ to /home1/ and there my screw-up of hard coding came to bite me.
Sorry for anyone who I wasted their time.
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am
Who is online

Users browsing this forum: No registered users and 2 guests