Post by RideTheWave » Thu Dec 05, 2019 5:31 am

I installed OpenCart 2.3.0.2 about two years ago. Everything has been fine but I got an email from my server GoDaddy saying that I need to upgrade my cPanel/WHM due to a security issue. I haven't upgraded cPanel/WHM in two years so the upgrade would most likely be substantial. My cPanel/WHM version is currently 64.0 (build 29) but it says that version 84.0.16 is available for upgrade. So if I upgrade from version 64.0 to 84.0, does anyone know if this will affect any functionality in OpenCart 2.3.0.2? It says there's no way to downgrade after the upgrade so if problems do arise, I won't be able to revert back to a working version of the site. Any recommendation before doing the upgrade? Will it really affect anything?

New member

Posts

Joined
Fri May 19, 2017 8:29 am

Post by rjcalifornia » Thu Dec 05, 2019 10:21 am

RideTheWave wrote:
Thu Dec 05, 2019 5:31 am
I installed OpenCart 2.3.0.2 about two years ago. Everything has been fine but I got an email from my server GoDaddy saying that I need to upgrade my cPanel/WHM due to a security issue. I haven't upgraded cPanel/WHM in two years so the upgrade would most likely be substantial. My cPanel/WHM version is currently 64.0 (build 29) but it says that version 84.0.16 is available for upgrade. So if I upgrade from version 64.0 to 84.0, does anyone know if this will affect any functionality in OpenCart 2.3.0.2? It says there's no way to downgrade after the upgrade so if problems do arise, I won't be able to revert back to a working version of the site. Any recommendation before doing the upgrade? Will it really affect anything?
Perform a backup of the site:

Files
Database

If possible, also generate a MySQL dump of your database, just to be sure. And be careful using automated backup tools.

It shouldn't affect your site upgrading cPanel/WHM, unless they also upgrade the entire server (PHP, MySQL, etc)

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by RideTheWave » Thu Dec 05, 2019 11:13 am

Ok, say I backup all the website files and the database. After upgrading the cPanel, if there is a problem, what do I do with those files and database? It says that I can't downgrade cPanel once I've upgraded. So once I've upgraded the cPanel, I'm stuck with it. How can a backup of those files and database be helpful if they don't work properly with the upgraded cPanel?

Is there any way to test it out first? Or does that require purchasing another server?

Does anyone know if the cPanel/WHM upgrade from version 64.0 to 84.0 affects any PHP or mySQL changes?

New member

Posts

Joined
Fri May 19, 2017 8:29 am

Post by thekrotek » Thu Dec 05, 2019 3:33 pm

cPanel/WHM has absolutely nothing to do with OpenCart. You don't have to do absolutely anything.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by RideTheWave » Fri Dec 06, 2019 8:33 am

If upgrading cPanel/WHM from version 64.0 to 84.0 changes anything with PHP or my SQL, then most likely it would affect the functionality of an OpenCart store. I'm currently using MySQL 5.5 and it appears that cPanel/WHM version 84.0 has removed MySQL 5.5 and replaced it with MySQL 5.6. So if I go ahead with the upgrade, will that cause the site to stop working properly since the MySQL versions won't match?

New member

Posts

Joined
Fri May 19, 2017 8:29 am

Post by EvolveWebHosting » Fri Dec 06, 2019 10:59 am

Is this a managed or un managed server? WHM / cPanel 64 was released almost 3 years ago so it's definitely time to get that upgraded. Once the upgrade is properly completed, Opencart v2.3.0.2 will run just fine. You're going to have to upgrade MySQL on the server as mentioned earlier along with EasyApache and other software for the server, depending on what you have installed.
Get a backup of your server and cPanel account and then begin the upgrade process. If the server is managed, have Godaddy do the work for you.
Once you're finished, set the upgrades to the 'release' tier. https://documentation.cpanel.net/displa ... references

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by thekrotek » Fri Dec 06, 2019 3:01 pm

RideTheWave wrote:
Fri Dec 06, 2019 8:33 am
If upgrading cPanel/WHM from version 64.0 to 84.0 changes anything with PHP or my SQL, then most likely it would affect the functionality of an OpenCart store.
Like I said, it won't.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 22 guests