Post by IP_CAM » Sun Dec 01, 2019 2:39 am

This modification will allow you to use the latest encryption functions that are available
in opencart 3.0.3.2 and let you install opencart at least 1.5.6.1 - 1.5.6.5_rc with php 7 Versions.
The installation is quite simple and just overwrite files. We preferred this approach because
the files are mostly useful to rapidly install opencart 1.5.6.4 with the latest version of php
with openssl and mysqli.

Some default OC INSTALLATION Files will also be changed, to enable a PHP-7 OC Installation of
OC v.1.5.6.x as well. For existing Installations, only the system/library/encryption.php
File needs to be replaced.
---
bnit.it mcrypt encryption replacement for opencart 1.5.6.4
https://www.opencart.com/index.php?rout ... n_id=38012

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by rjcalifornia » Sun Dec 01, 2019 5:37 am

let you install opencart at least 1.5.6.1 - 1.5.6.5_rc with php 7 Versions.
Neat! Thanks, will try it out!

Image


Active Member

Posts

Joined
Fri Sep 02, 2011 1:19 pm
Location - Worldwide

Post by IP_CAM » Sun Dec 01, 2019 7:59 am

Well, I only wrote(modified) parts of the Description above, because
they only mentioned v.1.5.6.4. The encryption.php file works
for any Version above 1.5.6 also. But the Italian Dev + Mod-Contributor
made a real nice Mod, by upgrading the Installation Routine as well.
So, it belongs here too! ;) :D
Ernie

I don't use Forum Mail, to reach me, contact: jti@jacob.ch
-
Server Q & A Basic Information on Code + Settings
http://www.everyauction.info/serverinfo.html
-
Demoversion OpenCart LIGHT v.1.5.6.5
http://www.jti.li/shop/
-
1'300+ FREE OC Extensions - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
-
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by xxvirusxx » Sun Dec 01, 2019 3:43 pm

1.5.6.4 work with encryption from 3.0.3.2.

I don't think is necessary to keep this function in his "mod"

Code: Select all

	private $key;
	private $iv;

	public function __construct($key) {
		$this->key = $key;
	}
	

Opencart 2.3.0.2 Bugs Fix Added | Opencart 2.3.0.2 Custom Version | Opencart 3.0.3.1 Bugs Fix Added


Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO
Who is online

Users browsing this forum: Bing [Bot] and 9 guests