Post by nixks » Thu Nov 07, 2019 5:23 am

Greetings everyone,

I am facing a problem where I get a 500 internal server error whenever I click on the input field to search for related products while I am creating a new one.
The autocomplete input does not work and no products popup. This only happens on the related products...All the above autocomplete inputs work just fine.

FYI I had a plugin regarding the related products which I removed to test if it was creating any conflict. Doesn't seem to be the solution either. And I didn't had any problems even after the installation of the extension anyway, it's something that happened all of a sudden.

I am posting the console log below also:

Code: Select all

jquery-2.1.1.min.js:4 GET https://mydomain.com/admin/index.php?route=catalog/product/autocomplete&user_token=RandomUserToken&filter_name= 500 (Internal Server Error)
Any help would be appreciated.

Newbie

Posts

Joined
Tue Jul 29, 2014 4:45 am

Post by letxobnav » Thu Nov 07, 2019 9:32 am

Code: Select all

https://mydomain.com/admin/index.php?route=catalog/product/autocomplete&user_token=RandomUserToken&filter_name=
user_token=RandomUserToken

Guess you did not remove it very well.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Active Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by paulfeakins » Thu Nov 07, 2019 6:57 pm

nixks wrote:
Thu Nov 07, 2019 5:23 am
route=catalog/product/autocomplete
Means /admin/catalog/product.php and a function called autocomplete.

It should be writing some sort of error to either /admin/error_log or the main system error log.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by cyclops12 » Sun Nov 10, 2019 5:30 pm

paulfeakins wrote:
Thu Nov 07, 2019 6:57 pm
Means /admin/catalog/product.php and a function called autocomplete.
It should be writing some sort of error to either /admin/error_log or the main system error log.
Surely this path cannot be correct ??

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by letxobnav » Sun Nov 10, 2019 5:39 pm

it is.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Active Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by cyclops12 » Sun Nov 10, 2019 7:02 pm

letxobnav wrote:
Sun Nov 10, 2019 5:39 pm
it is.
maybe admin/controller/catalog/product.php or language etc but not admin/catalog/product.php

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by letxobnav » Sun Nov 10, 2019 7:57 pm

that's how you call the controller.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Active Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by paulfeakins » Mon Nov 11, 2019 5:12 pm

cyclops12 wrote:
Sun Nov 10, 2019 7:02 pm
letxobnav wrote:
Sun Nov 10, 2019 5:39 pm
it is.
maybe admin/controller/catalog/product.php or language etc but not admin/catalog/product.php
Ah yes apologies I did miss the controller folder.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by cyclops12 » Mon Nov 11, 2019 6:14 pm

paulfeakins wrote:
Mon Nov 11, 2019 5:12 pm

Ah yes apologies I did miss the controller folder.
Haha thought I was going mad for a minute there Paul lol

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am
Who is online

Users browsing this forum: thekrotek and 17 guests