Post by Nordikota » Thu Sep 12, 2019 2:52 pm

Running OC3032 and Journal 3, on PHP 7.2.

Edit an option and try to save it I get the error message below. I can edit/save without issue if I don't add anything. But as soon as I add another option, the error below appears. It will not save the option or any of the changes.

Added max_input_vars = 50000 to the php.ini and the error message does not show, but when I edit an option, add an entry & try to save - it doesn't do anything. Just stays on the same page. If I cancel and re-edit, no changes are saved.

This appears to be only relevant for an option that has a large number of items in it. I have one option that needs 343 entries. Is there a limitation to this somewhere and can it be changed?



Code: Select all

Notice: Undefined index: option_value_description in admin/controller/catalog/option.php on line 393Warning: Invalid argument supplied for foreach() in admin/controller/catalog/option.php on line 393Notice: Undefined index: image in admin/model/catalog/option.php on line 44Notice: Undefined index: sort_order in admin/model/catalog/option.php on line 44Notice: Undefined index: option_value_description in admin/model/catalog/option.php on line 49Warning: Invalid argument supplied for foreach() in admin/model/catalog/option.php on line 49Warning: Cannot modify header information - headers already sent by (output started at admin/controller/startup/error.php:34) in storage/modification/system/library/response.php on line 36
Last edited by Nordikota on Sat Sep 14, 2019 12:56 am, edited 3 times in total.

Active Member

Posts

Joined
Tue Feb 11, 2014 8:04 pm

Post by Nordikota » Sat Sep 14, 2019 12:55 am

Limit is 252 items. Works OK until then. If you added 253, it doesn't work. In the absence of any ideas, we've had to split the options into smaller chunks.
We still get the occasional error when saving (not the same error). Seems really flaky for some reason!

Active Member

Posts

Joined
Tue Feb 11, 2014 8:04 pm

Post by letxobnav » Sat Sep 14, 2019 8:02 am

Apart from php, check your apache logs, could be post limitation or ssl buffer limitation.

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


Active Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan
Who is online

Users browsing this forum: No registered users and 29 guests